For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

After 200e firmware Upgrade, why I become unable to login with admin account ?


I'm doing a 200E firmware upgrade from v.5.1.1b to v.5.3.1b.

Using a telnet session, executed the firmwareDownload command and with a FTP server from the Server side, I've done successfully the Upgrades on both Partitions.

After the reboot, I've tried to logon with admin account but it says me that login/password is incorrect. On COM1 Port it says that "RBAC permission denied".

It says also that "there are stopped jobs".

I've tried all the known users/pawds, and all unavailable to logon except the user account .

With this user I can open the HTTP browser and the TELNET sessions. I've checked all the items and I see that theres a problem with the accounts, because they are not visible, for example, on the switchexplorer console ( Users list) it only appears user account ( maybe there's no permissions for user account to see admin,root and factory accounts).

I read that there's 2 possible things to solve this problem:

1. Reset Password through Serial port. Doing ESC and Reset Password. -> PROBLEM: on the 200E switch option for ESC didn't appear after reboot;

2. Downgrade from version 5.3.1b to v.5.1.1b and then disable the User Account, then doing again the Firmware Upgrade;

(for this one I need a privileged account for downgrade).

So, i'm stuck here. Any help or ideas will be very appreciated.

Best regards,

Filipe Quintino

Posts: 0

Re: After 200e firmware Upgrade, why I become unable to login with admin account ?


After some further investigation on this website and some others, I didn't found the root cause of the problem but found it the way to reset User/Password.

You will need:

     a) Serial Cable

     b) Serial Console Software (Putty)

     c) PROM Password

     d) printenv data (can take it from Command Shell option, before this operation).


The specific procedure for Password Reset on the Switch 200E:

Connect switch and PC with a serial cable on COM Ports (be attention with the connection if you are using a RJ45 cable with COM/RJ adapter connectors (some of these kits are doubled crossover and you will loose some time to discover it !!))

Then open a Serial Connnection Session ( for example with Putty ) with these configurations:

Speed (Baud): 9600bps

Data Bits: 8

Stop Bits: 1

Parity: None

Flow Control: XON/XOFF

After seeing boot happened on console:

1. Press ESCape Keystroke;

2. Choose option 3. Command shell

    1. Do logon with Boot PROM account, if NOT SET ON !!

  If a password it's defined, you need to put the password or ask to your provider or partner to supply one or a new one.

           2. After logon   

                     >boot <first memory address> -s    

                    >mount –o remount,rw,noatime /     

                   >mount /dev/hda1 /mnt   

                     >mount /dev/hda2 /mnt  

                      note1: Be sure that all OSRootPartitions are mounted (hda1,hda2...).     

                   Found OSRootPartition data on printenv data. 

                       note2: <first memory address> is on printenv data. for example: ATA()0xnnnn    

                    sintax: OSLoader=ATA()0xnnnn;ATA()0xnnnnn2;    

                               ATA()0xnnnn is the first memory address,ATA()0xnnnn2 is the second memory address.

      • The system is coming up, please wait...
        Checking system RAM - press any key to stop test 01a00000
        System RAM check terminated by keyboard
        System RAM check complete
      • Enter the passwddefault command, as follows:



                    sbin folder isn't on root folder, use cd and ls to find it.


                     This resets all account passwords to the default values. If there were additional user accounts created, they are
                         deleted and only the default accounts and passwords remain.


               3. Reboot the Switch

                         . >reboot –f command.

               4. Log in as root

               The process is now complete.

Best regards,

Filipe Quintino

Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.