For more details, please see ourCookie Policy.

Management Software

Posts: 0

Web tools no longer working

I had a perfectly fine working environment until I made the mistake of attempting to turn off the interopmode on my switches (original McData is no longer installed, so interopmode is not needed).  After changing my 48K director and one other ISL'd switch (Bladecenter 4020) to "interopmode 0", every ISL to the 48K became segmented (including 48K's ISL connection to the 4020 that also had interopmode turned off) and all zone configurations on the 48K were lost!!   "cfgshow" showed nothing defined, nothing effective. The Bladecenter switch did maintain a defined config, but no effective config.  So, on that fabric, all my servers lost connectivity to all disks (thank goodness for the other fabric).

So, after hunting for a solution, I re-enabled interopmode and issued the "configupload/configdownload" commands to restore a config file to the 48K (which is my core switch, by the  way) and thank goodness, everyone started to respond, ISL's were no longer segmented, zoning was in place.  Oh, happy day!!

So, here's the only problem outstanding:  My Bladecenter brocade will allow me to telnet in, but it the web tools do not work.  I don't get to the point of Java, I only get the familiar IE message "page cannot be displayed". 

Since I can telnet into the switch, is there some command that should be run to enable Web Tools?  The output of the "licenshow" command displays 3 licenses--Web license, fabric license & zoning license.  Any help (or ideas) is appreciated.

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: Web tools no longer working

Check please this DOC to restart HTTP Services

Posts: 0

Re: Web tools no longer working

Hi Abba,

Although I've never changed the root password, it has been changed on this switch.  I've logged into all of our other switches (about 7 total) and the root password is "fibranne", so there's no reason why "fibranne" shouldn't work on this switch.  But, it doesn't, so something else is wrong.

Without the root password, I won't be able to follow the procedure.  And, I can't change the password without downtime.

Here's the output from configshow "http":

http.lookupName:<switch IP address>

Update:  Thanks to kbrouwer, I was able to try one more password (PASSW0RD) for the root user, which worked!  Unfortunately, I don't have all of the options mentioned in the procedure, particularly the "HTTP Restart" option.  Here's the output of my procedure:

ACBC3SSM1:root> /fabos/libexec/webdconfigure
  http attributes (yes, y, no, n): y
        HTTP Enabled (yes, y, no, n):
        ErrorLog Enabled (yes, y, no, n):
        AccessLog Enabled (yes, y, no, n):
        SSLLog Enabled (yes, y, no, n):
        HTTP Port: (1..60000)
        Secure HTTP Port: (1..60000)
        HTTP IsAlive Check Enabled (yes, y, no, n):
Posts: 0

Re: Web tools no longer working

This problem has been resolved.  Here's what I did:

Working with the Blade admin, we decided  to power off the Blade switch.  We waited and waited, but it never came back  up.  So, we physically pulled it out and pushed it back into place.  When  it came up, I could telnet in, and when I ran the "switchshow" command, I say  that my ISL ports were segmented due to a zone conflict.  When I ran "cfgshow",  I saw NO defined configuration on the switch and the effective configuration was  about 2 months old!  I know this was not the case before, because I always run  "switchshow" and "cfgshow" when I have strange problems, and these looked  normal before.  That is why I focused on the http and Ethernet.
To fix the problem, I ran the following on  the Blade switch:  a)cfgclear b)cfgdisable c)portdisable/portenable (on the ISL  ports. 

And, everything came back perfectly, including http  access!  I guess my configs become out of sync when I turned off interoperability mode on the switch.

I hope this helps anyone else who experiences the same problem.

Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.