For more details, please see ourCookie Policy.

Fibre Channel (SAN)

Posts: 0

Is 48000 standby CP reboot disruptive

I have 2 x  Brocade 48000 director switches and I need to upgrade the FOS. The one switch had both CP's on 5.3.0b. The upgrade went without any problems. The other switch is a different story. One CP0 is on 5.0.1a and CP1 is on 5.3.0b. I don't know how this happened. I think that when the switches were installed the upgrade must have failed on the one CP0 and worked on the other CP1.

When I tried the upgrade I had the same problem. CP1 worked, CP0 did not. After lots of hours I found the problem. It was a ftp server problem. CP1 found the .plist file without any problems, but CP0 repeatedly said it cannot get the .plist.

Eventually I directly connected my laptop to the CP0 and setup a FileZilla ftp server on my laptop. This worked without any problems. I used firmwaredownload -s which only upgrades one CP. In this case CP0 is standby and CP1 is active. So I have found to a way to upgrade CP0 which is the standby.

Now my question: After I ran the firmwaredownload -s command, I selected not to reboot the switch after the frmware is downloaded. I was afraid the whole fabric would go down. Can I run the reboot command on the standby CP without desrupting operations on the 48000? Will reboot only reboot the standby or both switches? Will I loose connection on my hosts while the CP reboots.

I want to upgrade CP0 to the same as CP1 which is 5.3.0b and then run the firmwaredownload on the active, without the -s option, and continue to upgrade to 6.4.2b.I have already downloaded all the levels, v5.1, 5.2, 5.3......v6.4.

Any help would be appreciated.


Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Is 48000 standby CP reboot disruptive

If you connenct directly to the Standby CP and execute a 'reboot', only the Standby CP will reboot. The Active CP or hosts won't be affected unless there is another underlying issue in the switch.

Posts: 0

Re: Is 48000 standby CP reboot disruptive

Thank you for the reply Felipon. Yep I have tried this and successfully upgraded the Fabric OS on the 48000. The reboot only reboot the CP that I was on.

Thanks again.

Join the Broadcom Support Community

Get quick and easy access to valuable resources across the Broadcom Community Network.