IDMS

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  • 1.  Tech Tip: CA IDMS Missing Authorization for *DYNAM*.

    Broadcom Employee
    Posted May 01, 2018 12:49 PM

    Problem: 

    When trying to access a table or view or any other DB type entity, the following abend message is seen:

    SELECT * FROM SYSCA.ACCESSIBLE_TABLES;
    *+ DB005521 T7587 C-4M321: Missing authorization for *DYNAM*.

    What does this mean and in particular what is the meaning of the message component *DYNAM* in this case?

    Cause:

    When RESTYPE=DB is secured externally (SECBY=EXT), it is essential to also have TYPE=ENTRY entries in the RHDCSRTT assembly for the various DB sub-types. These sub-types are AREA, NRU, QSCH, NSCH, TABL, DACC and SACC.

    These entries must be there so that the central security system knows how to construct the external resource name for resources of each sub-type.

    The appearance of *DYNAM* in the DB005521 message (or any other value which does not obviously identify something in your environment) is an indication that no TYPE=ENTRY entry for the relevant resource type has been included in your RHDCSRTT assembly.

    Resolution:  

    Make sure that all of the DB sub-types are included in the RHDCSRTT assembly.

    The DB005521 may still occur but it will identify the entity for which the user does not have the appropriate authority.


    Additional Information:

    Administrating Security for IDMS - CA IDMS - 19.0 - CA Technologies Documentation 



  • 2.  RE: Tech Tip: CA IDMS Missing Authorization for *DYNAM*.

    Posted May 15, 2025 12:44 PM

    Problem:

    An external process (COGNOS) is trying to use ODBC to access IDMS database.

    Getting this error:

    Missing authorization for *DYNAM*.

    For background:

    We use COGNOS here to access an IDMS database. 

    COGNOS is moving to Version 12 and the cloud.  Currently COGNOS pulls data from IDMS using a Java Database Connection (JDBC) to a SQL Server than onto COGNOS.  IBM (our mainframe company) no longer supports the JDBC so our tech support is providing an Open Database Connection (ODBC) as a replacement.  The COGNOS team is receiving an ODBC error when testing this connection.  They met with tech support and believe the error is an access issue.  Below is the error:

     

    136 J=IDMP33 A=COGNOS1 TYPE=#IDMS RESOURCE=CV33.ODBC_INDEX
    Access Denied to #IDMS <CV33.ODBC_INDEX>
    Missing authorization for *DYNAM*.
    UserID Last-Used 08 May 25 10:33 System=MMA Facility=IDMP33

    *Note UserID replaces a real user id.

    Solution?

    We would we need to do some kind of setup in Top Secret to make this work ok?  We're stuck.