Fusion

 View Only

The Unofficial Fusion for Apple Silicon Companion Guide 

Nov 22, 2022 03:13 AM

This is the home of the latest version of the Unofficial Fusion for Apple Silicon Companion Guide.

Please report any inaccuracies in this content by messaging @Technogeezer.

If you have any questions about the content in the document, please post them as a thread in the Fusion Community.

This is version 28 of the Companion Guide. All earlier versions are superseded by this version. 

Statistics
1 Favorited
103 Views
1 Files
0 Shares
85 Downloads
Attachment(s)
pdf file
The Unofficial Fusion for Apple Silicon Companion Guide, v28   2.75 MB   1 version
Uploaded - Jul 03, 2024

Tags and Keywords

Comments

Mar 11, 2024 06:09 PM

  Did you try the GUI version of the tool first as noted in the Fusion documentation's procedure for building the VM that is referenced in the Companion Guide? You should only need to use the command line procedure if you're using Fusion 13.5.0 and running a macOS system language other than English. 13.5.1 fixes this issue.

It appears that copy/paste of the commands that are split across multiple lines in the pdf document isn't working as I expected it to. I apologize for that. Evidently the commands that are broken across multiple lines aren't getting pasted into the Terminal in the format that I expected - I only tried them from the source word processing document and they worked there. I'll see what I can do in the Guide to make them work better for users not familiar with Unix shell mechanics. 

To help you along, try using the following commands where I've done the editing for you. Copy/paste and execute them one-by-one in the Terminal (this assumes that we'll start the process from scratch with no ESD file downloaded and no Tools ISO file mounted. I've checked them myself and they seem to work.

hdiutil attach /Applications/VMware\ Fusion.app/Contents/Library /isoimages/arm64/windows.iso
/Applications/VMware\ Fusion.app/Contents/Library/vmw_esd2iso getesd --edition Professional --lang en-gb
/Applications/VMware\ Fusion.app/Contents/Library/vmw_esd2iso generateiso --esd 22631.2861.231204-0538.23H2_NI_RELEASE_SVC_REFRESH_CLIENTCONSUMER_RET_A64FRE_en-gb.esd --drivers "/Volumes/VMware Tools/svga,/Volumes/VMware Tools/vmxnet3"
hdiutil detach "/Volumes/VMware Tools"

If you're more skilled with the Unix shell, you can fix the commands so they work properly by::

  • copying and pasting each line of the split line separately, pressing return after each line pasted from the Guide,
  • pasting the entire split command, then editing the command line once pasted into the Terminal to be all on one line and remove the backslash "\" and the space next to it
  • manually typing the commands so they are on one line.

Mar 11, 2024 01:44 PM

hiya, im trying to follow this guide and im really confused about one detail

where it says

Create the ISO file from the ESD and include VMware video and network drivers (the

drivers will be installed by Windows setup)

and

The arguments to the --drivers option must be enclosed in quotes as noted above

because they contain spaces in the file names

im confused about this detail because im not sure if im meant to put anything after drivers and this whole step is just really confusing me

Screenshot 2024-03-11 at 13.44.10.png

Mar 01, 2024 01:55 PM

 if you report your results or have further questions on how shared folders work, please post in the main Fusion Community and not in this thread.

Thanks. 

Mar 01, 2024 07:09 AM

Got it thanks. My hope is to run a dropbox client (maestral) in a linux VM and have it sync on my OSX base system via these mounts. It would have been nice to have Windows native client as another option..oh well. Wish me luck...will post back with my results afterward

Mar 01, 2024 03:03 AM

 

The guide is still accurate.

Fusion folder sharing works for Linux when open-vm-tools is installed in the ARM Linux guest. The issue (with workaround)  in section 2.18 is because shared folders don’t  mount  automatically at Linux VM boot time by default.

Fusion folder sharing for Windows is (still) not implemented for Windows 11 ARM. 

Mar 01, 2024 02:03 AM

Curious... is file/folder sharing all good and working on the latest VMWare Fusion preview release now?

Section 15.11 in v25 of the guide seems to suggest that Windows folder sharing is still not supported, but according to section 2.18 linux folder sharing via fuse mount does work (with Arch Linux being the exception) but requires a small workaround.

Can anybody confirm any of this? Thank you.

Feb 09, 2024 10:03 PM

 thanks for pointing out the typos. It'll be fixed in the next update to the Guide.

Feb 09, 2024 04:47 PM

 there is a minor typo in the ubuntu instructions, need to remove the space after -- and ubuntu is spelt incorrectly at the end

kitenski_0-1707497238379.png

 

Jan 08, 2024 02:34 AM

 - the document is contained in the zip file that's an attachment to the first post in this thread.

Jan 08, 2024 01:14 AM

Where is the document exactly?

Nov 22, 2023 01:33 AM

 first and foremost, thank you for this incredible unofficial guide. I just got a M2 Mini with Sonoma and VMware Fusion 13.5.0, starting setting up a Windows 11 Home VM for testing, and *BAM* have been failing all afternoon to install VMware Tools.

Regarding your comment from Oct 28 about a bug that keeps the VMware tool from working in the GUI, this is not just for French users. I'm in the US, I just started this process for the first time today, and following your procedure above allowed me to install Windows 11 and VMware Tools.

Without the method described above, it is not possible to install VMware tools on a fresh setup of Win11 with Fusion 13.5.0. THANK YOU!

 

Here's what happened:

  1. I select "Install VMware Tools" from the Fusion menu in MacOS
  2. the CD mounts, I'm prompted for an autoplay action.
  3. the installer starts
  4. I get a "pop-up" from Windows asking me if I want the app to take action.
  5. I acknowledge that I do.
  6. And then the installer quietly terminates.

 

I've tried a variation of this. For example:

  1. Download the in-guest installer for VMware Tools.
  2. The install fails... I read VMware's release notes more carefully... I need a .NET installer of some sort. 
  3. I install the .NET installer (or so I think)
  4. I try to run the in-guest installer... it gets further, but still dies, this time with a different error message.

I should have taken screenshots, but I became exasperated.

 

By using your instructions above and specifying "en-us" as the language, I was able to get everything to work.

Point of note: in case anyone is typing out the pathnames to watch them auto-expand, you have to watch out for the backslashes that the shell will add in. For example, take the line below:

 

 

 

If you started typing "/Volumes/VMwa<tab>" to auto-expand the path, you'd get this:

 

 

 

If you leave that backslash in, the shell will not send the correct input into the command and the ISO creation will fail. Remove the backslashes, or better yet, don't be clever, and just copy/paste the exact text specifying the two driver paths.

 

Below is a copy/paste of my session to see what happens when you goof by 1) mistyping the language specification and 2) adding a backslash into a quoted pathname.

 

 

 

 

So to tie this all together:

  1. Create a new ISO using the instructions above.
  2. Install a new version of Win11 using the ISO you just created.
  3. After you are logged into Win11, select "Install VMware Tools" from the menu and it will now work.

 

I'm super happy just to see copy/paste working again from the host to the guest.

Oct 28, 2023 10:51 PM

It looks like there's a bug that keeps the VMware tool in the GUI from working. I've heard that reported for French, but it may be a problem for other languages.

You can generate the ISO using the command line version of the utility. Drop into a terminal session and use the following commands to mount the VMware Tools ISO from the Fusion application (that's where the video and network drivers are found that are used in the ISO build process), download the French version of the Professional ESD, generate the ISO based on the downloaded ESD, and clean up everything except the ISO when finished.

cd Desktop
hdiutil attach /Applications/VMware\ Fusion.app/Contents/Library/isoimages/arm64/windows.iso
/Applications/VMware\ Fusion.app/Contents/Library/vmw_esd2iso getesd --edition "Professional" --lang "fr-fr"
/Applications/VMware\ Fusion.app/Contents/Library/vmw_esd2iso generateiso --esd ./22621.1702.230505-1222.ni_release_svc_refresh_CLIENTCONSUMER_RET_A64FRE_fr-fr.esd --drivers "/Volumes/VMware Tools/svga,/Volumes/VMware Tools/vmxnet3"
hdiutil detach "/Volumes/VMware Tools"
rm  ./22621.1702.230505-1222.ni_release_svc_refresh_CLIENTCONSUMER_RET_A64FRE_fr-fr.esd

The ISO file should be on your desktop.

fr-ca (Canadian French) would be a similar process, except use fr-ca instead of fr-fr in the above commands.

 

Oct 28, 2023 07:24 PM

Great guide. I am using VMWare Fusion Player the French version. When I tried to create a Windows 11 VM with the VMWare tool the download doesn't work. I receive the following message: 

L'outil Esd2iso n'a pas pu obtenir l'URL ESD et l'algorithme SHA pour la version Professionnel de Windows 11 pour la langue en-us à partir de Microsoft.

The same message appears when I choose the fr-ca language.

I have a Visual Studio M2 Mac running Ventura 13.5.2.

Thanks for any help you can provide.

Oct 22, 2023 08:57 PM

No worries, I luckily managed to download the desktop image a few days before they pulled it, so for now I'm good. As a sidenote, one thing I noticed is that the choppy audio (which was mentioned in the tech preview under point 2.16) can also be fixed in Ubuntu by setting the audio to 4.0 in audio settings in Ubuntu without having to modify any config files.

As for Win11 issue with encryption, it's a shame VMware completely abandoned the subject. I noticed that not only was I unable to upgrade the encryption but also couldn't change the password for encryption even under 13.0.2 (which was also mentioned as one of the complaints on here). The only option was to build a completely new VM and do a fresh Windows install, which lead to another issue of being unable to activate Windows. Eventually I found a useful hint online which allowed me to copy two parameters from old VM (with the encryption problem) to the new one and make the new VM seem like it's an old one, from hardware perspective. Massive ballache to be honest, but you don't look a gifted horse in the mouth, I guess (that said I believe that paying customers of VMware products have the same issue, so...).

The parameters, in case anyone wonders, are:
uuid.bios
uuid.location
I also copied over the MAC address (directly under VM settings, not in the config), just to be on the safeside.

Once the VM is started you'll get a prompt asking if you moved or copied the VM, "moved" does the trick and makes Windows think it's the same "PC".

Oct 22, 2023 01:23 AM

Drat and thanks for the heads up on the Mantic daily development build.

Canonical just doesn't seem to care about arm64 Desktop except for one special build for a Lenovo X13s Gen 1 PC t(hat appears to have a Qualcomm Snapdragon CPU) and Raspberry Pi's. I tried the Lenovo build on Fusion and it won't boot - so there's something that they've done with it (something with secure boot keys for that specific hardware perhaps)

If you want the equivalent of Ubuntu Desktop. install Server and then use the procedures in the Companion Guide to "convert" to Desktop. All of my Ubuntu "Desktop" VMs have been created in that manner and they've all worked and updated without problems. 

Oct 21, 2023 10:38 PM

 

Thank you for taking time to maintain these guides. You're a legend.

A couple of points to note regarding recent release:

1) the link to Ubuntu 23.10.1 (Mantic Minotaur) Desktop daily development build stopped working when they officially launched during this month. I can't find any links to daily builds for desktop Mantic Minotaur so to me it looks like there's no way to install desktop for arm at all anymore.

2) this issue https://communities.vmware.com/t5/Fusion-2023-Tech-Preview/quot-Unable-to-reencrypt-the-virtual-machine-Disk-problem-quot/td-p/2977309 HAS NOT BEEN FIXED. So anyone with W11 hoping that the final release of 13.5 is safe to use, should think again and consider not upgrading since the only way to correct this is to build a new W11 machine, apparently if we keep declining that will cause other issues (as per one of the posts in the quoted thread).

Oct 20, 2023 12:48 AM

Heads up - According to  the next version of Fusion (a free update to Fusion 13 users) should be released to the public starting at 20:30 PDT on 2023-10-19. I would not at this point attempt anything new with Fusion 13.0.2. The 2023 Tech Preview is also on the cusp of becoming obsolete when the new version is released, so I'd avoid any new installation of it. 

I personally don't expect any major hiccups with the new Fusion version since the Tech Preview it's based on has been very stable. Hopefully the (relatively few) issues found by the testers of the Tech Preview have been addressed. 

I'm in the process of editing the Companion guide for the new version of Fusion. For you early adopters, use the 2023 Tech Preview Companion Guide as an interim guide since the next Fusion version is based on the features found in the Tech Preview.

No guarantees, but my goal is to get the new, improved Companion guide out the door on Sunday 2023-10-22. At which time the Tech Preview Companion Guide will be removed.

Oct 15, 2023 06:28 PM

New to this list.  Mac Guy since 1984.  VMWare user since 2017.  

Thanks for publishing this document, IMHO it is rather exceptional support by the VMWare organization and especially the people contributing!

I have gone thru the process and successfully installed Windows 11 ARM on a 2023 MacBook Pro M2... and will also install on an early Mac mini M1.

I have limited Windows experience and would appreciate some guidance on what to install, what to test, and how to provide feedback.

   Unofficial Fusion 13 for Apple Silicon Companion Guide

   Unofficial Fusion 2023 Tech Preview

Mmm... Which list would would best help advance VMWare?

Oct 15, 2023 05:43 PM

New to this list.  Mac Guy since 1984.  VMWare user since 2017.  

Thanks for publishing this document, IMHO it is rather exceptional support by the VMWare organization and especially the people contributing!

I have gone thru the process and successfully installed Windows 11 ARM on a 2023 MacBook Pro M2... and will also install on an early Mac mini M1.

I have limited Windows experience and would appreciate some guidance on what to install, what to test, and how to provide feedback.

Oct 08, 2023 07:10 PM

 

That error message shouldn't appear with Fusion 13. It will appear with Fusion 12 as it's not built to run on M1/M2 Macs. Really double check what Fusion version you have installed. What does it say when you open Fusion and then click VMware Fusion -> About VMware Fusion from the menu bar?

Delete all vestiges of Fusion from your laptop by using the information in KB article https://kb.vmware.com/s/article/1017838. Don't just drag the Fusion application to the trash, there's more to get rid of than just the application for a complete uninstall. Pay special attention to where the files are located:

  • /Library is the system-wide Library folder. Use the Finder Go -> Go to Folder.. and then type in "/Library" to find the files starting with /Library
  • ~/Library is the user's "Personal" library folder located in the user's home folder. Use the Finder Go -> Go to Folder.. and then type in "~/Library" to find the files in the KB article starting with ~/Library

Then, re-install Fusion 13.0.2 or (preferably) the Tech Preview available at  VMware Fusion Tech Preview 2023 Universal DMG.

If you have verified that you are running on Fusion 13 or the 2023 Tech Preview and the license key isn't working, then you may not have a Fusion 13 license key. You can sign up for a free Fusion 13 Player personal use license key at https://customerconnect.vmware.com/en/evalcenter?p=fusion-player-personal-13

A license key for Fusion 13 will work on both Fusion 13 or the 2023 Tech Preview.

Oct 08, 2023 06:00 PM

Hi,

Sorry if this has been mentioned elsewhere but I've been trying to get VMware to work on my M1 MacBook Pro for the past week (I am completely new to VMware and accessing vms in general, I'm normally used to using my university's vms). I keep getting the same error message of "

This version of VMware Fusion is for Intel-based Macs, but is being run on an Apple silicon based Mac via Rosetta-2.

See KB-84273.

Then after clicking 'ok',

Transport (VMDB) error -14: Pipe connection has been broken

"

I have reinstalled v13.0.2 countless times, used v13.0.0 and v13.0.1 countless times, still nothing.

I have tried to use the 2023 tech preview, however it never accepts my license key so I don't even get past the installation wizard. 

Really stuck on what to do, not sure if its VMware or my iso i am trying to use (Ubuntu v20.04.5)

Oct 04, 2023 02:59 AM

Thank you!

Oct 04, 2023 12:58 AM

 In general I would not rely on in in-product notification. Past major versions of Fusion would let you know that a new major version had been released, and if memory serves me a minor update just may be offered  for installation. I'd keep watch of the forums and VMware's Fusion product page for the official announcement. Then download the release installer from VMware and run it when you're ready. And that means when you've read the release notes and have all your virtual machines shut down and copied to another media. These are best practices for any software upgrade, and no negative comment intended on the quality of the next Fusion release - which I think will be pretty solid based on the Tech Preview. 

The version should install on top of your existing Fusion implementation (just like other updates/patch releases). The contents of your VMs won't be touched until you open them on the next Fusion version. You may be asked to upgrade the encryption algorithm (I'd do that) and the virtual hardware version to 21 (I'd do that). Then upgrade the VMWare Tools with the version included with the release and Windows 11 should now have copy/paste/drag/drop and other goodies missing from Fusion 13. 

Oct 01, 2023 05:09 PM

I have had Windows 11 ARM working smoothly for quite a while under Fusion Player 13.0.2, including now under MacOS Sonoma 14.0, thanks to 's guide and some personalized help. I have a simple question now that maybe there is no simple answer to.

I don't want to mess with my smoothly working setup by moving up to the Tech Preview, but I would like to have VM Tools completely working (copy/paste, etc.).

When VMware gets around to fully releasing a non-tech-preview version of Fusion, will my current set-up be notified through Fusion and be able to update to it smoothly and end up with a fully operational version of it? (Or am I going to have to start over with the fully operational update?) Thanks! (If you know.)

Sep 02, 2023 08:14 AM

Thank you so much for sharing this ! Very useful and saved me loads of time

Aug 29, 2023 08:34 PM

 - are you trying to change the size of the console display by resizing the Fusion window or switching to full screen display? If so, that only scales the size of the window at the same resolution. That would contribute to making the display blurry since the Windows 11 ARM video drivers shipped with Fusion 13 don't change the resolution when using either of those methods. The only way to change console resolution is from within the Windows 11 VM (Settings > Display). And even then, the available resolutions are limited. That's discussed in the Companion Guide.

You might wish to try the 2023 Fusion Tech Preview - it has much better Windows 11 ARM support in its tools - and the driver and tools do support resolution change by resizing the window and/or going to full screen.

 

Aug 29, 2023 08:16 PM

I'm running Windows 11 Arm and the display is pretty blurry. I'm wondering if there's a way to make it clearer without having to make the window really small since that isn't a good trade off.

Jul 27, 2023 01:38 PM

If you are using the Tech Preview, a version of this document specifically for the Preview has been created. You can find it at:

https://communities.vmware.com/t5/Fusion-2023-Tech-Preview/The-Unofficial-Fusion-2023-Tech-Preview-Companion-Guide/td-p/2977869

Jul 27, 2023 08:20 AM

short note:

new Tech preview of VMWare Fusion has been released, which besides 3D support now includes also drag/drop & copy/paste between Apple Silicon Host and Win11-arm Guest:

https://blogs.vmware.com/teamfusion/2023/07/vmware-fusion-2023-tech-preview.html

download:

https://customerconnect.vmware.com/downloads/get-download?downloadGroup=FUS-TP2023

(already tried drag/drop on Apple M1 Mini, running smoothly!)

Jul 24, 2023 04:14 AM

And what are you trying to do in the guest?  I've noticed that even the tech preview is more sluggish with certain operations than 13 (I strongly suspect it's due to the 5K monitor now being fully utilized, and 3d drivers that still need some optimization.

One note - would strongly suggest building a new guest from scratch using the instructions in this guide.  I had a  lot of pretty severe graphics artifacts, and other oddness when trying to upgrade from 13 to the TP (I suspect some of the manually installed drivers weren't properly removed).

Jul 24, 2023 12:47 AM

It's not the reported CPU frequency that is causing "sluggishness". The CPU frequency reported by Windows is irrelevant.  macOS does not always run its cores at their highest speed. It adjusts both the CPU frequency and type of core (performance vs efficiency) for each virtual CPU that's being run by your Windows VM (and seems to do a much, much better job than Microsoft/Intel does on Alder Lake CPUs). From anecdotal evidence it seems to prefer the performance cores when running Fusion.

"feels sluggish" is a subjective term. What feels "sluggish"?

Some thoughts:

  • What is the load on your host Mac when your VM is running? 
  • How much memory is on that MacBook, and what is the memory pressure as reported by the macOS Activity Monitor
  • Where are you running the VMs from (the Mac's SSD disk or an external disk)?
  • Are you running any AV solution that's scanning the virtual machine. If so, configure your AV 

You might want to try the 2023 Tech Preview - it now supports 3D acceleration that might make the UI seem "more responsive". 

Jul 23, 2023 10:47 PM

Is there some way to adjust the CPU frequency in a Windows host?  My Windows 11 guest thinks the CPU is 2.0 GHz.  I'm running on MacBook Pro M2 which should be 3.5GHz.  The guest OS feels sluggish.Screenshot 2023-07-23 at 3.48.14 PM.png

Jul 05, 2023 08:55 AM

Dear   and  , Dear All,

thanks a lot, it works!!!

I am using both VmwareFusion 13.0.2 Pro with Win11-arm-Pro and after several trials (including to add own NAT configuration although not sure if was required (?) I am able to access now Win11-pro with Microsoft Remote Desktop, which includes sharing folders from Mac.

Kind regards and thanks for support, great community!

Stork

 

Jul 03, 2023 05:33 PM

, see AFerrit's answer, above.

Jul 03, 2023 09:09 AM

To the best of my knowledge, the procedure to enable remote administration is exactly the same as any other windows 11 PC.   There's nothing special here about it being on an ARM system, which is largely the point of this guide.  You enable remote desktop in the control panel.

AFerrit_0-1688375265866.png

As regards networking, I found this Github Gist which is remarkably useful for giving ANY host a static IP when it's on my mac: https://gist.github.com/pjkelly/1068716/921c8b62ca07e29a7312e81e7b2efa88b69858ab

This is also not specific to the ARM version of Fusion or MacOS.  I think you're looking for more generic advice, but I hope these help

 

Jul 03, 2023 06:45 AM

Dear All and  ,

would it be possible to post or send a link with detailed step-by-step instructions on how you connected with WindowsRemoteDesktop to Win-11-arm (incl. NAT configuration [if required?], selection of IP addresses and correct writing of username etc)?

I am honestly not very advanced with network settings and currently stuck with file transfer between MacOS host and Win11-arm guest on VMwareFusion 13 Pro, with the infos contained in the links below I was able to create new network adapter but was not able to proceed further.

kind regards and many thx!

Stork

 

https://kb.vmware.com/s/article/1018809

https://docs.vmware.com/en/VMware-Fusion/13/com.vmware.fusion.using.doc/GUID-7D8E5A7D-FF0C-4975-A794-FF5A9AE83234.html

 

Jun 30, 2023 11:57 AM

I needed to convert my aarch64 openSUSE VM on Parallels 18 to VMWare Fusion 13. Searching Internet didn't provide a straightforward answer, but I found hints.

So I was eventually able to succeed in doing it.

Just wanted to post how I did it if anybody else is searching for the same. Possibly this would work for other distros as well, such as Ubuntu.

---

Clone the Parallels opneSUSE VM (so that all snapshots and Parallels guest tools can be removed without disturbing the existing VM)

Delete all VM snapshots in the clone.

Start the cloned VM and remove Parallels tools in the clone.

Turn off VM.

You will need Homebrew (https://brew.sh/) installed on the Mac. And the package 'qemu'.

$ brew install qemu

Open a terminal and cd to Parallels VM directory where the VM .hds file is located, e.g. in my case:

$ cd $HOME/Parallels/openSUSE.pvm/openSUSE-0.hdd
$ qemu-img convert -f parallels "openSUSE-0.hdd.0.{5fbaabe3-6958-40ff-92a7-860e329aab41}.hds" -O vmdk -o compat6 opensuse.vmdk

This .vmdk file can be used to create a new virtual machine in VMWare.
Move it to keep in somewhere reasonable location.
Or transfer to some other Mac (preferably using rsync).

In VMWare Fusion:
File > New
Create a custom virtual machine.
Choose the appropriate Linux version. (In my case 'Linux > Other Linux 5.x kernel 64/bit Arm')
Use an existing virtual disk. (Pick the .vmdk file created from the qemu-img command above).

The new VM will initially not boot. But it will contain all settings and all apps from the previous installation.

Now you can repair the installation (or in my case, upgrade to the next release 15.5). Because openSUSE 15.5 just had been released and my existing VM was 15.4 it was only a matter of upgrading to the new release. Alternatively I could possibly have used the same release DVD to "upgrade", but that would initially have downgraded all packages to the release versions.

You need the installation DVD:
https://download.opensuse.org/distribution/leap/15.5/iso/openSUSE-Leap-15.5-DVD-aarch64-Media.iso.

Download and mount the DVD in the VM that you just created.
VM > Settings > Removable Devices > CD/DVD
- Tick 'Connect CD/DVD Drive'
- Select the downloaded DVD ISO image

Make sure to change to boot order to boot from the installation DVD.
VM > Settings > Other > Startup Disk > CD/DVD

During upgrade it was possible to modify the URLs and keep the repos that I already had. So I could keep almost all extra packages that I had installed. After upgrade finished almost all apps were kept and almost all settings.

Another possibility, that I never had to explore since I did the upgrade route, would have been to try an actual repair as described here: 'https://forums.opensuse.org/t/repair-a-broken-uefi-grub2-opensuse-boot-scenario/129018'

---

Jun 29, 2023 07:44 PM

Thank you for confirming!

Jun 29, 2023 01:21 PM

Just FYI. I asked about File History in the Microsoft Community forums. The answer I got was that they haven’t implemented File History yet for Windows 11 ARM. So I guess there’s nothing to do to get it to work other than wait for Microsoft. 

Jun 28, 2023 05:27 PM

You might want to ask this to Microsoft. It does appear that Microsoft "forgot" to include it in Windows 11 ARM (and I'm running their official releases, and not a bets or :insider pre-release. 

It would be interesting to see if a Parallels user has the same issue, because the installation source for their Windows 11 is the same as what we recommend for Fusion.

Jun 28, 2023 03:17 PM

I've noticed that FileHistory does not exist on Win11 on Apple Silicon (M1). Anyone know how to add it?

Jun 25, 2023 04:52 PM

Bravo on all the hard work to help our community.

May 26, 2023 10:17 PM

Maybe this was obvious to everyone else but me, but the workaround for the lack of copy/paste in Fusion is . . . Remote Desktop! I just RDPed into my WinARM11 instance, and I can copy/paste!

I can't believe it took me this long to stumble upon it. 

May 21, 2023 09:45 PM

Techogeezer ... that works, downloaded and installing now ... Thanks! 

May 21, 2023 09:42 PM

Quick question, has anyone tried to install arch? I get kernel panics after the installation. I have an archboot iso (archboot-2023.05.10-04.07-aarch64.iso) but I can't get it to work

May 21, 2023 09:07 PM

Please see the Companion Guide that's available at the top of this thread. It will guide you on how to create an ISO for Windows 11 ARM because Microsoft in its infinite wisdom (sarcasm) doesn't deem mere mortals as worthy of downloading an ISO for Windows 11 ARM. The generated ISO is (currently) the Windows 11 ARM 22H2 22621.1702 Public Release build (a.k.a. "the real thing" -  not a Release Preview, Beta, Dev, or Canary channel build) .

For an enterprise edition license, you probably will want the Enterprise edition ISO of Windows 11 ARM. Use the instructions in the Companion Guide to download and execute a utility that will create the ISO for you, but where it instructs you to execute a command to build the ISO, use the following command line instead:

./w11arm_esd2iso -b en-us

The -b option tells the utility to create an ISO containing Windows 11 ARM Pro and Enterprise editions instead of Home and Pro editions. 

May 21, 2023 08:41 PM

Technogeezer ... I see my error, I've downloaded the x64 ISO, not the ARM ISO ... I can't find the ARM iso ... any ideas how to locate it? I don't want the windows insider build, want the full version ISO for my license key. 

May 21, 2023 08:38 PM

Technogeezer, thanks for quick reply  .... I don't get the 'press any key ..."  timeout message ... just immediately goes to PXE error. 

Have tried to change boot manager order, by getting to the BIOS while it's booting by pressing F2 ...  the bios manager comes up, I change the boot order so the CD is ahead of the Network adapter. But still get PXE message. It doesn't seem to see the CD which is linked to the ISO file.

May 21, 2023 08:29 PM

You should not need to change the boot order if you have the virtual CD/DVD device connected to the VM and the device configured for the ISO file before you power it up. Double check your VM's settings with the VM powered off and make sure of that. 

On power up, you should see a message before the PXE boot message saying:

"Press any key to boot from CD or DVD"

You MUST click in the VM's console window and press any keyboard key before that prompt times out (about 5 seconds) or the ISO installer will not boot.

 

May 21, 2023 07:42 PM

Can't boot ISO ... still get error below, after connecting to ISO file, per all previous comments in this thread:

>>>Start PXE over IPv4.

I'm using ISO file:

22621.1702.230505-1222.ni_release_svc_refresh_CLIENTCONSUMER_RET_A64FRE_en-us.iso

Have tried to change boot manager order, by getting to the BIOS while it's booting by pressing F2 ...  the bios manager comes up, I change the boot order so the CD is ahead of the Network adapter. But still get PXE message. It doesn't seem to see the CD which is linked to the ISO file. 

I have a MacBook Air m1 ... no idea. I do have the parallels windows insider file I've converted for the windows insider program, but want a clean, upgradable fresh install, for my Windows enterprises license. 

Any ideas? I'm completely stuck.

May 15, 2023 04:50 AM

Hey Technogeezer -- Since we can't copy and paste yet between windows and mac (Why?!), if we need to use our iCloud passwords in safari, we need working iCloud in the VM.

I've had some trouble getting the iCloud for windows control panel running.  It's a bug I plan to report to apple, but it's installed via the windows app store, which doesn't do proper dependency checking, so the install process will crash and burn with errors like this:

AFerrit_0-1684125985070.png

AFerrit_1-1684126076523.png

AFerrit_2-1684126089474.png


If you install the Visual c++ redistributable files (linked from here: https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170, iCloud will now work under windows 11 ARM.

(I've seen several people complaining on the mac forums, but the posts were too old to reply to).

I've got my own post about this all over at my medium page.  (gushi.medium.com)

May 13, 2023 11:41 PM

This guide is pure gold! An infinite THANK YOU. Please continue to keep it updated as you are doing! It's way too precious.

May 10, 2023 05:40 PM

Thank you! You did a really good job on this.

May 10, 2023 03:50 PM

Thank you for this guide. It was the only document that allowed me to get a working Windows 11 VM in my M1 mac. Your efforts are very appreciated!

May 09, 2023 05:59 PM


Why does Canonical not provide a GA Ubuntu Desktop? Do they get money from Intel? Is there some Apple legal reason?

That is a very good question and you would have to ask Canonical. There is nothing that Apple or VMware has done to block Canonical from releasing a Ubuntu Desktop for ARM.  It’s strictly a Canonical decision not to do it for anything other than Intel. 

May 09, 2023 05:48 PM

I've never seen a company as hostile to a user community as they are.  From regressions, to disappearing release files, to inconsistent support, it's a wonder that they're as popular and successful as they are.

To be fair, ARM desktop is a niche of a niche product, so it's probably a cost/benefit tradeoff, but even for the server all the other issues exist.

May 09, 2023 05:24 PM

Consider this statement from the guide.

"Canonical does not provide a GA (generally available) version of Ubuntu Desktop for ARM architectures. They only provide Ubuntu Desktop for Intel/AMD architectures. The only official GA releases that you will find for ARM are for Ubuntu Server."

Why does Canonical not provide a GA Ubuntu Desktop? Do they get money from Intel? Is there some Apple legal reason?

May 05, 2023 11:37 PM

 Yeah, I might've been around the block once or twice Working on getting the rest of the Hashicorp stack integrated, then I'll start on more complete documentation.  It looks like things have gotten past the cusp of automated usability in the last day or so!

May 05, 2023 08:08 PM

 Both of the configurations you state are out-of-the-box defaults for Fusion VMs created through the traditional GUI-based mechanisms. Sounds like you're a more advanced user that's automating deployment.

I'm not very conversant on the use of chef/packer/Vagrant so I'd like to include content that's somewhat intelligible.  If you can provide some additional content (you can PM me with a draft of what you'd like to see included), I'd be happy to include them in the Companion. 

May 05, 2023 06:53 PM

 Could you add a note about...  Specifying E1000E rather than e1000; and ensuring USB is enabled to enable keyboard/mouse (even over VNC)?  Ref  https://github.com/chef/bento/pull/1499 https://github.com/chef/bento/pull/1500 https://github.com/chef/bento/pull/1501 

There's also some minor stuff about tweaking over to SATA if using standard packer templates (probably to become more popular over the next few weeks now that Packer/Vagrant is going to be working for VMWare) - that's pretty minor - https://github.com/chef/bento/pull/1494/files

Mar 27, 2023 04:02 PM

It's definitely a hit - you'd be better off with an iPad, but it's a whole lot better than intel.

Mar 27, 2023 03:35 PM

Just wondering if anyone has a view on the impact of battery life running Windows 11 on Fusion on a M1 Macbook Air with 16gb memory?

I'm wondering if a way to get Netflix offline in Macos for use on planes etc is to run it inside Fusion!

Mar 25, 2023 10:13 PM

 - you are very welcome. I'm glad that the Companion Guide was able to help you out. 

Mar 25, 2023 09:43 PM

Thank You for your Document to install WIN11 ARM with Fusion on my Macmini ARM.

Greets from Bavaria 

Stetech

Mar 25, 2023 12:16 AM

WSL1 works fine in a Windows 11 ARM VM. WSL2 does not because of the nested virtualization.

Mar 24, 2023 10:46 PM

Thanks for this very helpful document.

WSL is a no go because of no nested virtualization

Mar 21, 2023 10:27 AM

Thank You 

Mar 21, 2023 02:32 AM

Thanks Technogeezer. Sure. I created it for the community. 

Mar 21, 2023 02:28 AM

This video is FABULOUS!   

May I post a link to it in the Companion Guide?

Mar 21, 2023 02:12 AM

Hi all, I posted video tutorial on YouTube that may be helpful for some. I still highly recommend you follow the documentation as well. https://youtu.be/A1Na0n65DY8

 

 

Mar 15, 2023 07:56 PM

  OK Thank You I will continue to research ALL because APPLE ##### we all have too jump though hoops.

Mar 15, 2023 06:09 PM

 it was primarily a response to  but that was in reply to your question about using that Sonnet device with a Windows 11 ARM VM. 

If the device can be seen from Windows as a USB device and the drivers are loaded in the Windows VM, then there's a chance things might work as Fusion is not involved in the video display. One thing, though, is that I've heard of issues with some types of USB devices not working with Fusion's USB pass through. I don't know if that will apply to what you want to do with the Sonnet DisplayLink adapter, though.

If I had one of those I'd try it out for you, but I don't have either the displays nor the device to do so...

 

Mar 15, 2023 05:35 PM

Was this for me Tinker1954.

 
@ColoradoMarmot If the device is seen attached to the guest via USB with USB drivers for it in the guest for it, it just might work as Fusion's not doing the graphics work. It'd be the dongle plus its USB drivers. It kind of would depend on if Fusion really passes through the USB device completely to the guest. 

Mar 14, 2023 09:34 PM

 Could you start a thread in the VMware Fusion Discussions forum on this and attach a copy of the VM's configuration (.vmx) file?

 

Mar 14, 2023 09:23 PM

That's the right iso. Are both Secure Boot and the TPM devices available for the VM (check the Settings of the VM).

Mar 14, 2023 09:23 PM

The ISO has the old version of Windows. I will have to re-create it. 

Screenshot 2023-03-14 at 5.21.42 PM.png

Mar 14, 2023 09:09 PM

I'm not sure what build. I followed the steps in the document and an iso named: "22621.525.220925-0207.ni_release_svc_refresh_CLIENTCONSUMER_RET_A64FRE_en-us.iso" was generated. That's what I used to install. Did I do something wrong? 

Mar 14, 2023 08:56 PM

 If the device is seen attached to the guest via USB with USB drivers for it in the guest for it, it just might work as Fusion's not doing the graphics work. It'd be the dongle plus its USB drivers. It kind of would depend on if Fusion really passes through the USB device completely to the guest. 

Mar 14, 2023 08:51 PM

Make sure you have configured both Secure Boot and the Trusted Platform Module device. Windows will refuse to install unless you have both of these.

(Use the Fusion encryption option to encrypt only the files needed to support a TPM device. There's no need to use the option to fully encrypt all the files of the VM).

Mar 14, 2023 07:06 PM

Did you use the new system to create the ISO or the VHDX?  If the latter, that's probably why (it's an insider build)

Mar 14, 2023 06:21 PM

Thanks for the instructions. I was able to create the ISO and created a VM with 4 cores, 12GB ram, 80gig, using a MacStudio (base model) host. Once I get passed the section to "Activate Windows", I get message saying that "This PC can't run Windows 11" See attached. I've rebooted multiple times, I've skipped the product key, I've entered a product key, Ive selected the "Home" and "Pro" edition. Keep getting the same message. Any body have this issue?

Screenshot 2023-03-14 at 2.18.58 PM.png

Mar 14, 2023 05:23 PM

I would try this on an intel machine first.  I suspect that it simply won't work because of how Fusion does graphics (it handles it on the host, and doesn't support multiple host monitors, let alone a hack inside a guest).

One workaround would be to run multiple guests, and put one window on each of the screens running on the hots.

Mar 14, 2023 05:06 PM

You should be able to determine from Device Manager in the Windows VM if the USB devices are recognized after "connecting" them through Fusion.

I went to Sonnet's site and found a driver download for the device. The release notes indicate that they have a drivers for

E. Supported Operating Systems
==============================
This release can be installed on the following operating systems:

- Windows 10 (S) v1607 and later (64-bit of Intel/AMD)
- Windows 10 & 11 (S) (64-bit Qualcomm Snapdragon and Microsoft SQ2) via INF package only
- Windows 11 (64-bit of Intel/AMD)

The Snapdragon and SQ2 are ARM processors. This indicates to me that they have drivers for Windows 11 ARM. 

Mar 14, 2023 04:40 PM

Yes I reviewed CG again just now. THANK YOU for your reply! I do have the USB version sonnet tech I see now that Win11 Arm may have an issue. I'll send that question (drivers) to sonnet tech support. They have always been helpful, I bought the units directly from them. So it appears System Ready isn't ready yet! Technogeezer THANK YOU   FJC

Mar 13, 2023 09:44 PM

 Did you read the Companion Guide? There’s a pretty comprehensive list of the things that are NOT implemented in there, and multiple monitor support is one of them.

If you have a USB version of the Sonnet device, it *might* be able to be passed to the VM but you’ll have to see if Windows 11 ARM will recognize it and if it needs any drivers since. 

As to whether Fusion will deliver multiple monitor support in the future, VMware does not comment on the content of future releases. 

Mar 13, 2023 08:23 PM

Bear with me Please I need to know can I use multiple displays with Fusion 13? I have a Mac desktop MI; I have 2 sonnet tech display links; I have 4 displays running Nicely plus the M1! Thank You Apple! I need to run TD Ameritrade, Ninja trader in Windows 11;  I want run Multiple Charts during live Trading on multiple displays WILL VM Ware do it? Or is Parallels the answer ? I am getting generic BS answers  from Both VM WARE and Parallels !!  Thank You 

Mar 01, 2023 03:42 PM

I can't see my previous comment anymore... anyways I tried installing Parrot OS Architect 5.2 on m1 mba, OS version is Monterey 12.6.3 and it works

Mar 01, 2023 03:37 PM

I just wanted to let you know that I tried installing Parrot OS Architect 5.2 and it works (M1 MBA)

ps I'm on Monterey 12.6.3

Feb 22, 2023 01:35 AM

VMware's response can be found in a blog post: https://blogs.vmware.com/teamfusion/2023/02/microsoft-now-officially-supports-windows-on-mac-computers-with-apple-silicon.html

We are waiting to see how quickly VMware can get the things done that they say they are moving "full speed ahead" on. 

Feb 21, 2023 07:32 PM

Tried to edit my comment above but it will not let me. 

Any input or comment from you all or VMWare on the Parallels/Microsoft announcement five days ago that Parallels Desktop 18 has Microsoft's blessing to sell and install Windows 11 on M1 and M2 based Macs?

Feb 21, 2023 06:47 PM

Trying this for the first time. Long VMWare Fusion user since 3.0.

MacBook Pro Running VMWare Fusion 12.2.1 running Windows 10 Pro 22H2.

Followed the instructions in "Building Windows for ARM 22H2 ISOs on Windows".

On step 5 I unchecked "Include Updates" per a comment above. 

Download, then move zip file to the Windows 10 desktop and run the script on step 10 to start the creation process.

In the Command window it opens am I supposed to see about 1/4 of the Green notices as red "[Error] checksum error detected"?

Feb 20, 2023 09:16 PM

 thanks for the catch. I thought I'd gotten all of them but evidently missed one. Autocorrect and "smart" replacements strikes again. I'll update that immediately.

Feb 20, 2023 08:53 PM

Thanks for making this guide, it was very helpful!

Just a quick correction note though: In Appendix D of the PDF for Installing cabextract 1.9.1, in step 6, the 2 dashes before both instances of `prefix=/opt` are encoded as en dashes instead of normal hyphen dashes. This may be the result of some typesetting software trying to intelligently convert your dashes automatically to be more typographically correct. Copy-pasting those Terminal commands with the incorrect dashes results in errors. You should probably update the PDF so those dashes are proper hyphen dashes.

Thanks again!

Feb 19, 2023 08:35 AM

 thanks for following up, I ended up using a Windows machine to download yesterday so am up and running with Fusion on my M1 Mac.

Feb 18, 2023 06:24 AM

 I think I've found what the issue is. See my reply to this thread in the VMware Fusion Discussions area of the forums:

https://communities.vmware.com/t5/VMware-Fusion-Discussions/where-to-download-Windows-that-works-with-Mac-Silicon/m-p/2955304

I'll be uploading a new version of the Companion Guide shortly that will include the workaround I posted in that thread.

Thanks for reporting this.

Feb 17, 2023 05:49 PM

I think I've found a way to get some additional information on why the error is occurring.

Run the uup_download_macos.sh script once, allowing it to download the component files from Microsoft. It will fail but leave the files that it downloaded in a sub-folder called UUPs.

You'll also find a sub-folder named "files". Within that folder is a script called "convert.sh". Open that with your favorite editor.

On line 426 of the file, it reads:

 cabextract -d "$extractDir" "$file" >/dev/null 2>/dev/null

Change that to read:

 cabextract -d "$extractDir" "$file" >>cabextract.out 2>>cabextract.err

Save and close the file.

Make sure your working directory is the one that contains the uup_download_macos.sh script, and run following command to restart the conversion of the downloaded files:

files/convert.sh

When the process fails again, you'll find two files cabextract.out and cabextract.err. The cabextract.err file may give a clue as to why the process is failing.

Feb 17, 2023 04:20 PM

 

I just downloaded the en-gb language build scripts 22000.978_arm64_en-gb_multi_a328eaaa_convert.zip, extracted them and ran the script. It built without seeing that error message.

There isn't much in the scripts as released to help you figure out what's exactly wrong. I'm trying to find a way to determine what the conversion is complaining about.

 

 

 

Feb 17, 2023 10:17 AM

 

The one that worked for me was the same as your us version:

22000.978_arm64_en-us_multi_a328eaaa_convert

Feb 17, 2023 10:10 AM

Just tried it again with US and had the same error! 

 

Status Legend:

(OK):download completed.

 

UUP Converter v0.7.2

Note: This script does not and cannot support the integration of updates.

Use the Windows version of the converter to integrate updates.

 

CAB -> ESD: Microsoft-Windows-LanguageFeatures-Speech-en-us-Package- arm64

Failed to extract Microsoft-Windows-LanguageFeatures-Speech-en-us-Package-arm64.cab

kitenski_0-1676628713114.png

 

Feb 17, 2023 10:04 AM

 I used 22000.978 as per the instructions, I didn't select updates and chose Home and Pro version. The only difference to your test is that the language was UK English.

The zip file downloaded was 22000.978_arm64_en-gb_multi_a328eaaa_convert.zip

 




 

 

Feb 17, 2023 09:16 AM

I do confirm that it worked for me, all done on a Mac M1 with Ventura 13.1. I followed exactly what the guide advised: I downloaded the build 21H2 from uupdump without updates, I installed all the utilities with brew and converted to ISO (the first run gave a checksum error but the second was fine). There was a little difference with what is in the guide: I had a choice between Windows pro and something called "core" if I remember well, not "home", and I choosed this one.

I tried the VMware tools installation step 12.4.4.16 in the guide but apparently it failed, probably because VMware tools does not work there according to experts. Now I'm trying to establish an easy-to-use connexion between the Mac and Windows to transfer data, something without a storage place on a server. I try to follow the suggestions in the guide but as I'm not at all familiar with the way Windows allows connexion to users and so on it's not straightforward. The best is probably to ask somebody who knows about networks on Windows.

Feb 16, 2023 10:13 PM

That's the key - you have to use the older build without updates.  Then update via windowsupdate after buildling the VM.

Feb 16, 2023 09:41 PM

As a test, I just created an ISO using the instructions for building a 21H2 Retail ISO (22000.978) from uupdump.net that are found in the Companion guide. I selected the English (United States) language, and included both Windows Home and Pro.  I did not select the "Include Updates" option as recommended in the Guide.

I do not see the "Failed to extract" error. 

I'm going to run a couple of other tests.

 

Feb 16, 2023 08:11 PM

 I would be very interested to know what build from uupdump you tried to use. It is preferable to create the ISO from uupdump on Windows, but with care it is possible on macOS using the instructions in the Companion Guide. I've done it several times before, but I would like to check my work to see if something has changed.

Feb 16, 2023 06:01 PM

I had the same issue and I re-read the instructions:

Screen Shot 2023-02-16 at 10.58.02 AM.png

I think the only way to get it to work correctly is on a Windows system.

Feb 16, 2023 03:05 PM

I'm following this guide to try and get Windows ARM running on a M1 Mac,

I've now tried it three times and each time I get this error right at the end after running

./uup_download_macos.sh

Status Legend:

(OK):download completed.

UUP Converter v0.7.2

Note: This script does not and cannot support the integration of updates.

Use the Windows version of the converter to integrate updates.

CAB -> ESD: Microsoft-Windows-MediaPlayer-Package-arm64

Failed to extract Microsoft-Windows-MediaPlayer-Package-arm64.cab

Feb 14, 2023 11:08 PM

wow - wonder why that isn't in their official documentation.

Feb 14, 2023 08:02 PM

 that's a good find. The use of that built-in utility hadn't come up during the tech preview phase. I'll give it a whirl and if it passes, I'll include it in the next version of the Guide.

I'll also make sure you're credited for the suggestion.

Feb 14, 2023 07:51 PM

Thank you for this guide!

One suggestion: In the section about converting the Insider Preview VHDX file, you do not need any third party utilities. VMWare Fusion has one included in its app bundle. You can just run the following and it will convert it to a vmdk file:

/Applications/VMware\ Fusion.app/Contents/Library/vmware-vdiskmanager -r ~/Downloads/Windows11_InsiderPreview_Client_ARM64_en-us_25276.VHDX -t 0 ~/Downloads/Windows11_InsiderPreview_Client_ARM64_en-us_25276.vmdk

 

Feb 13, 2023 10:11 AM

you can think of writing a workaround on how to export-import a VM. Basically you clone an existing VM, compact the files it creates into a zipper file. The pc that has to import just unzips the files and from vmware fusion do File --> Open and select the file that you just unzipped.

Feb 07, 2023 07:00 PM


- several times the ISO file was not found and I was stuck with >>>Start PXE over IPv4. as mentionned above. However in the settings of the VM, the CD was pointing to the ISO by default it seemed. You really have to click very fast and press a key very fast!

When initially creating the VM, the VM's boot firmware is set to boot from CD/DVD first, then the hard drive, then the network (PXE). If you've set the CD/DVD drive to the Windows installer ISO (and made sure the drive is connected to the VM). the firmware will find the bootable media in the CD drive and boot from it first. Windows Setup will change the firmware's boot order to hard drive first, then CD/DVD after it completes the first phase of the installation and before the first reboot.

At the point of the request "Press any key...", the VM has has booted from the Microsoft installer ISO that's configured to the VM's CD/DVD drive. It's the Microsoft installer that's asking for the key press, not Fusion. Microsoft doesn't give you a lot of time to perform the task.

Thank you again for this very detailed, efficient and well-written guide, that can be used even by someone with low technical abilities!

You are welcome. Glad it could help you!

Feb 07, 2023 06:35 PM

FANTASTIC!

I had given up a while ago because I could not find the ISO for Windows and didn't manage to convert the files from UUP dump, I hesitated between Windows 10 and the newly released 11 too... too hard for a simple biologist.

The only problems I had:

- several times the ISO file was not found and I was stuck with >>>Start PXE over IPv4. as mentionned above. However in the settings of the VM, the CD was pointing to the ISO by default it seemed. You really have to click very fast and press a key very fast!

- very important not to forget to change the settings for Windows if you are using an AZERTY keyboard!!!

- the usual shortcut for the antislash on a MacBook AZERTY keyboard did not work in the command line promt, and of course it was not possible to copy-paste. I found out somewhere that the combination ctrl + option + 8 worked.

Thank you again for this very detailed, efficient andwell-written guide, that can be used even by someone with low technical abilities!

Feb 07, 2023 01:37 AM

If you ever come across a directory with a space in it again and you need to work with the CLI/shell, you can do one of two things:

enclose the file path with the spaces in double quotes like "/Rogue Monk"

or

escape the space with the backslash character: /Rogue\ Monk

Feb 06, 2023 10:23 PM

No - I figured out the issue - the directory I was using had a space in it (/Rogue Monk/). When I moved it all to the root directory, it worked (or is currently working).

Thanks.

Feb 06, 2023 09:53 PM

There are underscores in the file name, not spaces. It reads

.\uup_download_windows.cmd

I'll see if I can make that a little more clear in the next update.

Feb 06, 2023 09:38 PM

Hello.

At step 10, page 34....I get an error at the command prompt --

"Current directory contains spaces in its path.
Please move or rename the directory to one not containing spaces."

Can you help? Thanks.

 

Feb 03, 2023 01:02 AM

You use the “cd” command to change the working directory when you are in the shell that’s open in the Terminal window. A web search for “unix change working directory” will give you more information on thie “cd” command and how to use it  

Opening the Terminal places you into a shell (that’s the equivalent of the Windows command prompt or Powershell) whose working directory is your account’s home folder. Your Desktop is a sub folder of your account’s home folder, (In Unix-like operating systems, folder and directory are synonymous). 

Let’s take an example. If you have a folder called “22000-something” on your Desktop, the following commands will change your working directory in the shell to this folder. :

cd Desktop
cd 22000-something

Or, the following single command will do the same thing starting in the same place

cd Desktop/22000-something

Videos are nice, but nothing takes the place of a well written manual. It’s easy to go back in a manual and use it as a reference. It’s not nowhere as easy to do that with a video - not unless you are taking copious notes as the video is playing. 

 

Feb 02, 2023 03:30 AM

Got to step 10 and totally lost as to what to do. It says...

Extract the zip file obtained from step 8 and change the working directory to the
folder that was created during the unzip process

So I've got Terminal open. I've got a folder on my desktop that has the zip file and in that folder I double clicked the zip folder and now have a folder called 22000 and within that many files and a sub-folder called files. 

I'm not tracking with with what I need to do to change the working directory and how that then works to create the ISO file. 

Anyone have more detailed instruction on what this step entails? For non-techie people, this really should be a YouTube video so I can see what the heck is actually being asked to do here. Sigh.

Feb 01, 2023 03:40 PM

 thanks for the comments.

Adding the ISO to the CD either in settings or the Virtual machine menu will work. You do have to make sure the virtual CD is set to connect to the VM if you do it through settings before booting the VM. I’ve forgotten that one a few times.  

The idea to use the updated Leap image is a good one.. I’ll make a note of that in the next revision to the guide (coming soon!). 

Feb 01, 2023 12:04 PM

Thank you for this REALLY useful guide. You may add some information (testet openSUSE Leap 15.4, macOS 13.2 and VMware Fusion Player 13.0.0):
- You need to connect a virtual CD/DVD-ROM and mount the appropriate image in the "Virtual machine" menu (not in Settings) if you encounter this error:

>>>Start PXE over IPv4.

It took me a while to figure that out...

- You can use the "Updated Offline Image" (I used openSUSE-Leap-15.4-CR-DVD-aarch64-Build31.98-Media.iso). This save some time for the required kernel update

Jan 29, 2023 05:23 PM

 In fairness, VMware does describe how to install VMware Tools in Windows 11 ARM in the product documentation. They note that it does not install automatically like it does in Intel Windows.

Should VMware have published something like this? The answer is obviously "yes". But the community can react and tailor any responses to the needs of the community (such as more detailed walk-throughs) faster than VMware can. 

I do fault the VMware Community boards for not having "sticky topics" like other boards I've seen. That would provide an opportunity to put the Companion Guide "front and center" so that it could be more easily found and help more people.

Jan 29, 2023 12:50 PM