Db2 Tools

 View Only

Important - Level Set Activation Requirement Coming in the Future

  • 1.  Important - Level Set Activation Requirement Coming in the Future

    Broadcom Employee
    Posted 12 days ago

    This announcement serves as notice of a future requirement for activation of a Level Set for Version 20.0 of the Database Management Solutions for Db2 for z/OS. 

    Starting with the PTF for Level Set 20.0.16 (planned for release in May 2025), Level Set 20.0.01 or higher must be activated. Xmanager will not start up at this maintenance level if the active Level Set is 20.0.00. 

    Activation of a Level Set is similar to activation of Db2 function levels and enables customers to control when certain functions or behaviors occur. It also makes it possible for you to revert back to previous behaviors, similar to Compatibility Mode in Db2 terminology. Activation of a Level Set lets you use any features in the Level Set that require activation.

    To enable these capabilities, activate Level Set 20.0.01 or higher before the PTF for Level Set 20.0.16 is applied. Activation of Level Set 20.0.01 enables customers to roll their Xmanager maintenance across members of a sysplex and avoid taking an outage as maintenance is applied. See Activate a Level Set in the Database Management Solutions for Db2 documentation for information about applying a Level Set PTF versus activating a Level Set, activation prerequisites and other considerations, and a video that provides a walk-through of the activation steps. Examples and an activation use case are also provided.

    For a list of the available Level Set PTFs and their corresponding features, see New Features.



    ------------------------------
    Andrew Badgley

    Lead Product Owner - Db2 Tools
    Broadcom
    ------------------------------