Hello,
SNMP Collector does not monitor using traps. For traps you need to use snmptd probe. SNMP Collector polls the device using SNMP.
You can test the credentials with snmpwalk, sapwalk2 or Paessler SNMP Tester.
Check the logs of snmpcollector.
Also, there is a know issue when importing SNMP devices from OC:
https://knowledge.broadcom.com/external/article?articleId=243902Also, a known issue from Dell side:
https://www.dell.com/support/kbdoc/en-us/000203267/powerstore-simple-network-management-protocol-snmp-traps-not-received-by-server-user-correctable?lang=en
PowerStore: Simple Network Management Protocol (SNMP) Traps not received by server (User Correctable)
Symptoms
Configuring an SNMP server that is down or nonexistent will prevent SNMP traps from being sent for alert notifications.
Attempts to contact the SNMP server may cause PowerStore Manager slowdowns.
Cause
The SNMP Trap sending code is blocking the Control Path code while trying to make contact with a nonexistent server.
Resolution
This issue is easily resolved by ensuring that the SNMP server configured on the PowerStore is up and reachable.
Original Message:
Sent: Dec 19, 2022 09:43 AM
From: Nijin K
Subject: dell Powerstore monitoring
Hi All
I am trying to add dell power store through SNMP collector using V3 traps but each time i am getting invalid credentials error i have checked with storage team regarding this but the credentials are correct and port used is 161 and 162, 161 is open from UIM to Powerstore and 162 from Powerstore to UIM.
Have anybody tried this if yes are there any specific steps involved or any steps i am missing before adding device to snmpcollector.
regards
Nijin