Layer7 API Management

Expand all | Collapse all

CA API Gateway 8.4 to 9.4 License and MySQL

Jump to Best Answer
  • 1.  CA API Gateway 8.4 to 9.4 License and MySQL

    Posted 01-31-2019 04:00 PM

    So we have software gateways running  8.4.02 CR02_FIX on RHEL 6.10, with MySQL 5.5 and Java 1.8 (couple of different versions).   It also has an older License issued by Layer 7 for version 8.  We want to go to 9.4.x.  

     

    Since it's a software gateway, the SSG part looks as easy as loading the 9.4.x L7P and then doing the DB update in the setup.    Am I missing something there?

     

    Next what (if anything) needs to be done with the license.  My recollection from looking at the original text, long ago is that it was tied to the major version.  Do I need to get a version 9 license ahead of time?  Or has the licensing changed and it will be converted?

     

    Next is when to upgrade MySQL to 5.7.  Do I need to do it before or after the L7P?   Or possibly make a few more steps.  Seems from the release notes that the appliance went from 5.5 to 5.7 in 9.2.0.  Would I need to do something like take the SSG to 9.2, then MySQL from 5.5 to 5.7, and finally SSG to 9.4?



  • 2.  Re: CA API Gateway 8.4 to 9.4 License and MySQL
    Best Answer

    Posted 02-04-2019 07:06 PM

    Good afternoon,

     

    In response to your questions:

    Since it's a software gateway, the SSG part looks as easy as loading the 9.4.x L7P and then doing the DB update in the setup.    Am I missing something there?

    Response: Correct that for software you can just upgrade to the 9.4 L7P as you are past the 8.3 release where we changed the way that the database is upgraded.

     

    Next what (if anything) needs to be done with the license.  My recollection from looking at the original text, long ago is that it was tied to the major version.  Do I need to get a version 9 license ahead of time?  Or has the licensing changed and it will be converted?

    Response: A new license is required for each major release so if you have a 8.x license it will not work on a 9.x or higher installation. Please open a support request for an updated license for 9.x.

     

    Next is when to upgrade MySQL to 5.7.  Do I need to do it before or after the L7P?   Or possibly make a few more steps.  Seems from the release notes that the appliance went from 5.5 to 5.7 in 9.2.0.  Would I need to do something like take the SSG to 9.2, then MySQL from 5.5 to 5.7, and finally SSG to 9.4?

    Response: One of the changes that occurred within the change from MySQL 5.5 to 5.7 using our standard my.cnf file was that it will use per file for each table instead of the one large ibdata file. Other than that there is no other changes so the upgrade to 5.7 can be done either before or after the upgrade.

    KB on the subject: How to Move Gateway Database Tables from the Syste - CA Knowledge 

     

    Sincerely,

     

    Stephen Hughes

    Broadcom Support