Clarity PPM

Expand all | Collapse all

Error Upgrade to 15.6 from 15.5

  • 1.  Error Upgrade to 15.6 from 15.5

    Posted 03-18-2019 12:14 PM

    Hello team

     

    RHEL PPM 15.5.0

     

    We are trying to upgrade to the new release 15.6 But we have a strange error:

     

    We are using JAVA 11. Our gateway.xml seems ok

     

    3/18/19 3:06 PM (ExecTask) 3/18/19 3:06 PM (ExecTask) installsteps: 3/18/19 3:06 PM (ExecTask) Internal error. See output above for more info. 3/18/19 3:06 PM (ExecTask) java.lang.NoClassDefFoundError: org/apache/tools/ant/BuildListener 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.ClassLoader.defineClass1(Native Method) 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1016) 3/18/19 3:06 PM (ExecTask) at java.base/java.security.SecureClassLoader.defineClass(SecureClassLoader.java:174) 3/18/19 3:06 PM (ExecTask) at java.base/java.net.URLClassLoader.defineClass(URLClassLoader.java:550) 3/18/19 3:06 PM (ExecTask) at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:458) 3/18/19 3:06 PM (ExecTask) at java.base/java.net.URLClassLoader$1.run(URLClassLoader.java:452) 3/18/19 3:06 PM (ExecTask) at java.base/java.security.AccessController.doPrivileged(Native Method) 3/18/19 3:06 PM (ExecTask) at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:451) 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588) 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) 3/18/19 3:06 PM (ExecTask) at com.niku.nsa.service.AdminManager.invokeAction(AdminManager.java:592) 3/18/19 3:06 PM (ExecTask) at com.niku.nsa.service.AdminManager.execute(AdminManager.java:200) 3/18/19 3:06 PM (ExecTask) at com.niku.nsa.service.Admin.main(Admin.java:77) 3/18/19 3:06 PM (ExecTask) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) 3/18/19 3:06 PM (ExecTask) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) 3/18/19 3:06 PM (ExecTask) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.reflect.Method.invoke(Method.java:566) 3/18/19 3:06 PM (ExecTask) at com.werken.forehead.Forehead.run(Forehead.java:551) 3/18/19 3:06 PM (ExecTask) at com.werken.forehead.Forehead.main(Forehead.java:581) 3/18/19 3:06 PM (ExecTask) Caused by: java.lang.ClassNotFoundException: org.apache.tools.ant.BuildListener 3/18/19 3:06 PM (ExecTask) at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471) 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588) 3/18/19 3:06 PM (ExecTask) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521) 3/18/19 3:06 PM (ExecTask) ... 19 more 3/18/19 3:06 PM (ExecTask) EXIT_CODE = 1 3/18/19 3:06 PM (ExecTask) 3/18/19 3:06 PM (ExecTask) BUILD FAILED



  • 2.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-18-2019 01:28 PM

    Mario - are you sure it detects the Java 11 properly? Did you specify JDK 8 and JDK 11 correctly when the installer prompted you? Seems like there is a Java conflict so I would suggest looking into why it happens. 



  • 3.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-18-2019 02:03 PM
      |   view attached

    Hi Nika

     

    Thanks for your email.

     

    We are on 15.5.0 (Java 8)

     

    Install.sh only asked me for Java 11 (see install.log)

     

    3/18/19 3:02 PM (Project) Trying to override old definition of task java

    3/18/19 3:02 PM (Target) Target "init" started.

    3/18/19 3:02 PM (Target) Target "init" finished.

    3/18/19 3:02 PM (Target) Target "_install" started.

    3/18/19 3:02 PM (SetupUtil)

    3/18/19 3:02 PM (SetupUtil) J2SDK 11 Home Directory :

    3/18/19 3:02 PM (SetupUtil)

    3/18/19 3:02 PM (SetupUtil) Beacon Multicast Address :

     

    We tried 2 times and same questions from install.sh like first time.

     

    Regards,

     

     

    Mario Luque



  • 4.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-18-2019 03:17 PM

    Maybe this does not relate to your problem.

    I had problem updating from 15.5 to 15.5.1 See

    'checkinstall' for Clarity PPM 15.5.1 fails due to JAVA version 

    What I have always done is uninstalled the old version of java and installed the supported version in a folder with the same name so that I do not have the need to modify JAVA_HOME

    Suman says that is wrong and I should have both versions. As said I have never done it like that.

    My problem with upgrade to 15.5.1 was the checkinstall and the java version.

    I could not make the proposed workaround for gateway.xml work. So I deleted the java version test completely.

    After that the install went smoothly.



  • 5.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-19-2019 03:16 AM

    Hi.

     

    Trying different approach with not luck.

     

    As this is RHEL, we have symbolic links for our JAVA and TOMCAT folders. In the bash_profile, we have declared  JAVA_HOME using JAVA symbolic link, this is working for us several years.

     

    Our primary error is with the jdk 11

     

    If we modified to use jdk 8 (091 or 171) we have other error in the install.sh process  and the error is

    BUILD FAILED

    /mnt/fs_servicios/niku_app/datos/usuarios/niku_app/instalacion_156/install/gateway.xml:44: The following error occurred while executing                                this line:

    /mnt/fs_servicios/niku_app/datos/usuarios/niku_app/instalacion_156/install/install.xml:19: java.lang.UnsupportedClassVersionError: com/                               niku/tools/taskdefs/VersionNumberCompareTask has been compiled by a more recent version of the Java Runtime (class file version 55.0),                                this version of the Java Runtime only recognizes class file versions up to 52.0

            at java.lang.ClassLoader.defineClass1(Native Method)

     

    Seems that:

    - We need to point our JAVA HOME to jdk11 to start the process

    - For some reason, install process is only asking us to jdk11 and not jdk8

     

    Regards,



  • 6.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-19-2019 05:25 AM

    As this is an upgrade to 15.1 to 15.5 and 15.6. We will back to 15.1 and try directly to 15.6



  • 7.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-21-2019 12:25 PM

    Was the location that Clarity is being installed to, moved at all?

     

    I.e. if you edit the properties.xml file does the installDir="..." attribute of the directories element point to the correct and current location?

     

    I would say from the stack trace that its inability to find the BuildListener class, means it is failing at that point to find the ant.jar on the classpath at all.  Yet the ant.jar is included with every version (and hasn't changed or has barely changed - that class is still there in every one of them).

     

    Java version differences should not be coming into play at that point.  Finding classes has more to do with class paths and file access permissions to the .jar files.  Once it gets that far and can locate the class, then it may begin to complain about version mismatches or similar.



  • 8.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-21-2019 12:40 PM
      |   view attached

    Thanks Nick

     

    installDir in properties.xml file is with the correct value

     

    My feeling is something related to JAVA 11 on RHEL, something is wrong but…. What? Any option to put a debug mode to have more info??

     

     

     

    Mario Luque



  • 9.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-21-2019 01:13 PM

    Debug mode.. not really.

     

    The ExecTask and installsteps points to the target (called installsteps) in the <install files>/install-packages/<version>/install.xml file

     

    There are two exec ant calls in this file, and they are basically calling out to the admin(.sh) scripts in the Clarity /bin folder.

     

    This in turn is what fires up the nsa admin management code that then tries to load the build listener class.

     

    So the only other thing I can suggest is checking and making sure those admin scripts haven't been altered in this environment.

     

    Otherwise, and if you suspect RHEL (although I can't see why it would be an issue from the stack trace alone), you could, at least in theory:

     

    1. Copy the files to another env

    2. Do the upgrade from that other non-RHEL env

    3. Install 15.6 fresh on RHEL

    4. Reconfigure the RHEL env to point to the upgraded database

    5. Scrap the upgraded non-RHEL env**

     

     

    ** being wary/mindful of things like the file store of course.



  • 10.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-21-2019 01:30 PM

    Thanks Nick.

     

    The last test by Nika and me was to  put another target folder to force in the ant the install dir....... but fails :-(

     

    Install script was download from support............. i´m trying to get the complete lRHEL release info from customer to understand if they have a 'strange' RHEL version , seems not but..............

     

    The upgrade from 15.1 to 155 is ok (15,2->15->3->15.4->15.5). 15.5 to 15.5.1 fails

     

    Thanks for your help



  • 11.  Re: Error Upgrade to 15.6 from 15.5

    Posted 03-22-2019 12:56 PM

    Hi Mario,

     

    If you are upgrading from 15.5 to 15.5.1  please follow the below steps,

    1.Login as PPM installation user

    2.Go to clarity 15.5 bin folder stop and remove all services[app, bg, beacon,nsa] and just a make a note what are the services are deployed in the server.

    3.Take the backup of current version  Clarity 15.5  PPM file system and clarity schema

                 4.Update the Environment variables for the ppm install user .bash_profile and update  JAVA_HOME directory  to Java 11.

    Eg: export JAVA_HOME=</opt/java/java11.0.28>

    Append the JAVA_HOME in the export PATH with bin directory

    export PATH=</opt/java/java11.0.28/bin>

    5.Once the JAVA_HOME Patch is set log out  from PPM Installation user

    6.Login back  as PPM installation user Validate whether JAVA_HOME path is reflected

    Eg: echo $JAVA_HOME

    You should see the JAVA_HOME Path set in PPM Installation user .bash_profile

    </opt/java/java11.0.28>

    7.Check Java version whether it is reflected properly

    Java -version

    8.Give the Install Directory and Target Directory as  same current clarity Home directory

    9.Install scripts will rename the install directory with the previous version and current version will be installed in the install directory

    If you are running the check install script for 15.5.1 version there is known defect with the Java 11 error message but if you run the install.sh  clarity PPM Installation will work and check install will be run as part of clarity installation and results will stored in /<temp>/checkinstall/check-logs

     

    If you are using ORACLE as database  make sure that there is access to DBMS_OBFUSCATION_TOOLKIT  to PPM schema refer here for more info on how to validate the access.