Automic Workload Automation

Expand all | Collapse all

Task preconditions - Data is generated at runtime and not available yet

  • 1.  Task preconditions - Data is generated at runtime and not available yet

    Posted 10-09-2018 11:10 AM

    I’m seeing the following error when trying to modify the preconditions of a workflow task.

    Has anyone seen this before?



  • 2.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-09-2018 12:33 PM

    I have not seen this before.  But I don't think we use *OWN in our precondition rules, so I would guess that for some unknown reason it wants to resolve the agent but that can only be done at runtime(?)



  • 3.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-09-2018 04:50 PM

    The job might be defined on an agent group. I'll look into that.



  • 4.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-09-2018 02:54 PM

    Hi Michael

     

    I got this message when I tried using promptset variables with default values (object variables) outside of a workflow

    [EDIT: not sure, if it was in or outside a workflow....]

     

    Couriously sometimes it worked if I tried a couple of minutes later again....

     

    pls do not ask why....

    V11.2.3 and V11.2.6

     

    cheers, Wolfgang



  • 5.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-10-2018 07:46 AM

    I think I know what’s going on. I think the UC4 Java User Interface is attempting to establish communication directly from the JUI to the agent. The agent is behind a firewall. The firewall allows communication between the Automation Engine server and the agent, but it does not allow direct communication between the JUI and the agent.



  • 6.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-11-2018 03:40 AM

    I confirmed that the firewall between the JUI and the agent is the problem. What does CA recommend here?



  • 7.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-11-2018 08:56 AM

    I still see this when I try to add a new pre/post condition on a JOBP/JOBS. I have been using the AWI (web interface) to add the conditions. Didn't really get to trouble shoot.

    Thanks for sharing the reason for the issue @Michael Lowry . what are your next steps then?



  • 8.  Re: Task preconditions - Data is generated at runtime and not available yet

    Posted 10-17-2018 09:17 AM

    I opened an incident. I’ll report back when I have a solution.