Layer7 API Management

Expand all | Collapse all

Manage Firewall rules button disabled in CA API Gateway.

Jump to Best Answer
  • 1.  Manage Firewall rules button disabled in CA API Gateway.

    Posted 11-01-2018 01:44 AM

    Hi All,

     

    I have been trying to redirect all the requests landing on 80 of my cluster host to 8080. And for doing the same I need to use Manage firewall rules option in policy manager but it is disabled.

    Can someone suggest how to enable the Manage Firewall rules button?

    How can we redirect all request from 80 to 8080?

     

    Thanks in advance team.

     

    Regards,

    Himanshu



  • 2.  Re: Manage Firewall rules button disabled in CA API Gateway.

    Posted 11-01-2018 02:35 AM

    Just to update you all I am using the software gateway and not an appliance.

    I have tried looking for the resolution in docops but couldn't find any.

     

    Regards,

    Himanshu



  • 3.  Re: Manage Firewall rules button disabled in CA API Gateway.

    Posted 11-01-2018 03:56 AM

    That is what my first question would be. The software gateway is the reason why this is greyed out. Only on the appliance gateways there is an integration with the firewall, this is not part of the software install. If you want to do a redirect, you should do it manually on the local firewall or in an external firewall.

     

    Regards,

    Michiel



  • 4.  Re: Manage Firewall rules button disabled in CA API Gateway.
    Best Answer

    Posted 11-01-2018 04:01 AM

    Hello Himanshu,

     

    on the software version of the gateway the firewall must be set up directly by the host administrator. See also:

    My Manage Firewall Rules Button Is Greyed out on C - CA Knowledge 

    and

    Manage Firewall Rules - CA API Gateway - 9.3 - CA Technologies Documentation 



  • 5.  Re: Manage Firewall rules button disabled in CA API Gateway.

    Posted 11-01-2018 06:31 AM

    Thank you so much for the quick response. The issue is resolved.

     

     

    Regards,

    Himanshu