IT Process Automation

Expand all | Collapse all

pamconnectorplugin only supports outdated versions of Eclipse.

Jump to Best Answer
  • 1.  pamconnectorplugin only supports outdated versions of Eclipse.

    Posted 06-18-2018 09:20 AM

    Is the pamconnectorplugin ever going to be updated for newer versions of Eclipse? 

    Currently the only versions of Eclipse the CA connector supports are very outdated.



  • 2.  Re: pamconnectorplugin only supports outdated versions of Eclipse.
    Best Answer

    Posted 06-19-2018 04:40 PM

    Hi,

    Have you tried using this plugin in another Eclipse version?

     

    It's a common practice, not desired, in java development to have multiple versions of eclipse. So to develop plugins for pam I keep a luna eclipse.

     

    I've done lots of pam's connectors, is there something that you need from Oxygen (eclipse latest)? If there is, you develop an project as an testable api, that you can just port as a .jar to the connectors project. What I usually do when working with connectors,

    I create a separate api project for the thing that I need to do:

     

    For example:

     

    Which syncs sdm users with ldap and have some junit to validate its usage. When I validate that this integration is working, I wrap it up as a jar to be imported at the pam's connector project

     

    This is a workaround your problem, I know it's not ideal and it would be nice to have features like, default operators extensions.. but unfortunately this feats are not available. You can create an idea for this, and I'll surely upvote it.

     

    Hope it helps



  • 3.  Re: pamconnectorplugin only supports outdated versions of Eclipse.

    Posted 06-21-2018 11:02 AM

    To be honest, I'm not a big Java guy, but we have a new employee starting who knows Java, so I was trying to help him set up the tool.

     

    We tried a few of the newer Eclipse versions, but it didn't detect (or wasn't able to run) the plugins when I placed them in the directory.

     

    He is just used to the newer tools, but I guess I will place an Idea request for it, and see if anyone else (besides us) will upvote it

     

    Thanks for your suggestion though, I will review it with him and see if that will tide us over.

     

    Ian



  • 4.  Re: pamconnectorplugin only supports outdated versions of Eclipse.

    Posted 06-21-2018 03:48 PM

    I'll sure upvote it



  • 5.  Re: pamconnectorplugin only supports outdated versions of Eclipse.

    Posted 10-26-2018 09:05 PM

    What is the ticket?  I'd like to upvote it too, but don't know where the ticket is.