Clarity Service Management

Expand all | Collapse all

Web Screen painter does not start - download dialog instead of run

Jump to Best Answer
  • 1.  Web Screen painter does not start - download dialog instead of run

    Posted 10-14-2018 11:26 AM

    When I try to start WSP, after login (user name and password is correct) I get download dialog instead of start of WSP.

    It seem like security setting of OS (Windows 2012), but I was not able to find which one...

    The server is not in domain, there is no GPO. It worked in the past, but now, I am not able to start it (WSP is not used so often, so I do not know how long is it in this state).

    It is also profile independet (I try 2 different server users) and the same result is on primary and also secondary server.

    Any idea what is wrong?

     



  • 2.  Re: Web Screen painter does not start - download dialog instead of run

    Posted 10-15-2018 05:13 AM

    Have you tried resetting your IE settings to the default? Or using a different browser like Google Chrome or Firefox?



  • 3.  Re: Web Screen painter does not start - download dialog instead of run

    Posted 10-15-2018 05:30 AM

    Yes, of course...

    IE default setting, clean installatin of Chrome...still the same...



  • 4.  Re: Web Screen painter does not start - download dialog instead of run

    Posted 10-15-2018 07:16 AM

    I discovered, that the WSP is trying to open following link

    http://vmcasdapl/CAisd/pdmweb_wsp.exe?WSPHOST=xxxxxxxxxxxxxxxxx

    But on our server (IIS) is the http redireeted to https with external address and http is not allowed

    So if I try to use the httpS instead of http, it works...

    Where can I change the link which is used by WSP by default?



  • 5.  Re: Web Screen painter does not start - download dialog instead of run
    Best Answer

    Posted 10-15-2018 09:49 AM

    radek.mihalik 

     

    Check the NX.ENV file to see if the @NX_WSP_CGI_URL variable is defined.



  • 6.  Re: Web Screen painter does not start - download dialog instead of run

    Posted 10-15-2018 10:00 AM

    Thanks! It works now.