Test Data Manager

Expand all | Collapse all

Issue in creating Test data model using TDM portal

Jump to Best Answer
  • 1.  Issue in creating Test data model using TDM portal

    Posted 06-28-2018 03:54 AM

    In CA TDM Portal, While creating the "Test Data Model", there is an option to select the rspective table from the source connection profile. While selecting the tables it shows the error as " Data source not found for the selected entity". Verified the source connection profile and it points to the respective DB.

     

    Can you please help me in resolving this issue. Thanks in advance.



  • 2.  Re: Issue in creating Test data model using TDM portal

    Posted 07-02-2018 03:27 AM

    Please can you check whether the data source has been added into the selected environment.

     

    The entity selected is the part of the registered objects of the Project. While creating a Test Data Model, you will be selecting an Environment. This environment should have the data sources defined for the DB from which the selected entity has been registered.

     

    Hope this helps.



  • 3.  Re: Issue in creating Test data model using TDM portal

    Posted 07-02-2018 03:43 AM

    Hi Srinivasan Sathiamurthi,

     

    Thanks for your response. 

     

    Yes my environment and the data source connection is the same. And the registered tables are part of source connection.

     

    PFB Screenshot for your reference

    Environment

    Connection Profile

    Model Entity

     

    Data Source



  • 4.  Re: Issue in creating Test data model using TDM portal

    Posted 07-02-2018 04:56 AM

    Hi Sowmiya,

     

    From the screen shots, the entity Address is under the db schema ARBOR. Please can you ensure the same schema is selected in the connection profile REL04.

     

    Also can you verify this connection profile is added as a data source under the  environment REL04.



    (Suggestion: It would be better to have different names for the connection profile and environment, though this should not cause any problem)



  • 5.  Re: Issue in creating Test data model using TDM portal

    Posted 07-02-2018 05:45 AM

    Hi Srinivasan Sathiamurthi,

     

    Yes the schema name is selected as "ARBOR" in the connection profile. Below is the screenshot

     

     

    PFB Screenshot for connection profile

     

    Thanks for responding promptly. I'm currently stuck in this stage and need to get this fixed. Can you let me know you Contact number, so that i can discuss on the setting (Again it is upon your convenient time and interest)

     

    Regards,

    Sowmiya Sambath



  • 6.  Re: Issue in creating Test data model using TDM portal
    Best Answer

    Posted 07-02-2018 07:09 AM

    Thanks for the screen shots. All looks fine, not sure what could be causing this error.  

    Just FYI, the document explains about the possibility of this error as below.


    V4.4 - Create a Test Data Model

    If possible, please try the steps in a new temp project to isolate the issue with detailed logs enabled. If still not resolved, It is advisable to raise an support ticket with CA.



  • 7.  Re: Issue in creating Test data model using TDM portal

    Posted 07-04-2018 07:24 AM

    Thanks a lot Srinivasan Sathiamurthi.

    I'm trying to check with CA people, meanwhile if i get any updte, will keep posted.