Service Virtualization

Expand all | Collapse all

JSON Assertions and Filters are not working

Jump to Best Answer
  • 1.  JSON Assertions and Filters are not working

    Posted 05-15-2018 06:59 AM

    Hi, I have installed new DevTest version 10.2 in my desktop today and could see that JSON assertions & filters not working. Following are the errors, Could someone please help me out.  Attached the full error details.

     

    Filters: 

    | Message: Unexpected exception thrown during evaluation of 'JSON Path Filter': Could not initialize class com.jayway.jsonpath.spi.JsonProviderFactory
    ----------------------------------------------------------------------------
    | Trapped Exception: Could not initialize class com.jayway.jsonpath.spi.JsonProviderFactory
    | Trapped Message: java.lang.NoClassDefFoundError: Could not initialize class com.jayway.jsonpath.spi.JsonProviderFactory

     

    Assertions:

    | Message: Test Execution Stopped due to exception
    ----------------------------------------------------------------------------
    | Trapped Exception: Could not initialize class com.jayway.jsonpath.spi.JsonProviderFactory
    | Trapped Message: java.lang.NoClassDefFoundError: Could not initialize class com.jayway.jsonpath.spi.JsonProviderFactory

    Attachment(s)

    zip
    Error_Assertions.txt.zip   673B 1 version
    zip
    Error_Filters.txt.zip   832B 1 version


  • 2.  Re: JSON Assertions and Filters are not working

    Posted 05-15-2018 09:45 AM

    Do you have a sample testcase or Json  that you can attach ?  Are you using  any custom jars ? 



  • 3.  Re: JSON Assertions and Filters are not working

    Posted 05-16-2018 01:30 AM

    Hi Shiney, Thanks for the reply. We are not using any custom jars. I just created a test case and added JSON assertions and Filters. If i run the same test case from portal, JSON assertions and Filters are working fine.



  • 4.  Re: JSON Assertions and Filters are not working
    Best Answer

    Posted 05-16-2018 01:27 PM

    Hi Panditi, can you open a ticket with CA support.  please reference this communities post in the description. 



  • 5.  Re: JSON Assertions and Filters are not working

    Posted 05-17-2018 03:22 AM

    Sure Shiney, i will raise a ticket. Thanks.



  • 6.  Re: JSON Assertions and Filters are not working

    Posted 05-17-2018 07:19 AM

    Also, please update the resolution to this ticket here also. In case if we encounter the issue, it will be easy for us to resolve. Thanks



  • 7.  Re: JSON Assertions and Filters are not working

    Posted 02-12-2019 01:00 AM

    Hi Abraham,

    Would you please update me with the resolution the same error I am getting now where none of the JSON filters or assertions are getting parsed?

     

    Kind Regards,

    Chaitanya