Service Virtualization

Expand all | Collapse all

DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

  • 1.  DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-09-2018 10:23 AM

    DevTest WorkStation (Client) is running too slow. It starting to run slow a couple of weeks ago. Before that, it used to run fast. When I am working on a open project and change selection from one step to another, it takes several seconds to load the "Step Information". My PC spec is under minimal requirement: I have 16 GB of Memory, i7-4790S 3.20 GHz Processor, 64-bit System, WIndows 10.



  • 2.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-09-2018 11:17 AM

    Add additional heap size to the Workstation.

     

    Add this to start with to the Workstation.vmoptions file:

     

    -Xmx1g

     

    Restart the Workstation and see if this speeds up the client a bit.



  • 3.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-09-2018 01:50 PM

    I made the changes in Workstation.vmoptions as suggested and restarted the application, but the application is still running slow.



  • 4.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-09-2018 01:58 PM

    Try deleting testcase.rsp file(s) and see if that helps.



  • 5.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-09-2018 02:26 PM

    I have just tried. Unfortunately, it did not help.



  • 6.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-09-2018 05:07 PM

    On the test case where you are noticing the slowness, what are your steps doing?

    Is your project located on your local machine or on a share drive?



  • 7.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 07-12-2018 12:52 PM

    Is this happening for all projects or is the slowness happening for a specific project? You can try to delete your user preferences to see if that helps relieve some of the lagginess. Your user preference should be under C:/Users/<windowslogin>/lisatmp_x.x. This folder contains log files along with specific user preferences and history. Wiping this out will leave reset your user preferences (you will also lose certain history such as registry url during startup etc.).



  • 8.  Re: DevTest WorkStation (Client) is running too slow. How can I make it run faster again?

    Posted 10-12-2018 02:47 PM

    Igor,

     

    Are you still having this issue? If so, can you provide the responses to William's questions?