Automic Workload Automation

Expand all | Collapse all

CA AUTOMIC AWA r12.2 initial Db Load crashes with PostGreSql 9.4, 9.6 and 10.5

  • 1.  CA AUTOMIC AWA r12.2 initial Db Load crashes with PostGreSql 9.4, 9.6 and 10.5

    Posted 08-28-2018 02:59 PM

    Hi Everyone,

     

    I'm having an issue when installing CA AUTOMIC AWA r12.2 (12.2.0+build.1004) with PostGreSql as a database repository, the DB Load utlity (ucybdlb.exe) crashes with DEADLOCK message (U00000006). The same issue could be verified running DB Load with PostGreSql 9.4, 9.6.10 and 10.5. All the recommended configurations described in the AWA guide (https://docs.automic.com/documentation/webhelp/english/AWA/12.2/DOCU/12.2/AWA%20Guides/help.htm#Installation_Common/Prep… ) were applied.

     

    Any idea about that ?

     

    Thanks, Jorge Rocha



  • 2.  Re: CA AUTOMIC AWA r12.2 initial Db Load crashes with PostGreSql 9.4, 9.6 and 10.5

    Posted 08-28-2018 03:46 PM

    Hey Jorge,

     

    I am interested in a solution to this as well. I have been running into the same issues and I cannot seem to figure it out either. Currently I have a ticket open with CA support and I will let you know what we find out.

     

    Regards,

     

    Michael



  • 3.  Re: CA AUTOMIC AWA r12.2 initial Db Load crashes with PostGreSql 9.4, 9.6 and 10.5

    Posted 08-28-2018 04:49 PM

    Hi Michael,

     

    I had evolved in a solution for this issue. The tablespaces must have ae_data and ae_index names and the schema must be created under AE DB connection.

    I have received another message the first time I executed the DB Load (U00003539 UCUDB - DB Check: Error in rollback), that I must investigate.

     

    Running the DB Load via command line twice, apparently solve the issue, but I'll try other options to make sure that the database is consistent:

    1 (first time): UCYBDBld -B -X<path >\UC_UPD.TXT

    2 (second time): UCYBDBld -B -TNO -K<your key>

     

    Any news will be posted. Good luck !

     

    Regards, 

    Jorge Rocha



  • 4.  Re: CA AUTOMIC AWA r12.2 initial Db Load crashes with PostGreSql 9.4, 9.6 and 10.5

    Posted 08-28-2018 05:12 PM

    Hi Michael,

     

    to solve the db check issue, just change the timeout to connect_timeout=15. You can still run the first command line "UCYBDBld -B -X<path >\UC_UPD.TX".

    Apparently everything is fine.

     

    Regards,

    Jorge rocha



  • 5.  Re: CA AUTOMIC AWA r12.2 initial Db Load crashes with PostGreSql 9.4, 9.6 and 10.5

    Posted 08-28-2018 05:44 PM

    Hey Jorge,

     

    Thanks for the help! I was able to get the database loaded with these hints.

     

    Regards,

     

    Michael