DX Application Performance Management

Expand all | Collapse all

How to ignore agent named 'WebLogic Server' before Auto naming function?

Jump to Best Answer
  • 1.  How to ignore agent named 'WebLogic Server' before Auto naming function?

    Posted 06-20-2018 11:16 PM

    Hi,

    After agent installation and start the WLS, I always see an agent named WebLogic Server for a while. After the auto-naming, the agent name will be turned into their real name.

     

    It's really inconvenienced if customers ask me why there is a disconnected agent.

    Is there a way to control the agent to report to EM when it finishes the auto-naming function?

     

    Thanks. 



  • 2.  Re: How to ignore agent named 'WebLogic Server' before Auto naming function?
    Best Answer

    Posted 06-20-2018 11:46 PM

    Hi Gary,

    By default the agent will wait 2 minutes (120 seconds) for auto-naming to complete before trying to connect to EM, so you can test increasing that value in increments until the auto-naming kicks in before the EM connection is made: 

    Java Agent Naming - CA Application Performance Management - 10.5 - CA Technologies Documentation 

    Java Agent Properties - CA Application Performance Management - 10.5 - CA Technologies Documentation 

     

    Hope that helps

     

    Regards,

     

    Lynn



  • 3.  Re: How to ignore agent named 'WebLogic Server' before Auto naming function?

    Posted 06-21-2018 12:21 AM

    Hi Lynn,

    Thanks for your response. It should solve my problem.

    I'm wondering the same problem happened in Command Center either.

    I don't see any related setting within apmccctrl.properties file.

     

    Is there a way to solve this in ACC?

     

    Thank you.



  • 4.  Re: How to ignore agent named 'WebLogic Server' before Auto naming function?

    Posted 06-21-2018 02:29 AM

    Hi Gary,

    I also think that would require an agent profile side property to delay the connection of the agent to the ACC Agent Controller. From my agent log I can only find these acc related properties

    introscope.agent.acc.enable
    introscope.agent.acc.port: default value of "51914"
    introscope.agent.acc.heartbeat: default value of "1440" (heartbeat test every 24 hours)
    introscope.agent.acc.poll: default value of "300000" (polling interval of 5 minutes)

     

    As introscope.agent.acc.enable is dynamic you could change it from false to true after the agent auto-naming time has passed and maybe automate that with a script that gets called as part of WebLogic instance startup (required "sleep" delay at the start of the script)?

     

    Regards,

     

    Lynn



  • 5.  Re: How to ignore agent named 'WebLogic Server' before Auto naming function?

    Posted 06-21-2018 05:14 AM

    Hi Lynn,

    Thanks for your suggestion.

    It's a sophisticated way to solve this issue.

    I'll try and see what happen

     

    Thank you again.