Service Virtualization

Expand all | Collapse all

Live system execution responds interleaved 1 ok and one "target server failed to respond"

Jump to Best Answer
  • 1.  Live system execution responds interleaved 1 ok and one "target server failed to respond"

    Posted 09-28-2018 07:22 PM

    Hi everyone,

    When use the live system execution mode, the live system responds interleaved.

    1 response is ok but the next one shows an error "target server failed to respond".



  • 2.  Re: Live system execution responds interleaved 1 ok and one "target server failed to respond"

    Posted 09-29-2018 01:23 AM

    Hi Luis,

     

    This behavior of interleaved “now it works as expected” and “now it doesn’t” most often comes when there are 2 virtual services in “Running” mode on the VSE and they have been deployed with the same base-path and are listening on the same port.

     

    In that case the VSE does a round-robin with the incoming requests and giving the request on turn to the first and then to the second.

     

    If that is not the case, and it is only once deployed and shows this odd behavior, is this a customized .vsm? If so, what was customized?

     

    Cheers,

    Danny



  • 3.  Re: Live system execution responds interleaved 1 ok and one "target server failed to respond"

    Posted 09-30-2018 12:29 PM

    Hi Danny,

     

    I'm only deployed a virtual service on one single port, the only thing I customized was the ip, port and path of virtual Http/s live invocation step to communicate to the live system.

    I verified the communication between components, firewall, antivirus but still getting the same error.

     

    Regards.



  • 4.  Re: Live system execution responds interleaved 1 ok and one "target server failed to respond"

    Posted 10-01-2018 06:05 AM

    Hi Luis,

     

    Are you saying that in your VSE there is only one (1) virtual service deployed, nothing else is running, only this one virtual service? Can you navigate to the below url using a browser and send us the result of this query?

     

    http://

     

    RegistryServerHost: the hostname where the registry is running

    yourVseName: the name of your Virtual Service Environment, the default name is VSE (this is not the name of your virtual service)

     

    Example: http://localhost:1505/api/Dcm/VSEs/VSE

     

    Cheers,

    Danny



  • 5.  Re: Live system execution responds interleaved 1 ok and one "target server failed to respond"
    Best Answer

    Posted 10-01-2018 11:10 AM

    Hello Luis,

     

    Please, take a look at this document:

    The use of the lisa.vse.http.live.invocation.max.i - CA Knowledge 

     

    Try to set the property below in the local.properties in the VSE Server and restart the VSE service:

    lisa.vse.http.live.invocation.max.idle.socket=20s

     

    See how it helps.

     

    Thank you,

    Heloisa



  • 6.  Re: Live system execution responds interleaved 1 ok and one "target server failed to respond"

    Posted 10-01-2018 06:21 PM

    Hi Maria and Danny,

     

    Thanks so much for your help, now It works.

    I agregated:

    lisa.vse.http.live.invocation.max.idle.socket=20s

    to the local.properties.

     

    Regards.