Automic Workload Automation

Expand all | Collapse all

install windows agent

  • 1.  install windows agent

    Posted 10-10-2017 01:27 AM
    Hi,

    I have installed windows agent, the installation succeeds. But how do I install service manager or make it run as windows service? And how to configure the ini file.

    https://docs.automic.com/documentation/webhelp/english/ALL/components/AE/9/All%20Guides/Content/ucaaku.htm I read this but it seems not help me too much.


  • 2.  install windows agent

    Posted 10-10-2017 01:43 AM
    Once you installed the Service Manger, open a command line and run the following command from the ServiceManager\bin directory: ucybsmgr -install <Phrase>.

    https://docs.automic.com/documentation/webhelp/english/ALL/components/AE/9/All%20Guides/Content/ucaajx.htm

    Then you will see a new service in your services.msc called UC4.ServiceManager[Phrase]

    59qcfroz5ivv.pnghttps://us.v-cdn.net/5019921/uploads/editor/nh/59qcfroz5ivv.png" width="585">

    By default it uses the ""Local System" account, but you can also start it with any other user you want too.

    Then you can switch to the Service Manager Dialog and start the Windows agent from this component.

    With a right click on the Windows agent you can adjust command and path like in the screenshot below:

    5na7pjtdv5fq.pnghttps://us.v-cdn.net/5019921/uploads/editor/wi/5na7pjtdv5fq.png" width="516">





  • 3.  install windows agent

    Posted 10-10-2017 01:50 AM
    You will need to install the Service Manager Utility to install the service and run the 'ucybsmgr.exe -install phrase' command.
    Your definition file (.smd) needs a  DEFINE line similar to this:
    DEFINE ServerName;*OWN\..\..\Agents\Windows\bin\UCXJWX6.exe;*OWN\..\..\Agents\Windows\bin 

    This will explain more detail...
    https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/12.0/AWA%20Guides/help.htm#AE_AWA_Source/Administration/ucaazn.htm

    Your agent .ini file should have your server name=, system= and cp= all defined.




  • 4.  install windows agent

    Posted 10-10-2017 02:55 AM
    Mike Halliday said:
    You will need to install the Service Manager Utility to install the service and run the 'ucybsmgr.exe -install phrase' command.
    Your definition file (.smd) needs a  DEFINE line similar to this:
    DEFINE ServerName;*OWN\..\..\Agents\Windows\bin\UCXJWX6.exe;*OWN\..\..\Agents\Windows\bin 

    This will explain more detail...
    https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/12.0/AWA%20Guides/help.htm#AE_AWA_Source/Administration/ucaazn.htm

    Your agent .ini file should have your server name=, system= and cp= all defined.


    I see that there is a checkbox authenticated in the UC4 UserInterface. Can you explain a bit more about it? 


  • 5.  install windows agent

    Posted 10-10-2017 07:38 PM
    Phat Tran said:
    I see that there is a checkbox authenticated in the UC4 UserInterface. Can you explain a bit more about it? 
    We have UC_AS_SETTINGS configured to set AUTHENTICATION = NO.  So the checkbox is greyed out for us.

    If you are enabling authentication you will need to create a company key an authorise each agent to connect to your system.  To be honest I've never used it, I believe it's setup in the initial DB Load but can be changed.


  • 6.  install windows agent

    Posted 10-11-2017 12:59 AM
    Hi, I install the agent and service manager and assign it to my client. But I cannot start it
    zo36ty6i6n02.png
    Why the port 0 appear here? I already set the port to my agent ini file.

    I install agent and service manager as default.

    I use this command ucybsmgr -install UC4_TEST


  • 7.  install windows agent

    Posted 10-11-2017 01:58 AM
    Phat Tran said:
    Hi, I install the agent and service manager and assign it to my client. But I cannot start it
    zo36ty6i6n02.pnghttps://us.v-cdn.net/5019921/uploads/editor/6v/zo36ty6i6n02.png" width="468">
    Why the port 0 appear here? I already set the port to my agent ini file.

    Which application raises this exception?
    Furthermore can you please provide the INI configuration files for Agent, ServiceManager and ServiceManager Dialog.


  • 8.  install windows agent

    Posted 10-11-2017 02:30 AM
    peter_grundler_automic,

    I found the root cause, in the license class I put wrong info.


  • 9.  install windows agent

    Posted 10-11-2017 04:42 AM
    Hello,

    I can start my agent with service manager, but from UC4 console, I'm missing the "Start" command in right-click menu.
    wsnwbr8fn3dn.png

    How can I make it available now?


  • 10.  install windows agent



  • 11.  install windows agent

    Posted 10-11-2017 06:48 AM
    FrankMuffke
    Great help :) tks so much


  • 12.  install windows agent

    Posted 10-11-2017 08:39 AM
    You re welcome...