Automic Workload Automation

Expand all | Collapse all

OpenJDK support

  • 1.  OpenJDK support

    Posted 05-22-2017 08:07 AM
    The Automic compatibility matrix lists the Java environments supported for various Automic apps. Here are some examples.
                           
     

    Product

     
     

    Component

     
     

    Sub-component

     
    Version
     

    Java environment(s) supported

     
     

    Automic Workload Automation

     
     

    Automation Engine

     
     

    Application Interface

     
    12.0.1
     

    Oracle Java 1.8

     
     

    Automic Workload Automation

     
     

     Automic Web Interface

     
     

    UI

     
    12.0.1
     

     Oracle Java 1.8

     
    Automic Workload Automation
    Automation Engine
    Agent RA Core
    12.0.1
    Oracle Java 1.7
    Oracle Java 1.8
    Automic Workload Automation
    RA Informatica
    RA Informatica Solution
    5.0.0
    Oracle Java 1.6
    Oracle Java 1.7
    Oracle Java 1.8
    OpenJDK is not specifically mentioned. OpenJDK is based on the same code base as Oracle Java, and is the Java environment used in many cloud computing environments such as Cloud Foundry. We are working to enable applications to run in the cloud, and want to ensure that we run the apps in a supported configuration. As more and more customers adopt cloud computing, it will become increasingly important for Automic to support these environments.

    Will Automic commit to support the same versions of OpenJDK as Oracle Java?


  • 2.  OpenJDK support

    Posted 05-23-2017 05:12 AM
    We also run several applications in WebSphere, where IBM Java is the only available JRE. We note that Automic supports IBM Java on AIX. Can Automic also support this Java environment on other platforms such as Linux?


  • 3.  OpenJDK support

    Posted 05-29-2017 06:31 AM

    I submitted two new enhancement requests for this:



  • 4.  Re: OpenJDK support

    Posted 08-29-2018 11:30 AM

    Have this discussion with Automic for more than two years. We are using SAP agents which are running with OpenJDK installed with SLES 12.  See it also critical for AWI and other Tomcat applications like RequestTool which depend on JRE. 
    Now with new Oracle license politic for Java there seem to be three options.  (1.) Automic has to license JRE and provide it to customer in the package and do update on regular base (2.) Each customer has to sign expensive commercial JRE license with Oracle or (3.) Compatibility matrix get extended and Open JDK is usable / valid.

     

    Thank you for opening request.