Workload Automation1

Expand all | Collapse all

Assigned new IP address to server hosting EEM, how do I get WLA AE and the WCC to recognize it?

Jump to Best Answer
  • 1.  Assigned new IP address to server hosting EEM, how do I get WLA AE and the WCC to recognize it?

    Posted 10-10-2017 01:18 PM

    WLA AE and the WCC are on Server A, and the EEM is on Server B.  Both servers were moved and assigned new IP addresses. Now I can't sign into the WCC on Server A because it can't connect to the EEM instance on Server B.  I ran as_safetool and autosys_secure on Server A and (I thought) pointed it to the EEM server but that didn't work.  When I sign into the EEM server (global) I can see the Applications "WorkloadAutomationAE" and "WCC0003" on it -- and it still has the old IP address of Server A (where WLA AE and WCC runs).  The hostnames did not change, btw.



  • 2.  Re: Assigned new IP address to server hosting EEM, how do I get WLA AE and the WCC to recognize it?
    Best Answer

    Posted 10-11-2017 02:47 AM

    Hi Leo,

     

    You said: "When I sign into the EEM server (global) I can see the Applications "WorkloadAutomationAE" and "WCC0003" on it -- and it still has the old IP address of Server A (where WLA AE and WCC runs)."

     

    Are you referring to the IP address under Configure -> Applications -> WorkloadAutomationAE -> Install Host Address: ?

    If yes, then that is pretty much static, so do not worry about it.

     

    "I ran as_safetool and autosys_secure on Server A and (I thought) pointed it to the EEM server but that didn't work."

    What didn't work? Did you register with EEM hostname or IP?

     

    Also, you mentioned the hostname remains the same. So long as Server A can resolve Server B's hostname, then I believe there shouldn't be any issue. Please check if the hosts file on Server A points to the correct (new) IP for Server B.

     

    It might be worth a try, to restart WAAE and WCC services once if you haven't tried already so that the any cached DNS records are cleared. If you're on Windows try DNS flush as well. If you're on Linux, then flushing NSCD (name service cache daemon) hosts database might help. Please check with your System Admins regarding DNS flush.

     

    Cheers,

    Chandru



  • 3.  Re: Assigned new IP address to server hosting EEM, how do I get WLA AE and the WCC to recognize it?

    Posted 10-11-2017 03:10 AM

    Hi Leo,

     

    In Addition to the above suggestions. If the restart of the services does not fix it. You can consider the following documentation.

    Configure a New CA EEM Instance with Existing CA WCC Security Policies

    https://docops.ca.com/ca-workload-automation-ae/11-4-2/en/securing/ca-eem-security-data-replication-backup-and-migration/configure-a-new-ca-eem-instance-with-existing-ca-wcc-security-policies

     

    This gives steps to take a backup of existing security policies and then deregister and set it up again. Please let us know if you need further clarifications.