Clarity PPM

Expand all | Collapse all

Scheduled reports not working as expected.

  • 1.  Scheduled reports not working as expected.

    Posted 03-13-2018 06:05 AM

    Jasper report is scheduled to run on 5th of every month. This used to work earlier, but It's not sending any email notifications.

     

    I have searched with the report name and couldn't find any extract in the Advanced reporting side.



  • 2.  Re: Scheduled reports not working as expected.

    Posted 03-13-2018 06:15 AM

    Hi,

     

    Hope the schedule is still there. Is the save to repository is checked in the schedule? Is the email functionality is working for jasper reports now?

     

    Thanks

    Agin



  • 3.  Re: Scheduled reports not working as expected.

    Posted 03-13-2018 12:24 PM

    Do you have the stack trace enabled in report notification to see what the error you are seeing. If the report is not found in repository output then probably it failed to run and you should start looking at Jasper server log and having stack trace will give you that log 



  • 4.  Re: Scheduled reports not working as expected.

    Posted 03-14-2018 03:48 AM

    No email notification was sent. There is no extract prepared in the Output folder(Destination folder).



  • 5.  Re: Scheduled reports not working as expected.

    Posted 03-14-2018 05:01 AM

    yes that means the report had failed and if you had stack trace you will get to know why it failed else you have to keep scanning Jasperserver.log 



  • 6.  Re: Scheduled reports not working as expected.

    Posted 03-14-2018 06:44 AM

    How to search in the Jasperserver.log ? where can i find this ?



  • 7.  Re: Scheduled reports not working as expected.

    Posted 03-14-2018 07:17 AM

    it will be available in (jaspersoft tomcat)/reportservice/webapps/WEB-INF/logs/jasperserver.log

     

    Thanks,

    Agin



  • 8.  Re: Scheduled reports not working as expected.

    Posted 03-15-2018 06:15 AM

    I have issue with the schedule report on monthly basis.

     

    The scheduled report has completed the run and it shows the Last run date and also showing the next run date. There is no report extract placed at the destination folder.

     

    Email notification was sent saying that report run as "PASS" , but the extract was not sent to the email. I have seen that the Option was checked "Include report files as ZIP attachment".

     

    Is this any Bug ? or It there any limitation with the report file size generated.?



  • 9.  Re: Scheduled reports not working as expected.

    Posted 03-15-2018 06:40 AM

    Which version of jaspersoft & CA PPM you are using ? If you are receiving email notification saying that report run as "PASS" means report ran successfully. May be mail server attachment size limit is the reason for not receiving the extract.

    nceSuch cases also, report has to be saved to the repository. Hence, you need to enable trace in Jasperserver to get more on this issue?

     

    Thanks,

    Agin



  • 10.  Re: Scheduled reports not working as expected.

    Posted 03-15-2018 06:50 AM

    Its 15.2 version CA PPM, Jasper - 6.2.1.
    when I scheduled the report after I receive the email that report run has "PASS" after couple of minutes i used to get the email having the report extract attachments.

     

    In this case the report attachment was not sent and the report extract is not placed at the destination folder.

     

    We can assume that if the report extract was more than 25 MB , which cannot be attached in emails, but I don't think there is limitation with the destination folder.

     

    Yes Stack trace was checked during report schedule.



  • 11.  Re: Scheduled reports not working as expected.

    Posted 03-15-2018 09:22 AM

    I believe there is no size limitation in the destination folder. It must be saved in the destination folder. 

     

    Could you please try with a fresh schedule and check. If that also gives the same issue, then try enabling "Timing for SQL queries run for reports" in DEBUG mode under log settings in jasper console,which will show the 'Logs the time it takes a query run by the SQL query executer to return data to a report' (to see its completing).

     

    Thanks,

    Agin



  • 12.  Re: Scheduled reports not working as expected.

    Posted 03-16-2018 01:52 AM

    What was the stack? Can you post the stack trace



  • 13.  Re: Scheduled reports not working as expected.

    Posted 03-16-2018 09:01 AM

    are you talking about Stack trace(exception file) ?



  • 14.  Re: Scheduled reports not working as expected.

    Posted 04-02-2019 05:37 AM

    In one of the case we got below exception shared by Support team from jasper logs.

    /**************************************************************************************************************************/

    2019-01-04 06:00:31,079 ERROR HibernateDaoImpl,quartzScheduler_Worker-6:111 [] - ************** HibernateDaoImpl.executeWriteCallback EXCEPTION **********
    com.jaspersoft.jasperserver.api.JSDuplicateResourceException: jsexception.resource.already.exists
    Arguments: "/organizations/myorg/Custom_Tasks_Report.xls",
    at com.jaspersoft.jasperserver.api.metadata.common.service.impl.hibernate.HibernateRepositoryServiceImpl.getRepoResource(HibernateRepositoryServiceImpl.java:695)
    at com.jaspersoft.jasperserver.api.metadata.common.service.impl.hibernate.HibernateRepositoryServiceImpl$14.execute(HibernateRepositoryServiceImpl.java:578)
    at com.jaspersoft.jasperserver.api.metadata.common.service.impl.HibernateDaoImpl.executeWriteCallback(HibernateDaoImpl.java:83)

    Deleting and recreating the scheduled report works only temporarily.



  • 15.  Re: Scheduled reports not working as expected.

    Posted 04-02-2019 11:52 AM

    We have seen this happen when the report is misfiring. I recommend you trying to reschedule the report at another time, such as +- 1 hour. This usually helps to resolve the issue permanently. Here is the KB: 

    https://comm.support.ca.com/kb/scheduled-report-is-sent-out-blank-in-email/KB000127868