DX Infrastructure Manager

Expand all | Collapse all

USM does not deploy latest version robot

  • 1.  USM does not deploy latest version robot

    Posted 03-08-2018 08:16 PM

    Even though we have a latest robot update downloaded in the local archive but while the deploying robot via USM, Robot version shipped  with UIM 8.5.1 is being deployed. 


    All robots are required to update to the latest version after deployment. 


    Is there anyway to push the latest robot version during robot deployment process via USM?



  • 2.  Re: USM does not deploy latest version robot

    Posted 03-08-2018 08:35 PM

    Hi ,

     

    You can deploy the latest native installers like robot.exe , robot_deb etc to your Primary HUB from archive

    Example
    It will update <UIM_install_folder>/install/setup/nimsoft-robot*.exe. etc 



  • 3.  Re: USM does not deploy latest version robot

    Posted 03-09-2018 03:38 AM

    Indeed, as said by Franklin, you have to update in your achives all the packages:

    • robot_update
    • all individual robot version (that's the one taken for initial deployment)


  • 4.  Re: USM does not deploy latest version robot

    Posted 03-09-2018 03:42 AM

    Yes, when you push the robot out using USM it doesn't use the robot_update package, it uses the robot installers which come with the install.



  • 5.  Re: USM does not deploy latest version robot

    Posted 03-09-2018 04:41 AM

    for usm gui based robot deploy - here.

    TECH TIP : How to get updated Robot native installer