Layer7 API Management

Expand all | Collapse all

Production Error, API Gateway KO.

  • 1.  Production Error, API Gateway KO.

    Posted 03-17-2018 03:33 PM

    Suddenly we find that the Gateway responds with error, we do not know how to solve it, someone has happened.

    • We have reviewed the licenses and they are valid.. 
    • We can not reinstall the gateway because it is a production environment.

     

    -- Policy Manager --

     

    -- Response -- 

    <?xml version="1.0" encoding="UTF-8"?>

    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">

        <soapenv:Body>

            <soapenv:Fault>

                <faultcode>soapenv:Server</faultcode>

                <faultstring>Error in assertion processing</faultstring>

                <faultactor>https://api.xyz.com/v1/adicional?none=53</faultactor>

                <detail>

                    <l7:policyResult

                        status="Assertion not available: Unknown assertion: ValidateCertificate" xmlns:l7="http://www.layer7tech.com/ws/policy/fault"/>

                </detail>

            </soapenv:Fault>

        </soapenv:Body>

    </soapenv:Envelope>



  • 2.  Re: Production Error, API Gateway KO.

    Posted 03-18-2018 05:21 PM

    Hello,

     

    We have copied one of the assertion that has the problem to a text editor, and the result was this :

     

    <?xml version="1.0" encoding="UTF-8"?>

    <wsp:Policy xmlns:L7p="http://www.layer7tech.com/ws/policy" xmlns:wsp="http://schemas.xmlsoap.org/ws/2002/12/policy">

        <wsp:All wsp:Usage="Required">

            <L7p:ValidateCertificate>

                <L7p:SourceVariable stringValue="request.ssl.clientCertificate"/>

                <L7p:ValidationType certificateValidation="PATH_VALIDATION"/>

            </L7p:ValidateCertificate>

        </wsp:All>

    </wsp:Policy>

     

    The assertion where they are stored?. Could it be a problem of permits or access to assertion ?.

     

    Greetings,



  • 3.  Re: Production Error, API Gateway KO.

    Posted 12-19-2018 05:42 PM

    Good afternoon,

     

    Both of the assertion complaining about being now available are core assertions to the product and should be available no matter what level of license you have. We have seen this happen if permissions where changed against modular or  custom assertion that we uploaded to the gateway through SSH. Were you able to get this resolved?

     

    Sincerely,

     

    Stephen Hughes

    Broadcom Support