CA Client Automation

Expand all | Collapse all

Error executing DSMNetworkDiag

Jump to Best Answer
  • 1.  Error executing DSMNetworkDiag

    Posted 08-03-2017 05:37 PM

    Personally, I'm running DSMNetworkDiag on Domain Manager, but this error is showing up.

     



  • 2.  Re:  Error executing DSMNetworkDiag

     
    Posted 08-03-2017 05:42 PM

    What version of Client auto are you running.  I am not sure the utility has been updated recently to match the newer client auto versions.

     

    Richard Lechner

    Principal Engineering Services Architect

     

    CA Technologies

    Mobile: +1 703 655 7161 | Richard.Lechner@ca.com

     

    <mailto:Richard.Lechner@ca.com>[CA]<http://www.ca.com/us/default.aspx>[Twitter]<http://twitter.com/CAInc>[Slideshare]<http://www.slideshare.net/cainc>[Facebook]<https://www.facebook.com/CATechnologies>[YouTube]<http://www.youtube.com/user/catechnologies>[LinkedIn]<http://www.linkedin.com/company/1372?goback=.cps_1244823420724_1>[Google]<https://plus.google.com/CATechnologies>[Google+]<http://www.ca.com/us/rss.aspx?intcmp=footernav>



  • 3.  Re:  Error executing DSMNetworkDiag

    Posted 08-03-2017 06:54 PM

    Running CA Client Auto 14

     

    Obter o Outlook para Android<https://aka.ms/ghei36>



  • 4.  Re:  Error executing DSMNetworkDiag

    Posted 08-08-2017 11:50 AM

    I've confirmed the same popup error, after finding and trying the tool.  I'd have to say this tool is obsolete as it's from May 2009, which is the 11.2 SP4 / 12.0 GA era.  This tool requires updating from engineering in order for it to work with current releases of ITCM.  What was your reason for running the tool in the first place?  Maybe we can help with the problem you're trying to troubleshoot instead...



  • 5.  Re:  Error executing DSMNetworkDiag

    Posted 08-08-2017 11:55 AM

    Hello Brian, in other versions of ITCM, it was very useful to diagnose communication problems between Scalability and Domain. I'm going through a situation where the cam does not communicate and another where the caf does not communicate.



  • 6.  Re:  Error executing DSMNetworkDiag

    Posted 08-08-2017 12:08 PM

    I've tried the tool on ITCM 12.9 and I received the same error.  I don't have anything older to test to check where this stopped working.  Honestly I wasn't aware of this tool-- is there a particular KB or site where you pulled this tool from?

     

    For CAM/CAF communication issues, most are these are usually due to required ports not being opened:

    UDP 4104

    TCP 4728,7163

     

    The above are the basic ports and they need to be opened in both directions.

     

    For CAM, camping is our litmus test.  If the camping does not work between two endpoints, then likely UDP 4104 is being blocked or is not reachable.

     

    DNS could also be a factor as well-- is a normal ping of the endpoint name, resolving to the correct IP, in both directions?

     

    If CAM pings are working, but CAF pings are not, there could be a few additional factors--

     

    1- UDP filtering.  A default camping sends only 64 bytes of data.  When CAF performs a ping or communicates in general, the data is larger, and is possibly being filtered.  To adjust for this, you can add "fragment_size = 1024" in your cam.cfg file.  1024 is just a suggestion.  This informs CAM to send packets no larger than 1024 bytes.  I've seen several cases where UDP is filtered when the packet size is above a particular number, and a cam.cfg is necessary to control the packet size.

     

    2- Certificates.  If two endpoints are using custom certificates for ITCM, and those certificates are not matching, then CAF ping would fail.

     

    Hope this helps get you started.  I just don't see that tool getting updated in the near future.



  • 7.  Re:  Error executing DSMNetworkDiag
    Best Answer

    Posted 08-08-2017 12:17 PM

    Hi Brian, I remember that in version 12.5 it worked very well, however, I went back to working with ITCM in version 14 and it did not work anymore. In this link, you will have more details of the tool.

    CA IT Client Manager Network Diagnostic Tool - CA Technologies 



  • 8.  Re:  Error executing DSMNetworkDiag

    Posted 08-09-2017 09:06 AM

    Hello, I see this question has already been answered but got curious on why it fails.

    The error is related to a call to the current dbbkstor.dll from the provided old dlls in the tool so why not to use the dlls from the installed Itcm version?

    So, removed the dlls from the DSMNetworkDiag directory, added two targets in my xml file and worked fine. Now I have the htm reports and also a TRC_CF_DSMNETWORKDIAG_0.log under DSM\logs.

    Hope this helps too.

    Cheers, Xavi.



  • 9.  Re:  Error executing DSMNetworkDiag

    Posted 08-09-2017 10:53 AM

    It worked perfectly, thank you my friend!!!!