Layer7 Access Management

Expand all | Collapse all

PDF Form submit(POST) - Data getting lost after IIS/IWA

  • 1.  PDF Form submit(POST) - Data getting lost after IIS/IWA

    Posted 04-10-2017 06:03 PM

    Could someone help me to figure it out what's going on in the below scenarios:

     

    Working scenario: Access online pdf form via url --> fill in data--> submit(post) to app url--> webagent/IIS intercepts --> windows auth success --> redirect to app --> data getting submitted without loss and POST header stays as POST.


    Failure Scenario: offline Pdf(already saved copy) form -->fill in data--> submit(post) to app url--> webagent/IIS intercepts --> windows auth success--> redirect to app -->  lost all the submitted data and POST header is getting converted to GET.

     

    Only difference between both of the above scenarios is offline and online pdf submission. And even offline scenario works with Basic auth.

     

    Yes, I did try "PreservePostData=yes" which did not help.

     

    Is this the expected behavior ? or does IIS/webagent need any additional config ?

     

    Regards

    Ashok



  • 2.  Re: PDF Form submit(POST) - Data getting lost after IIS/IWA

    Posted 04-10-2017 07:41 PM

    HI Ashok, it would be good to compare a fiddler trace of both the working and not-working senario.  post preservation should retain the POST data, and end up with a POST - as it does in your first example.

     

     

    Cheers - Mark

    ----
    Mark O'Donohue
    Snr Principal Support Engineer - Global Customer Success