Layer 7 API Management

Expand all | Collapse all

"Set to Private" does not appear in API menu

Jump to Best Answer
  • 1.  "Set to Private" does not appear in API menu

    Posted 04-06-2017 11:07 AM
      |   view attached

    Hi,

     

    From API Portal, using admin account, I'm able to set one API to private using "Set to Private" in the menu associated to this API.

    But, "Set to Private" does not appear in the menu associated to another API. 

    See attachment.

    Please advice, how to set to private an API, if this does not appear in the menu ?

     

    Thanks,

    Best Regards,

     

    Corinne

    Attachment(s)

    pptx
    question private API.pptx   333K 1 version


  • 2.  Re: "Set to Private" does not appear in API menu
    Best Answer

    Posted 04-06-2017 02:26 PM

    Connie,

     

    The reason for the behavior you are seeing is that the API which doesn't have the option to "Set to Private" is already associated with applications (4 apps in this case). Whereas the API which does have the option available is not associated with any applications yet. You would either need to set the API to private prior to associating it with applications, or in this case you would need to first disassociate the API from all applications, set it to private, then re-associate the applications to the API.

     

    Regards,

    Azad



  • 3.  Re: "Set to Private" does not appear in API menu

    Posted 04-18-2017 07:16 AM

    Thanks, understood. This helps !

    Thanks a lot !

    Regards,

    Corinne