Layer7 Access Management

Expand all | Collapse all

Secure Proxy - Issues post installation & configuration

Jump to Best Answer
  • 1.  Secure Proxy - Issues post installation & configuration

    Posted 08-11-2016 08:30 AM

    Hello All,

     

    I am trying to install SPS in lab environment and able to install and configure successfully. But I couldn't see a functioning SPS i.e. assertion retriever or proxyui are not working.

     

    Setup:

     

    OS : Windows

    SM:

    ProductName=CA Single Sign-On Policy Server

     

    FullVersion=12.52.200.6411

     

    SPS:

    Product Name=CA SiteMinder Secure Proxy Server

    FullVersion=12.52.0100.499

    Version=12.52

    Update=0100

    Build Number=499

    Location=C:\Program Files (x86)\CA\secure-proxy

    InstanceName=default

     

    Java: 32bit jdk1.6.0_45... Unlimited Strength JCE files are placed.

     

    Few Errors from Server log:

     

    [ERROR] - java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\CA\secure-proxy\agentframework\bin\SPS60Agent.dll: The specified procedure could not be found

     

     

    Attached the logs for more info. Could you help me to get it resolved?

    Attachment(s)



  • 2.  Re: Secure Proxy - Issues post installation & configuration

    Posted 08-11-2016 01:12 PM

    Please open a support case for this configuration issue.

     

    Thanks.



  • 3.  Re: Secure Proxy - Issues post installation & configuration
    Best Answer

    Posted 08-11-2016 07:16 PM

    Hi Saravanan,

     

    The errors in the nohup.log and server.log are suggestive of some broken links/ references:

     

    FATAL ERROR: Exception from System.loadLibrary java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\CA\secure-proxy\agentframework\bin\smjavaagentapi.dll: The specified procedure could not be found

    FATAL ERROR: Exception from AgentAPI.initialize() java.lang.UnsatisfiedLinkError: netegrity.siteminder.javaagent.AgentAPI.initialize()V

     

    [FATAL] - Exception caught stack trace below: java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\CA\secure-proxy\agentframework\bin\SPS60Agent.dll: The specified procedure could not be found

     

    Try using Dependency Walker or Process Explorer to trace the SPS startup process and check if there's permission or error loading the library files.



  • 4.  Re: Secure Proxy - Issues post installation & configuration

    Posted 09-01-2016 05:33 AM

    Hi

    make sure your windows version is supported by the SPS version you are installing. If all it's correct you should open a case to the support site.

     

    Regards

    Alessandro