DX Application Performance Management

Expand all | Collapse all

Anyone using SOI Connector v2.2.0.81 with APM 10.1?

  • 1.  Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-03-2016 04:44 PM

    I've recently upgraded from APM v9.5.3 to APM v10.1


    We were using SOI Conn 2.2.0.81 with APM v9.5.3 and was working well. After I upgrade APM to v10.1 SOI Connector is not polling raw data properly. We are not seeing CEM Business Services nor Transactions.

     

    Has anyone experienced any issues using SOI Connector 2.2.0.81 with APM v10.1?

     

    Thanks in advance

    Manish



  • 2.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-09-2016 10:39 PM

    Hi again mparikh72,

     

    currently the integration with SOI does not work with APM 10.1+ due to a change on how the (application) map is generated (from dedicated tracers to transaction traces).

     

    You can try setting introscope.apm.appmap.legacy.data.source=true. This will use the data from the agents to build the map. It will probably create the data structures used by the SOI integration as well but I'm not 100% sure.

     

    Jeff_Morris, MichaelBoehm - do you know if there is an updated connector or APM 10.1+ integration?

     

    Ciao,

    Guenter



  • 3.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-10-2016 12:12 PM

    Guenter_Grossberger

    We have upgraded our SOI Connector to v2.2.0.82 a few weeks ago. Are there any issues with that and v10.1?

     

    bchou Jeff_Morris MichaelBoehm



  • 4.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-10-2016 04:20 PM

    Guenter_Grossberger

    So, I did change that property to "true" and recycled the MoM, still no joy

     

    I've opened up a not discussion SNMP Alert Action not Triggering in APM 10.1

     

    APM v10.1, the SNMP Alert Action is not triggering even though the threshold as been breached by the alert. I had an additional action (email) to make sure it wasn't "any" action that's not triggering. The email action is triggering but the "Sending SNMP Trap to SOI Conn" is not triggering (based on MoM logs) 



  • 5.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-11-2016 08:41 AM

    Hi Manish:

       I am following both threads. Hopefully Lynn's and Hiko's last notes help

       Failing that, consider opening a case

     

    Thanks

    Hal German



  • 6.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-11-2016 10:08 AM

    Ok thanks Hallett_German



  • 7.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-10-2016 12:14 PM

    Guenter_Grossberger

    is introscope.apm.appmap.legacy.data.source=true property on the agent or on the Collector?



  • 8.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-10-2016 12:23 PM

    nvrmd Guenter_Grossberger, I found that property on the MoM. Does it require a recycle of EM/MoM?



  • 9.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-11-2016 05:10 PM

    Hi Manish,

    In the test I ran for your related thread Re: SNMP Alert Action not Triggering in APM 10.1 I had a standalone EM with the legacy property enabled i.e. introscope.apm.appmap.legacy.data.source = true

    From my research it should only need to be set on the MOM & then restart is needed.

    Configure the Team Center Map - CA Application Performance Management - 10.2 - CA Technologies Documentation

     

    Unrelated, but if that property is not set to true in 10.1 the exception reported in this KB may appear. Not sure if that applies to any EM i.e. Collectors as well, but if you do see it I would suggest setting the property on the whole cluster & restarting:

    "APM 10.1 EM restart shows java.lang.StackOverflowError log entry"

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec1730457.aspx

     

    Regards,

     

    Lynn

    Attachment(s)



  • 10.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-11-2016 05:16 PM

    I just spoke to Engineering and there is some Collector related code that also uses the legacy setting so the advice is to set

    "introscope.apm.appmap.legacy.data.source = true" on all EMs and restart the whole cluster.



  • 11.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-12-2016 09:50 AM

    Lynn_Williams

    So, we have upgraded to SOI Conn v2.2.0.82. Do I still need to edit that property on all EMs? We've been working with Jeff_Morris also on this effort also. He has suggested to test out the new v3.0 code for SOI Conn for APM.

     

    Hallett_German - I'd like to leave this discussion open till I have an update.

     

    Thanks

    Manish



  • 12.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-12-2016 09:57 AM

    Hi Manish:

    This is marked as a discussion. So there is no concept of open or closed

     

    Thanks

    Hal German



  • 13.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-12-2016 10:01 AM

    Just to clarify for all who are reading this thread

    1) It's true that the 2.2 connector doesn't support the new Relationship Map structure which is part of APM 10.1

    2) From the diagnosis I've done with your team, Biing, and Scott Hahn, your issue does not seem to be related to this issue.  On the surface it appears that it may be a defect in the 2.2 connector, but I need to research it further

    3) I have data and logs from your environment and am researching the root cause of this issue - I will advise as soon as possible

    Regarding the APM Connector 3.0, this is currently in beta.  My comment to Scott about this was that if this turns out to be a defect, it will likely be the best course of action to correct it in this new version, since it will also support the 10.1 Relationship Map.

    Hope this clarifies the situation,

    Jeff



  • 14.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 05-12-2016 10:09 AM

    Jeff_Morris

    Yup, crystal clear. Thanks for that update.

     

    Awaiting feedback from Lynn_Williams if I still need to update that property, "introscope.apm.appmap.legacy.data.source = true", on all EMs (on APM side) , after upgrading SOI Conn to v2.2.0.82

     

    Thanks

    Manish



  • 15.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 06-06-2016 04:09 PM

    I am working on upgrading APM to 10.1 as well.  I would be happy to test the new SOI 3.0 beta connector, too.  Any way I can get on that trial?



  • 16.  Re: Anyone using SOI Connector v2.2.0.81 with APM 10.1?

    Posted 06-06-2016 05:23 PM

    Chris_Knowles

    We are currently working with Jeff_Morris on testing out the BETA SOI Connector. You'd have to ask him .

     

    Also, I've finished performing APM v10.1 upgrade (late March) successfully so can assist anyway I can (if need be) with your upgrade efforts.

     

    Cheers

    Manish