DX NetOps Manager

Expand all | Collapse all

In the GitHub (Jason N)

Jump to Best Answer

Michael Poller07-19-2017 09:14 AM

  • 1.  In the GitHub (Jason N)

    Posted 07-18-2017 02:49 PM

    In the gitHub there is a   link for GitHub - CA-PM/Interface-Connections 

    Can you explain what this does?



  • 2.  Re: In the GitHub (Jason N)

    Posted 07-18-2017 04:53 PM

    Hello Robert,

     

    I believe, per that URL, it resolves the following problem:

     

    "Fixed OpenAPI queries which were missing /pc and were causing auto-complete and list existing connection to fail"

     

    With that in place querying interfaces and their connections via OpenAPI should no longer cause auto-complete or a list of existing connections to fail.

     

    jason_normandin is that correct or is there more to that GitHub posting than meets the eye?

     

    Thanks,

    Michael



  • 3.  Re: In the GitHub (Jason N)
    Best Answer

    Posted 07-19-2017 02:12 AM

    the app is used for the Weathermap app. It sets the ConnectsTo custom attribute on an interface.



  • 4.  Re: In the GitHub (Jason N)

    Posted 07-19-2017 09:14 AM


  • 5.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 04:21 AM

    Hi @jason normadin

     

    i still get error using GitHub - CA-PM/Interface-Connections, here capture :

     

     

     

     

     

     

     

     

     

     

     

     

    Please let me know why my devices not appear.

     

    Thx



  • 6.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 05:21 AM

    Hello,

    what is the error you are facing?

    What do you mean by "SW" - this should be the name of the target device this interface connects to. As mentioned above, the ConnectsTo relationships are used to plot the lines between devices on the weathermap. If you are missing devices on your map, this is different topic, and I would suggest to review Tech Tip: Troubleshoot CA PC App 

    Hth, Lutz.



  • 7.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 05:32 AM

    Hi Lutz_Holzbecher,

    I want to create the line between my devices, here capture my weathermap :

    My Weathermap

    I already create custom attribute & device alias, but my devices can't appear on interface connection context.

     

    Thx



  • 8.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 06:08 AM

    Ok, so your devices display correctly on the map. For the connection, you should have

    • on RTRLAB01.demo.com an interface with ConnectsTo setting of SWLAB01
    • on SWLAB01 and interface with ConnectsTo setting of RTRLAB01.demo.com

     

    Hth, Lutz.



  • 9.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 09:41 AM

    Oke Thx LUTZ HOLZBECHER

     

    The problem is, i cannot setting my interfaces connectsTo. I was followed the instruction but still failure after click save.



  • 10.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 11:14 AM

    How did you log in to CA PC? Please note that non-admin users need to be authorized for DA REST calls like the ConnectsTo setting in this app: CA PC Apps and User Authorization 



  • 11.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 12:16 PM

    I used admin user. ConnectsTo text box cannot lookup my devices. I think auto complete interface connection app doesn't work properly on my machine.

    Do you have zip file interface connection app? i used this one GitHub - CA-PM/Interface-Connections, doesn't work for me.



  • 12.  Re: In the GitHub (Jason N)

    Posted 05-09-2018 01:25 PM

    In this case I would recommend to set the custom attribute with REST client according to Create Custom Attributes - CA Performance Management - 3.5 - CA Technologies Documentation , e.g.

    PUT http://da_hostname:8581/rest/ports/customattributes/itemID

    <PortCustomAttributes version='1.0.0'>
         <ConnectsTo>target device name</ConnectsTo>
    </PortCustomAttributes>



  • 13.  Re: In the GitHub (Jason N)

    Posted 05-15-2018 11:53 AM

    Hi Lutz_Holzbecher

    Thank You for your advice, my problem solved now.



  • 14.  Re: In the GitHub (Jason N)

    Posted 05-16-2018 02:41 AM

    Hi Irsan,

    just curious about what was the problem and how did you solve it?

    Thanks, Lutz.



  • 15.  Re: In the GitHub (Jason N)

    Posted 05-19-2018 01:10 PM

    I followed your advice about custom attribute port using rest.