Clarity PPM1

Expand all | Collapse all

Empty Advanced Reporting workspace

  • 1.  Empty Advanced Reporting workspace

    Posted 12-19-2016 12:36 PM
      |   view attached

    Hello everyone,

     

    I'm having a problem in viewing the Advanced reporting area within CA PPM that shows me all the icons and functionalities that the user has access too. In this case i gave all the advanced reporting permissions to the Admin group, including the Administrate permission.

    I successfully run the create and update jaspersoft users job, but although the user has all the permissions set correctly the menu items does not show on the initial screen (seen image attached).

    I ran this procedure many times in other environments and all works fine (Data sources, Domains, Ad Hoc Views, Reports, Dashboards and Admin) display correctly.

     

    What am i missing here? Why the difference in functionality for similar installations?

     

    Thank you!



  • 2.  Re: Empty Advanced Reporting workspace

    Posted 12-20-2016 12:00 AM

    Hi Tiago,

     

    Can you please let us know which version of PPM and Jaspersoft you are using? The problem looks like themes are not getting applied correctly.

     

    Regards

    Suman Pramanik 



  • 3.  Re: Empty Advanced Reporting workspace

    Posted 01-03-2017 09:11 AM

    Hello Suman,

     

    The PPM version is 15.1.0.149, and the JasperReport Server 6.2.1

     

    Thank you.



  • 4.  Re: Empty Advanced Reporting workspace

    Posted 01-03-2017 09:47 AM

    It looks like content is not in sync, can you run the below command 

     

    admin jaspersoft syncPPMContext -userName superuser -password superuser

     

    Replace the password with your password and let me know.

     

    Regards

    Suman Pramanik 



  • 5.  Re: Empty Advanced Reporting workspace

    Posted 01-06-2017 06:11 AM

    Hello Suman,

     

    No change after i ran the command. Anything else i can try?

     

    Thank you.



  • 6.  Re: Empty Advanced Reporting workspace

    Posted 01-06-2017 07:11 AM

    Did you install and apply the PMO addin? 



  • 7.  Re: Empty Advanced Reporting workspace

    Posted 01-06-2017 09:55 AM

    Hi Tiago

     

    Does it display this way with all browsers? Does clearing cache work?

     

    If this doesn't help, try creating a new organization in CSA, then creating a keystore and importing new content with admin content-jaspersoft csk. See if that helps display the icons and menus.

     

    Thanks -Nika



  • 8.  Re: Empty Advanced Reporting workspace

    Posted 02-02-2017 05:42 AM

    Hello Nika,

     

    Yes all browsers have the same issue, even cleaning cache.

    I tried to re create the organization but the problem still persists (empty workspace in advanced reporting area). Now i'm also getting the error when i run the load data warehouse job:

     

    com.ca.jasper.restAdapter.JasperException: Could not update attribute business_owner_key of object idea to domain CSK_IDE_Management

     

    I ran the admin content-jaspersoft restoreDomains -userName superuser –password superuser command, no change.

    I ran the admin update jasperParameters, the problem persists.

     

    I think it will be better for me to make a clean install... (in ppm there is never 2 installations that are the same )

     

    Thank you for the help.



  • 9.  Re: Empty Advanced Reporting workspace

    Posted 02-02-2017 12:14 PM

    The last error is helpful and points to resolution by running admin content-jaspersoft restoreDomains -userName superuser –password superuser

     

    More Jaspersoft command are here List of Jaspersoft Commands in accordance with CA PPM Version 

     

    Regards
    Suman Pramanik  



  • 10.  Re: Empty Advanced Reporting workspace

    Posted 02-23-2017 02:33 AM

    Hi, I'm facing the same error:

     

    ERROR 2017-02-23 04:24:20,241 [Dispatch Cargar almacén de datos : bg@S12K-PPM-ABCDIN (tenant=clarity)] niku.njs (clarity:admin:8387379__5AD94AB0-EE0C-46D4-B200-85FDCC8ADE6D:Cargar almacén de datos) Error executing job: 5115011
    com.ca.jasper.restAdapter.JasperException: Could not update attribute business_owner_key of object idea to domain CSK_IDE_Management

     

    How can I fix this? I tried admin content-jaspersoft restoreDomains -userName superuser –password superuser

     

    But I got: USER NAME OR PASSWORD ARE EMPTY. PLEASE ENTER VALUES.

     

    Any ideas?

     

    Thanks,

     

    JUAN



  • 11.  Re: Empty Advanced Reporting workspace

    Posted 02-23-2017 02:44 AM

    This is the correct command admin content-jaspersoft csk restoreDomains -userName superuser –password superuser

     

    csk was missing 

     

    Regards

    Suman Pramanik 



  • 12.  Re: Empty Advanced Reporting workspace

    Posted 02-23-2017 02:49 AM

    I tried that and still getting the same error: USER NAME OR PASSWORD ARE EMPTY. PLEASE ENTER VALUES.



  • 13.  Re: Empty Advanced Reporting workspace

    Posted 02-23-2017 02:59 AM

    Can you copy the command in notepad and then execute the same. 



  • 14.  Re: Empty Advanced Reporting workspace

    Posted 02-23-2017 03:03 AM

    Same result. I have no clue what is wrong with it.



  • 15.  Re: Empty Advanced Reporting workspace

    Posted 02-23-2017 03:45 AM

    I hope you are on 14.3, else open a case and we will help you out. 



  • 16.  Re: Empty Advanced Reporting workspace

    Posted 01-12-2018 07:44 AM

    Hi All, 

     

    I've faced the same issue. Resolution was:type the same command manually into command line. Then, suddenly it was working!  

     

    Hope it helps to someone/ 

    Matej



  • 17.  Re: Empty Advanced Reporting workspace

    Posted 05-24-2018 01:41 AM

    This is PPM version 15.3, SQL Server.

     

    Load Dataware house job fails with following error:

     

    ERROR 2018-05-24 12:09:57,159 [Dispatch Load Data Warehouse : bg@server (tenant=clarity)] kettle.JasperSoftDomainUpdates (clarity:pjoshim:9590297__31480823-7B7E-48C8-A772-1FA6633F7B06:mjLoad Data Warehouse) Error occurred while processing domain attributes. com.ca.jasper.restAdapter.JasperException: Could not update attribute business_owner_key of object idea to domain CSK_IDE_Management
    ERROR 2018-05-24 12:09:57,159 [Dispatch Load Data Warehouse : bg@server (tenant=clarity)] niku.njs (clarity:pjoshim:9590297__31480823-7B7E-48C8-A772-1FA6633F7B06:Load Data Warehouse) Error executing job: 5084116
    com.ca.jasper.restAdapter.JasperException: Could not update attribute business_owner_key of object idea to domain CSK_IDE_Management

     

    I executed following steps:

    1. Deleted the organization in the Jaspersoft console.
    2. Deleted JKS files from the Jaspersoft Server
    3. admin jaspersoft keystore and copied the .jks files
    4. stopped and started PPM and Jasper services
    5. admin content-jaspersoft csk -userName superuser -password superuser
    6. admin jaspersoft syncPPMContext -userName superuser -password superuser
    7. Ran the job to create users in jaspersoft
    8. ran Load data warehouse job with full load checked and unchecked, both but still get the above error.

     

     

    Please note, I typed all commands manually on the command prompt.



  • 18.  Re: Empty Advanced Reporting workspace

    Posted 05-24-2018 02:38 AM

    Did you run Restore domain command? 



  • 19.  Re: Empty Advanced Reporting workspace

    Posted 05-24-2018 02:39 AM

     Hi Mayank,

    Please Check this KB where CA PPM Load Data warehouse Job failing while updating domains.

     



  • 20.  Re: Empty Advanced Reporting workspace

    Posted 05-24-2018 06:55 PM

    This resolved the issue.

    Many thanks for your assistance.