Layer7 Access Management

Expand all | Collapse all

Unable to register Admin UI.

Jump to Best Answer
  • 1.  Unable to register Admin UI.

    Posted 02-27-2017 07:56 AM

    Hi All,

     

    I checked this SiteMinder 12.5: Policy Server Unreachable  and it slightly resembled my issue but in my case i'm able to access Admin UI by localhost and 127.0.0.1 .
    My Policy Server and Data source connection is showing Test connection successful but when i execute the XPSRegClient, Siteminder Admin UI still shows server is unreachable.
    Policy server and WAM UI are on the same server.

     


    While trying to register the Admin UI to use it with FQDN ,
    Tried smreghost command t manually enter the siteminder as a trustedhost but if also failed.
    I'm stuck.
    Executed the XPSReg command multiple times with no positive result.
    Attaching the smps.log and XPSRegClient log file, yes XPSConfig and XPSExplorer option is working fine.


    Regards,
    Hridyesh

    Attachment(s)



  • 2.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:05 AM

    Hi Hridyesh,

     

    It seems like your policy server is down, Hence you are getting unreachable message while trying to login to adminui.

     

    I could see below errors in smps logs.

     

    [4760/4124][Mon Feb 27 2017 02:54:27][CSmDbSessionManager.cpp:585][INFO][sm-Server-04350] Using ODBC 'Policy Store' data source 'CA SiteMinder DSN'.
    [4760/4592][Mon Feb 27 2017 02:54:27][CSmDbUtilities.cpp:465][ERROR][sm-Odbc-00060] Failed to connect to datasource 'SiteMinder Keys Data Source'.
    [4760/4592][Mon Feb 27 2017 02:54:27][CSmDbUtilities.cpp:470][ERROR][sm-Odbc-00070] Error Code is 0 message is 'State = 08003 Internal Code = 0 - [Microsoft][ODBC Driver Manager] Connection not open'.
    [4760/4676][Mon Feb 27 2017 02:54:27][SmObjProvider.cpp:187][ERROR][sm-Server-03090] Policy store failed operation 'Save' for object type 'SharedSecretPolicy' . Unexpected error in database interface. Error code -1063
    [4760/4676][Mon Feb 27 2017 02:54:27][SmPolicyStoreVersion.cpp:219][INFO][sm-Server-04420] Minimum supported Key Store version taken as default 5.
    [4760/4676][Mon Feb 27 2017 02:54:27][SmObjCache.cpp:402][INFO][sm-Server-02800] Preloading policy store cache
    [4760/4676][Mon Feb 27 2017 02:54:27][SmObjCache.cpp:415][INFO][sm-Server-02860] BulkFetch policy store
    [4760/4676][Mon Feb 27 2017 02:54:28][SmPolicyServer.cpp:710][ERROR][sm-Server-00450] Failed to initialize policy store Policy store failed operation 'BulkFetch' for object type 'Policy store provider'. DoBulkFetch Failed
    [4760/4676][Mon Feb 27 2017 02:54:28][CServer.cpp:3943][INFO][sm-Server-04230] The suspend timeout is 3600 seconds.
    [4760/4676][Mon Feb 27 2017 02:54:28][CServer.cpp:4359][INFO][sm-Server-01880] smpolicysrv shutting down
    [4760/4676][Mon Feb 27 2017 02:54:28][CServer.cpp:4378][INFO][sm-Server-01890] Unregistering from the Monitor
    [4760/4676][Mon Feb 27 2017 02:54:30][CServer.cpp:4389][INFO][sm-Server-01900] Releasing Monitor API[4760/4124][Mon Feb 27 2017 02:54:27][CSmDbSessionManager.cpp:585][INFO][sm-Server-04350] Using ODBC 'Policy Store' data source 'CA SiteMinder DSN'.
    [4760/4592][Mon Feb 27 2017 02:54:27][CSmDbUtilities.cpp:465][ERROR][sm-Odbc-00060] Failed to connect to datasource 'SiteMinder Keys Data Source'.
    [4760/4592][Mon Feb 27 2017 02:54:27][CSmDbUtilities.cpp:470][ERROR][sm-Odbc-00070] Error Code is 0 message is 'State = 08003 Internal Code = 0 - [Microsoft][ODBC Driver Manager] Connection not open'.
    [4760/4676][Mon Feb 27 2017 02:54:27][SmObjProvider.cpp:187][ERROR][sm-Server-03090] Policy store failed operation 'Save' for object type 'SharedSecretPolicy' . Unexpected error in database interface. Error code -1063
    [4760/4676][Mon Feb 27 2017 02:54:27][SmPolicyStoreVersion.cpp:219][INFO][sm-Server-04420] Minimum supported Key Store version taken as default 5.
    [4760/4676][Mon Feb 27 2017 02:54:27][SmObjCache.cpp:402][INFO][sm-Server-02800] Preloading policy store cache
    [4760/4676][Mon Feb 27 2017 02:54:27][SmObjCache.cpp:415][INFO][sm-Server-02860] BulkFetch policy store
    [4760/4676][Mon Feb 27 2017 02:54:28][SmPolicyServer.cpp:710][ERROR][sm-Server-00450] Failed to initialize policy store Policy store failed operation 'BulkFetch' for object type 'Policy store provider'. DoBulkFetch Failed
    [4760/4676][Mon Feb 27 2017 02:54:28][CServer.cpp:3943][INFO][sm-Server-04230] The suspend timeout is 3600 seconds.
    [4760/4676][Mon Feb 27 2017 02:54:28][CServer.cpp:4359][INFO][sm-Server-01880] smpolicysrv shutting down
    [4760/4676][Mon Feb 27 2017 02:54:28][CServer.cpp:4378][INFO][sm-Server-01890] Unregistering from the Monitor
    [4760/4676][Mon Feb 27 2017 02:54:30][CServer.cpp:4389][INFO][sm-Server-01900] Releasing Monitor API

     

    is there any issue with the policy store?

     

    Thanks,

    sharan



  • 3.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:14 AM

    Hi Sharan,

    Thanks for the tip, i restarted policy server and it worked but only with localhost:8080 and 127.0.0.1.
    But not with the server IP nor with FQDN.
    Any suggestions for this?

    Regards,
    Hridyesh



  • 4.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:16 AM

    Hi Hridyesh,

     

    Check using nslookup & verify  etc/host file .

     

    Regards,

    Leo Joseph.



  • 5.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:31 AM

    Hi Leo ,

     

    Checked via nslookup and also verified host file.
    The entry is as usual :-

     

    IP    FQDN

    Regards,
    Hridyesh



  • 6.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:22 AM

    Hi Hridyesh,

     

    Are you talking about AdminUI URL? or the server name while entering into the adminui console screen ?

    Do you have DNS entry for the same FQDN?

    Could you please try to do nslookup FQDN? or nslookup ipaddress?

    Also you could try adding the FQDN under hosts file.

     

    Thanks,

    Sharan

     



  • 7.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:33 AM

    Hi Sharana,

    Yes,i'm talkiing about the AdminUI URL.
    Also i didn't get : " or the server name while entering into the adminui console screen ?"
    Checked and verified the host file entry and also the
    nslookup.




  • 8.  Re: Unable to register Admin UI.

    Posted 02-27-2017 08:43 AM

    Hi Hridyesh,

     

    what is the hostname you entered while installing the adminui ?

    When you use FQDN/IPaddress, is the request reachable to adminui ?

     

    Thanks,

    Sharan



  • 9.  Re: Unable to register Admin UI.

    Posted 02-28-2017 12:58 AM

    Hi Sharan,

    I entered the FQDN of the server while installing the adminui and the default page which opens from the link created uses that FQDN too but the request is unreachable.

    Thanks,

    Hridyesh



  • 10.  Re: Unable to register Admin UI.

    Posted 02-28-2017 01:02 AM

    Hi Hridyesh,

     

    Are you trying from your local machine? if so kindly capture the fiddler trace and send it.

     

    Thanks,

    Sharan



  • 11.  Re: Unable to register Admin UI.

    Posted 02-28-2017 06:19 AM
      |   view attached

    Hi Sharan,

    I can access the WAM UI and do configuration as usual.
    Yes i'm trying from local machine because accessing through FQDN on a different server redirects to localhost which throws the obvious error for localhost.
    I'd registered the Admin UI using the FQDN and the port 8080. Later,I checked the Launcher.html file & hostname present is the same.
    Also if it helps pointing, the while configuring the agent and adding the policy server ip i'm getting this :-
    Now on accessing the URL i'm getting redirected to localhost:8080. Below are the screenshots for the same:-


    Launcher.html

     

     

    Siteminder Admin UI from start menu :-

     

     



    I'm attaching the Fiddler outputs in Raw format as required.

    Thanks,
    Hridyesh

    Attachment(s)

    zip
    attachFile.zip   2K 1 version


  • 12.  Re: Unable to register Admin UI.

    Posted 02-28-2017 06:48 AM
    Please open a support case. This is easier to troubleshoot over the remote session.




  • 13.  Re: Unable to register Admin UI.

    Posted 02-28-2017 11:55 PM

    I'll have to consider that option as i can notice this is related to the Jboss service deployed by siteminder installer while installing UI in standalone mode.
    Also JBoss components are accesible.



  • 14.  Re: Unable to register Admin UI.
    Best Answer

    Posted 03-02-2017 02:16 AM

    Hi All,

     

     

    Thanks everyone.Fixed this issue via sitemindermanager. Thanks Ujwol  for your past post at Configure SiteMinder Administrative UI for HTTP (non SSL) connection .
    Fixing this issue required troubleshooting to the core.

    Regards,
    Hridyesh