Layer7 API Management

Expand all | Collapse all

Forums No Longer Appear

  • 1.  Forums No Longer Appear

    Posted 11-02-2016 11:50 AM

    We wanted to turn off the "Bookmark it" link when a post is viewed.

     

    Based on the documentation... Admin Control Panel | Groups then the Permissions of the specific group... Set "Enable Bookmarks" to No.  That was done and saved.

     

    Now... all forums are showing empty... even the default ones.  Check the database and they are all there.

     

    Could something else be getting set behind the scenes that is causing this once that option is turned off?

     

    Thanks!



  • 2.  Re: Forums No Longer Appear

    Posted 11-08-2016 01:43 AM

    Did you check if you are not restricting the forums under "Restricted Forums" in Group Permissions?

     

    Thanks,

    Gopinath



  • 3.  Re: Forums No Longer Appear

    Posted 11-09-2016 10:56 AM

    For Admin... everything is set to "Allow All"... but when logged in as Admin the forums do not appear.



  • 4.  Re: Forums No Longer Appear

    Posted 11-09-2016 02:46 PM

    One more note... when I go to Categories... none show up.  Same when I go to Forums.



  • 5.  Re: Forums No Longer Appear

    Posted 11-25-2016 01:42 PM

    Hi mcowan,

     

    I tried this by disabling Bookmarks in my General groups per the documentation and I was unable to duplicate the behaviour you are seeing in your environment. Can you perhaps attach a screenshot or list of all the settings from that Groups > General > Security Permissions page? Or did you do this on a different area other than General? I also tried it on the Admin section but still couldn't reproduce the issue. In each test, I was able to see the forum categories and posts within it.

     

    If you can provide more details on your configuration, specifically from the permissions page and where exactly you changed it, I think that might be helpful so that I can try to reproduce this issue. Also, if you re-enable bookmarks, did it fix the issue for you, or do the topics and posts stay as missing? Did you try different browsers just to verify that it wasn't a browsers corrupt cache or something browser-related?

     

    I also checked for any known issues around that but did not see anything, so I can only suspect this is an environmental issue at the moment as I've never seen this behaviour before, but I'm currently unclear on what environmental areas would conflict with that behaviour of the bookmarks option. If you're able to provide more information, I can try to reproduce it in my lab. Also, if anything gets too specific in terms of hostnames and such that you're uncomfortable sharing, you can consider opening up a support case so the details are kept private and then we can give a non-customer-specific answer back in here once we've found the root cause and resolution.

     

    Sincerely,

     

    Dustin Dauncey

    Sr Support Engineer, Global Customer Success

    Email: Dustin.Dauncey@ca.com

    Phone: +1 800 225 5224 ,48385

    Phone if outside North America - https://tinyurl.com/CAContactSupport

    CA API Management Community: https://tinyurl.com/CAAPIMCommunity