Layer7 API Management

Expand all | Collapse all

Which Versions of AMQP are supported in V9.0 and V9.1?

Jump to Best Answer
  • 1.  Which Versions of AMQP are supported in V9.0 and V9.1?

    Posted 08-26-2016 03:17 AM

    The Eurocontrol NM B2B Web Services support two communication

    paradigms
    n
    Request/Reply
    n
    SOAP Web Services and POX (Plain Old XML)
    n
    WSDL 1.1 and SOAP 1.1
    n
    Publish/Subscribe
    n
    Push and Pull mode
    n
    AMQP V1.0
    Is this supported by the CA API Gateway?


  • 2.  Re: Which Versions of AMQP are supported in V9.0 and V9.1?
    Best Answer

    Posted 08-29-2016 06:30 PM
      |   view attached

    Thomas,

     

    The Gateway has a tactical assertion that can be requested through support (https://support.ca.com) that supports AMQP version 0-9-1, and there has been some work (not gone through our testing group so not officially supported) using the Generic JMS provider to support version 1.0. Document attached for the version 1.0 option.

     

    Sincerely,

     

    Stephen Hughes

    Director, CA Support



  • 3.  Re: Which Versions of AMQP are supported in V9.0 and V9.1?

    Posted 10-27-2016 12:51 PM

    Dear Stephen,

     

    today, we tried to implement an amqps collection following the instructions in your document. The only change we had to make was a newer version of  qpid (apache-qpid-jms-0.9.0-bin.tar.gz was not available anymore).

    We configured everything according to your instructions, but the gateway didn't establish an outbound connection to the target URL.

    Associated log entries:

    2016-10-27T16:32:43.141+0000 INFO    76 com.l7tech.server.transport.jms2.JmsBootProcess: Connection ccdbd58758c25bc65a5e1cd5a9c8e1d0 updated!2016-10-27T16:32:43.152+0000 INFO    155 com.l7tech.server.transport.jms2.asynch.a: Starting JMS poller on EC-nm-b2b w/o SSL,/opt/SecureSpan/Gateway/runtime/lib/ext/EC-Queue[ccdbd58758c25bc65a5e1cd5a9c8e1d2v1,ccdbd58758c25bc65a5e1cd5a9c8e1d0v3]

    2016-10-27T16:32:43.153+0000 WARNING 155 com.l7tech.server.transport.jms2.asynch.a: Unable to receive message from JMS endpoint EC-nm-b2b w/o SSL,/opt/SecureSpan/Gateway/runtime/lib/ext/EC-Queue[ccdbd58758c25bc65a5e1cd5a9c8e1d2v1,ccdbd58758c25bc65a5e1cd5a9c8e1d0v3]

    2016-10-27T16:32:43.155+0000 INFO    152 com.l7tech.server.transport.jms2.asynch.a: Stopping JMS poller on EC-nm-b2b w/o SSL,/opt/SecureSpan/Gateway/runtime/lib/ext/EC-Queue[ccdbd58758c25bc65a5e1cd5a9c8e1d2v1,ccdbd58758c25bc65a5e1cd5a9c8e1d0v2]

     

    Any idea where to start troubleshooting? Is the information in your document still valid, especially the instruction to leave the JNDI URI blank?

     

    Any help is appreciated!

     

    Regards,

    Thomas



  • 4.  Re: Which Versions of AMQP are supported in V9.0 and V9.1?

    Posted 12-05-2016 07:46 PM

    Thomas,

     

    What version of the qpid did you use as our tactical team had only built the solution using the information provided? I was able to find 0.9.0 at Qpid JMS 0.9.0 - Apache Qpid™.

     

    Sincerely,

     

    Stephen Hughes

    Director, Technical Support



  • 5.  Re: Which Versions of AMQP are supported in V9.0 and V9.1?

    Posted 12-08-2016 03:59 AM

    Stephen,

     

    we used qpid 0.11.1. I have my next session with Thomas scheduled for December 19th, we can try Qpid JMS 0.9.0 then. 

     

    Regards

    Christopher