Layer7 Access Management

Expand all | Collapse all

SiteMinder 12.52 WAM GUI - https setup

Jump to Best Answer
  • 1.  SiteMinder 12.52 WAM GUI - https setup

    Posted 02-19-2016 10:19 AM

    I am trying to setup siteminder WAM UI (in version 12.52) to take requests our https. While the server is running on port 8443, all the https requests immediately get forwarded http on port 8080.  I have not changed any default setting in server.xml under <>/ server/default/deploy/jbossweb.sar and has  SSL enabled = "tue". Infact WAMUI can take take requests over https but immediately forwards (http 301 status code) to http.

    Any ideas why this is happening ?

     

    thanks



  • 2.  Re: SiteMinder 12.52 WAM GUI - https setup

    Posted 02-20-2016 12:21 PM

    Hi rhegde,

     

    The community member Ujwol from CA wrote an excellent write up on checking the SiteMinder management console to verify https is the default Base URL. In my case below I am running the WAMUI on the OOTB JBOSS. Your paths may very depending on your application server context.

     

     

    1. 4. Enable the Siteminder Management Console and Verify that https is the default value.

    cp /opt/CA/siteminder/adminui/server/default/deploy/iam_siteminder.ear/management_console.war/WEB-INF/web.xml /opt/CA/siteminder/adminui/server/default/deploy/iam_siteminder.ear/management_console.war/WEB-INF/web.xml.bak/op

     

    viA /opt/CA/siteminder/adminui/server/default/deploy/iam_siteminder.ear/management_console.war/WEB-INF/web.xml

     

    Look for AccessFilter and set this to True

     

    <filter>

    <filter-name>AccessFilter</filter-name>

           <filter-class>com.netegrity.ims.manage.filter.AccessFilter</filter-class>

           <init-param>

    <param-name>Enable</param-name>

    <param-value>true</param-value>

           </init-param>

         </filter>

     

    iteminder/adminui/server/default/deploy/iam

    1. 5. Access the SiteMidner Management Console at

    http://fqdn:8080/iam/sitemindermanage/

    Under Environtments -> Siteminder

    Verify the Base URL is using the https://fqdn:port/ reference

     

    https://fqdn:8443/iam/siteminder

     

     

     

    Thanks to Ujwol for those steps in one of his previous posts.

     

    Adam Rusniak



  • 3.  Re: SiteMinder 12.52 WAM GUI - https setup
    Best Answer

    Posted 02-21-2016 04:40 PM

    Thanks Adam.

     

    Here is the post that Adam is referring to:

    Configure SiteMinder Administrative UI for HTTP (non SSL) connection

     

    Hegde,

    Please go through the post and see if it helps to resolve your issue. If not , please come back and we will see what we can do to get you through.

     

    Cheers,

    Ujwol Shrestha

    Ujwol's Single Sign-On Blog