Clarity PPM

Expand all | Collapse all

Getting the error "User is not registered on the reporting server" when click on advance reporting

Jump to Best Answer
  • 1.  Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 05-31-2016 09:14 AM

    Hi All,

     

    I have configured jaspersoft in my another environment (4 environments, am able to implement it successfully). But this environment giving some issues like below. When i click on advance reporting from application. Am getting an error below.

    "User is not registered on the reporting server"

     

    i have already ran this create ad update jaspersoft users job successfully after installation. In jasper server also, am able to see my user is created.

     

    After getting the above message, i have ran again the job, but this time it get failed saying that

     

    "Failed to get an instance of ClarityJasperAdmin :: Exception getting ClarityJasperAdmin : Unauthorized access to http://***********:8080/reportservice with username ppmjasperadmin"

     

    Could anyone please help me on this to fix this issue?

     

    Thanks,

    Agin



  • 2.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 05-31-2016 11:04 AM

    Have you tried running the "Create BusinessObjects Users" as well?

     

    NJ



  • 3.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting
    Best Answer

    Posted 05-31-2016 11:09 AM

    Create Business Object is for BO, I hope you meant Create Jaspersoft User NJ

     

    Agin,

     

    Please refer to you earlier post where I have already provided you answers and all possible workarounds.

     

    Create and Update Jaspersoft Users job is only creating 8 users.     

     

    Keystore file generation failed during Clarity 14.3 Upgrade

     

    getting error message in importing advance reporting content in Jaspersoft installation

     

    So if you content import and keystore generation was successful then you shouldn't get this.

     

    Regards
    Suman Pramanik 



  • 4.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 05-31-2016 02:11 PM

    Hi Suman, Thanks for your quick reply. I have done that also. This environment, we have 4 app servers. So I have generated keystore file for each server and placed file from one app server in to jaspersoft tomcat folder. First time, when I ran this job, it was successful(keystore is generated only in one server). After that I have generated keystore separately in each server. Is that created this issue?              Thanks, Agin



  • 5.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 05-31-2016 02:21 PM

    Hi Agin,

     

    If you have multiple app server then you should generate one and copy the same to each app server, why there is a explicite need to generate multiple times on each server?  Ideally on a cluster you should set up everything on one app server and then distribute or copy to different app servers on cluster.

     

    Hope this helps you

     

    Regards
    Suman Pramanik



  • 6.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 06-01-2016 08:25 PM

    Thanks Suman... I have deleted the keystore files from all servers and regenerated in one app server and copied the file to jaspersoft tomcat. It worked. One interesting thing is, I didn't copy the keystore file to other servers or not distributed..still jaspersoft is working fine.                                                              Thanks, Agin



  • 7.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 06-03-2016 02:44 AM

    It worked because load balancer redirected to the correct app server, you would need to distribute the file system. However this case is unique because you generated a key store on one server and copied to jaspersoft server and you are not required to generate keystore on all app servers.

     

    Regards

    Suman Pramanik



  • 8.  Re: Getting the error "User is not registered on the reporting server" when click on advance reporting

    Posted 05-31-2016 02:14 PM

    Thank NJ. It's working fine. Have issues coming, while running jaspersoft job