Service Virtualization

Expand all | Collapse all

LISA VSE Recording Issue

Jump to Best Answer
  • 1.  LISA VSE Recording Issue

    Posted 07-20-2016 09:10 AM

    I am using LISA workstation 7.5.1 and i connect to registry which is on different server.

    I am not able to use the recording feature properly.During the recording the wizard asks for the port no whcih is default 8001 so VSE recorder is listening on http://localhost:8001 for the incoming request.

    My Question is

    Do i need some special permission to access this feature  that i might not have.

    Or

    i might be making some mistakes while recording.

     

    Please advice!



  • 2.  Re: LISA VSE Recording Issue

    Posted 07-20-2016 01:42 PM

    Hi Ankit,

    You should be able to change the "Listen/Record on port" field while configuring the VSE Recorder - I believe it is the second  window.

     

    VSERecorder.PNG

     

    Hope it helps.

     

    Heloisa



  • 3.  Re: LISA VSE Recording Issue

    Posted 07-21-2016 04:42 AM

    Hi Maria

    Consider this scenario

    I am trying to virtualize a web service which is publicly available :

    Here are the details:

    WSDL : http://wsf.cdyne.com:80/WeatherWS/Weather.asmx?WSDL

    Endpoint URL : http://wsf.cdyne.com/WeatherWS/Weather.asmx

    so while recording i change the endpoint URL to http://localhost:8019 (Port no which i provided on second window)

    i am getting following error while hitting the webservice

    java.net.SocketTimeoutException: Read timed out

    Please advice how should i proceed with this.

     

    Capture.PNG



  • 4.  Re: LISA VSE Recording Issue

    Posted 07-21-2016 11:00 AM

    Hi Ankit,

     

    What did you provide for Target host and port?

    I am sending to you how I configured the recorder using the details you provided:

    Verify the Target host and Target port you provided in the recorder:

    VSERecorder1.PNG

     

    Check the Endpoint URL:

    RequestRecorded.PNG

    Below is the request being captured in the VSE Recorder.

    VSERecorder2.PNG

     

     

    Hope it helps.

     

    Thank you,

    Heloisa



  • 5.  Re: LISA VSE Recording Issue

    Posted 07-22-2016 04:42 AM

    Thanks for the response!

     

    I tried the same settings but now I am getting a different error, Please find details below:

     

    Recorder Configuration :

    recorder.PNG

    Web Service Call :

    Test_call.PNG

     

    Please Advice.

     

    Thanks

    Ankit



  • 6.  Re: LISA VSE Recording Issue

    Posted 07-22-2016 09:59 AM

    AnkitBhutani are you on the next tab where it shows the VS is in recording mode?

     

    Thanks,

    Abhishek



  • 7.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 02:45 AM

    yes i am on the next tab@IamAbhi



  • 8.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 06:53 AM

    Hi AnkitBhutani,

     

    Sorry, even I'm too getting the same exception. I will try to look into the issue and will update you if anything is missing from my side.

     

    Thanks,

    Abhishek



  • 9.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 07:52 AM

    Hi IamAbhi

     

    Thanks for the help! Can you open a support ticket as suggested by Maria.

     

    Anyways, If you find a solution please let me know.

     

    Thanks

    Ankit



  • 10.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 07:55 AM

    Hi AnkitBhutani,

     

    Sorry, but not sure I will open the ticket instead you can go ahead and open the support ticket as you are the one facing issue

     

    Thanks,

    Abhishek



  • 11.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 07:59 AM

    Hi IamAbhi

     

    So sorry, I don't have any idea how to open a support ticket :(.

     

    Can you please help!

     

    Thanks

    Ankit



  • 12.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 08:44 AM

    Hi AnkitBhutani,

     

    Sorry me too don't know.

     

    Regards,

    Abhishek



  • 13.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 09:43 AM

    You will need some additional information to open a ticket.  Tickets are created on https://support.ca.com

     

    a) Find out who within your customer "owns" the DevTest license and contact them.  They should have a login ID/pwd for gaining access to the support site and their login ID will be registered to their Customer Site ID

    OR

    b) ask the license owner to contact their CA Account team to get assistance with the ticket.  Either party should be able to help you get a ticket opened.

     

    If you have an account on support.ca.com that has been assigned to your customer Site ID, you can login and open the ticket on your own.  Simply registering on the site will not be enough.  Your account will need to be associated with a license holder.

     

    When you open the ticket, provide the link to this thread when describing the issue and upload pertinent log files, etc. so the support team will have some background information.  Additionally, be prepared to demonstrate your issue.  These kinds of activities will help you get to a resolution more quickly.



  • 14.  Re: LISA VSE Recording Issue

    Posted 07-28-2016 11:38 AM

    Hello Ankit,

     

            I have seen the free weather service go down in the past. The error you received may be from the actual service itself. As of today, when I tried to record the service, I do not see any errors as shown below.

     

     

    Recording.png



  • 15.  Re: LISA VSE Recording Issue

    Posted 08-02-2016 06:22 PM

    try couple of things

     

    1. checkout the option "do not modify the host header received from client"

    2. are you sure 8019 is accesable from your  recorder machine and also make sure no other service is deployed/running on that port while you recording



  • 16.  Re: LISA VSE Recording Issue

    Posted 07-22-2016 10:35 AM

    Hi Ankit,

     

    Please, open a support ticket and a support engineer will help you with this.

     

    Thanks,

    Heloisa



  • 17.  Re: LISA VSE Recording Issue

    Posted 07-25-2016 08:56 AM

    Hi

    Can you help in opening a support ticket , I have no idea how to do that.

     

    Thanks in advance

    Ankit



  • 18.  Re: LISA VSE Recording Issue
    Best Answer

    Posted 07-25-2016 11:32 AM

    Hi Ankit,

     

    Please, check the detailed response from Joel Nesmith above.

    I am also sending to you this link that might help you.

    What do i need to open a support case with CA Technologies Support?