Layer7 Access Management

Expand all | Collapse all

Test Tool Load Testing not working

Jump to Best Answer
  • 1.  Test Tool Load Testing not working

    Posted 03-05-2015 05:47 AM
      |   view attached

    Hello Everyone,

     

    I am trying to create a test tool setup to do some load testing. I have followed CA documentation for preparing test tool setup for stress testing. Everything runs but there is no result. And it is also not showing any error as well.

     

    I am uploading test tool setup files, if anyone can find what's the problem in my script files, it would be very helpful.

     

     

    Regards,

    Neeraj

    Attachment(s)

    zip
    files.zip   3K 1 version


  • 2.  Re: Test Tool Load Testing not working

    Posted 03-05-2015 10:49 PM

    Neeraj NeerajChase

    There are a couple of issues in Control file (e.g. missing thread / repitition control / .connect should be smtest.ini).

    Please check this thread. I have a sample Control File and INI file pasted as replies.

     

    Re: SiteMinder Stress Test

     

     

     

    TRY THIS as you Control File.

     

    .verbose

    .sleep 5000

    .connect smtest.ini

    C:\Users\appadm\Desktop\test_tool_files\neeraj\smtestrecord.txt, 50, 10

    .disconnect

    .report

    .output

    .viewstats

     

     

     

    Regards

     

    Hubert



  • 3.  Re: Test Tool Load Testing not working

    Posted 03-06-2015 04:25 AM

    Hello Hubert,

    Have corrected it now but still no success. I referred to the link as well to see if I am missing anything. I am suspecting that test tool is not calling my smtest.ini file.

     

    Correct me if I am wrong.

    smtest.ini file will have stored configuration which is related to only test agent connecting to policy server successfully. I have kept smtest.ini file in folder "C:\Users\appadm\Desktop\test_tool_files\neeraj\" and have tried both options separately.

     

    .connect smtest.ini

    .connect C:\Users\appadm\Desktop\test_tool_files\neeraj\smtest.ini.

     

    how does .connect call smtest.ini file? When I click on run script, I see that 50 iterations are happening but test tool is not reading the data present in smtest.ini file or smtestrecord.txt file.

     

    Do you see any mistakes in smtest.ini file ?

     

    smtest.ini file:

     

    # This is a system file for SiteMinder Test Tool.

     

    Agent/Radius:           0

    Agent name:             test_neeraj1

    Server:                 localhost

    Secret:                 8672b40e7c39c947

    Policy Server Mode:     0

    Server IP Address:      10.54.54.202

    Authentication Port:    44442

    Authorization Port:     44443

    Accounting Port:        44441

    Server IP Address 2:   

    Authentication Port 2:  44442

    Authorization Port 2:   44443

    Accounting Port 2:      44441

    Round Robin/Failover:   0

    Timeout:                30

    Repeat Count:           1

    Resource:              

    Action:                

    Username:              

    Password:              

    Certificate File:      

    Test Mode:              0

    Comments:              

    Input File:            

    Output File:           

    CHAP Password:          0

    Encoding Spec:         

     

     

    Regards,

    Neeraj



  • 4.  Re: Test Tool Load Testing not working
    Best Answer

    Posted 03-06-2015 11:04 AM

    No No NeerajChase

     

    Do not create a file called as smtest.ini; this is a proprietary command to initiate the SmTestTool.

     

    smtest.ini is not a physical file.

     

     

    TRY ONLY THIS. Do not create a smtest.ini file. It is a initialization command for SmTest Tool.

     

    .verbose

    .sleep 5000

    .connect smtest.ini

    C:\Users\appadm\Desktop\test_tool_files\neeraj\smtestrecord.txt, 50, 10

    .disconnect

    .report

    .output

    .viewstats



  • 5.  Re: Test Tool Load Testing not working

    Posted 03-06-2015 11:16 AM


    So have only 2 files under the SmTestTool folder.

    - Control File. (e.g. see above).

    - Recorded File (e.g. smtestrecord.txt).

     

    Now open a SmTestTool. Run one Txn i.e. Connect / IsProtected / IsAuthenticated / IsAuthorized.

     

    Then flip to Advanced Setting. Open the control file in SmTestTool. Then execute.