DX Infrastructure Manager

Expand all | Collapse all

NMS 7 and .net API 1.6.3532.33037 crashing controller

  • 1.  NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 10-29-2013 10:51 AM

    Hi,

     

    I was just testing opening a session to controller on version 7.0 hub / controller and it seems to crash the controller. Tried this on two hubs and one non-hub robot.

     

    Didn't try it as a probe, but a standalone app that runs from commandline.

     

    Anyone else having a problem like this?

     

    -jon



  • 2.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 10-29-2013 10:57 AM

    Correction, it crashed the hub the robot is connected to.



  • 3.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 10-29-2013 08:09 PM
    So I have found that in perl doing a nimlogin crash's the HUB as well . You need to create a case about this as I have a case regarding this and they are making a hotfix for it .

    This is only relevant for NMS 7 .. You would think one day they may publish this data to the mass's like a bug LISTING so people can avoid some issues or wait for a fix before deploying X version.



  • 4.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 10-29-2013 08:46 PM

    Hi Louis,

     

    Yes I did indeed open a case about this. Sad to hearl Perl API is affected as well.. I'm using perl Api in production, .net api in prod is the most recent which seems to work.. glad I didn't upgrade production yet!

     

    I totally agree about the bug tracking.. I probably mention it at every meeting with CA people, to no avail.

     

    -jon

     

     



  • 5.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 11-01-2013 03:40 PM

    You know I experince issues with hub 7.0 I downgraded back to 5.82 and everything was working again.  I was having issus opning probes that had a large config file mostly snmptoolkit once downgraded it all worked again.  I still have controller 7.0 running.



  • 6.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 11-01-2013 06:06 PM
    I've done the same myself Neal. A bit disappointed with quality control..


  • 7.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 12-13-2013 11:56 AM

    Apparently .net and perl api are to be updated soonish.. and hub as well. Hopefully more bugs will be addressed :smileyhappy:



  • 8.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 01-10-2014 11:43 PM
    Anyone tried NMS 7.1 yet?


  • 9.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 01-12-2014 11:00 PM

    Yes, I tried. The hub on 7.1 didn't crash at least when trying simple programs. But it seems like my probe created with Perl API isn't working anymore with 7.1. Didn't investigate it any further than that yet, as I noticed it late friday evening. Seems like it fails to register, though.

     

    Not 100% if  old .net api probes work properly on 7.1, I'll have to test that too now. I tried some basic login methods which now worked & didn't crash anything. I'm now developing on newer version of .net api that I got from support, and it works fine. Also some of the bugs from previous versions have been fixed, so I'm liking it pretty much.

     

    I think new Perl and .net api versions were in the roadmap from early 2014, so I'm hoping there will be official releases & fixes for the perl api soon.

     

    -jon



  • 10.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 01-13-2014 08:15 AM

    old .net api probes seem to work alright on 7.1, just checked.



  • 11.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 01-23-2014 02:14 PM
    Where can you download the 5.82 version?


  • 12.  Re: NMS 7 and .net API 1.6.3532.33037 crashing controller

    Posted 01-23-2014 03:16 PM