Backup & Recovery

 View Only
  • 1.  password of vcenter appliance

    Posted 30 days ago

    Good day,

    I just Clone as VM for a vcenter appliance. Could you guide the passwod for the new clone password?

    Brgds

    Liu Wei



  • 2.  RE: password of vcenter appliance

    Posted 29 days ago

    Hi Liu, 

    We need more context. Are you trying to recover the password to the vCSA (root) or is the GRUB menu locked and you can't get in to change it? It shouldn't be changed from what it was previously. 




  • 3.  RE: password of vcenter appliance

    Posted 27 days ago
    Edited by lwsamcn01 27 days ago

    Good day, Redhatcc,

    The version is 6.7.  From the guide reset the password could be done frrom sso log in menu.

    I saw root right menu all greyed. VAMI also has not root change password option.

    In this case, I shall do changing password from ssh by putty or from GRUM menu?

    Brgds

    Liu Wei




  • 4.  RE: password of vcenter appliance
    Best Answer

    Posted 27 days ago

    Try changing it on boot. This method works all the way up to 7.0.3 but I have not tested on 8.x

    1. Take a snapshot or backup of the vCenter Server Appliance before proceeding.
                           Caution: Do not skip this step

    Note: If the vCenter Appliance is on the same ESXi hosts it manages, connect directly to the ESXi host that it is located on to perform these steps. If not, I would highly recommend moving the vCenter to a host you can login too, and open a console on to run these commands. 

    1. Reboot the vCenter Server Appliance.
    2. After the VCSA Photon OS starts, press the e key to enter the GNU GRUB Edit Menu.
    3. Locate the line that begins with the word Linux.
    4. Append these entries to the end of the line:

      rw init=/bin/bash

      The line should look like the following screenshot:

      Reset root password in VCSA - rw init=/bin/bash
       
    5. Press F10 to continue booting.
    6. Run the command  
                      mount -o remount,rw / 
    1. Unlock the 'root' account using below command if it is already locked due to multiple logins with incorrect password
                      pam_tally2 --user=root --reset

    1. In the Command prompt, enter the command passwd and provide a new root password (twice for confirmation):
               passwd

     

    1. Unmount the filesystem by running this command (yes, the unmount command is umount  -  it's not a spelling error):
               umount /

     

    1. Reboot the vCenter Server Appliance by running this command:
               reboot -f

     

    Please reply and let us know if that worked. Don't skip a step!



    ------------------------------
    Love for Virtual Infrastructure!

    If my post helped, please click the thumbs up or mark as solved. I can't promise my solutions will work, but I will promise to do my best!

    VCP-DCV 8.x | VCP-DCV 6.x | CompTIA A+, Net+, Sec+, Proj+ | MCSE | MCSA | MCITP |
    ------------------------------