Client Management Suite

ITMS 7.1 Beta - Now Available 

10-13-2010 06:23 PM

Welcome to the ITMS 7.1 Beta

 

ITMS 7.1 is the latest and most advanced version of the Altiris IT management software. The following are the key suite-level features planned for this release:

 

·         Enhanced UI for improved usability and performance – navigation in the new UI for managing Computers and Software is specifically designed to help administrators quickly find the data and management options they need. The look-and-feel and responsiveness of the new UI is intended to greatly improve user productivity and satisfaction.

·         Inclusion of full Symantec Workflow  – Workflow is the means to tie together Symantec and other environments, to connect people, process and information, and to automate and enforce procedures. All Workflow components and capabilities are available through ITMS and associated management suites.

·         Inclusion of IT Analytics data analysis capability – IT Analytics incorporates multi-dimensional analysis and robust graphical reporting and distribution features. This enables users to explore data without advanced knowledge of databases or third-party reporting tools. Both IT Analytics and the packs for Client Management Suite, Server Management Suite, and Asset Management Suite are included with their corresponding suites.

·         Support for installing on a 64-bit server – all Client Management Suite, Server Management Suite, and Asset Management Suite solutions and components are supported on 64-bit Windows Server 2008 R2.

·         Simplified software license management – software-based usage tracking is provided through the new Silverlight-based UI for intuitive license management.

 

Additionally, important enhancements are provided in various individual functional areas. The following are some examples:

 

·         Deployment Solution – support for extended driver types in Deploy Anywhere (HII); RDeploy-style multicast and imaging over HTTP in the Ghost engine; Solaris imaging.

·         Inventory – application metering performance and scalability improvements.

·         Monitor/Server Health – Windows and Linux s server health monitor policy.

·         OOBM – Integration of new Intel SCS 56.4 for complete SQL 2008 support.

·         Patch Management – Linux endpoints no longer require Internet access to verify entitlement status.

·         pcA Solution – policy pages have targets and schedules as hierarchy editable properties.

·         PC Transplant – support for 64-bit MS Office 2010.

·         Real-time System Manager – 1-to-1 and 1-to-many out-of-band BIOS management; scalability validation for large number of clients powered on.

·         Software Management – new UI for dynamic creation of software products, new software product based display, and software-based usage tracking; separate scheduling for program execution and download in Managed Delivery Policies; hierarchy editable properties (HEP) support.

·         VM Management – simplification of credentials setup and use; integration of DS Jobs in Create VM Wizard.

Statistics
0 Favorited
0 Views
7 Files
0 Shares
0 Downloads
Attachment(s)
zip file
Altiris_IT_Management_Suite_Beta_Guide_7.1.zip   193K   1 version
Uploaded - 02-25-2020
zip file
ITMS_7_1_Beta.zip   40.20MB   1 version
Uploaded - 02-25-2020
zip file
ITMS_7_1_BETA_Known_Issues.zip   67K   1 version
Uploaded - 02-25-2020
pdf file
ITMS_7_1_BETA_Known_Issues_Update18Oct.pdf   105K   1 version
Uploaded - 02-25-2020
zip file
ITMS_7_1_Beta_Licenses.zip   24K   1 version
Uploaded - 02-25-2020
zip file
ITMS_7_1_Beta_Licenses_VMM.zip   1K   1 version
Uploaded - 02-25-2020

Tags and Keywords

Comments

02-14-2011 03:04 AM

Valid 7.0 licenses should work fine with 7.1 release.

 

Cheers,

Alex.

02-11-2011 06:11 PM

some Logicbase extensions still use the Ensemble name.  Not sure why you don't have the forms if everything was installed.  Not sure if you have done so, but you may want to perform a clean install of everything (fresh OS, but keep your install files from the SIM folder because they seem to no longer be available online).  The SD file used to install SD 7.1 also installs full Workflow, so there is no need to install WF separately first.  I basically just installed full ITMS, then installed SD 7.1 following the install guide for a domain account for SD 7.0 MR2 (HOWTO-31346).  I also did the application pool tweaks (run as Classic and under domain account) for the default and classic .Net app pools.  Installed to the D (had to copy logicbase library to C afterward).  I made sure to check Advanced Settings on the setup, ran Native Authentication and basically installed everything on the ServiceDesk postInstallation.  I then logged in with the default admin account, set up my domain in the AD servers and enabled AD authentication in Master Settings.  Performed AD sync to import my domain accounts and have been running fairly smooth since.

I don't know if the same page is used for 7.1 as for 7.0, but maybe check your IIS virtual directory to see if you have the SD.Installation.PostInstallWizard page and if you do, browse to it and run through the post-install steps.

02-11-2011 04:23 PM

SD 7.0 used EnsembleDB.  ProcessManager DB seems to be used for 7.1.  I thought I saw references to Ensemble in the log files that I had posted above. 

02-11-2011 03:25 PM

Because I have this running in vmware i just re-installed everything to C: and the install went fine (completed successfully). I installed Incident, change, problem management etc. (all available) and am still finding that there is nothing available when submitting a request as both a user and the admin.

Does anything need to be done with Workflow prior to running service desk?

I will work on getting the AD piece in later as getting categories is a higher priority at this point.

Also seeing manny errors in SD log viewer:

Application Name : LogicBase.ServerExtensions.exe
Process ID : 1036
Date :2/11/2011 2:52:41 PM
Log Level :Error
Log Category :AbstractWebServiceURLInvoker
Machine Name : DC-SYM71-SD
Message :
(WebServiceScheduleInvokeDelegate) Error triggering service at http://dc-sym71-sd//sd.documenteventlistener/ScheduleInvokeDelegateService.asmx System.Exception: exception invoking method ---> System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.UriFormatException: Invalid URI: The hostname could not be parsed.
   at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink..ctor(String channelURI, TcpClientChannel channel)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSinkProvider.CreateSink(IChannelSender channel, String url, Object remoteChannelData)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSinkProvider.CreateSink(IChannelSender channel, String url, Object remoteChannelData)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientChannel.CreateMessageSink(String url, Object remoteChannelData, String& objectURI)
   at System.Runtime.Remoting.Channels.ChannelServices.CreateMessageSink(String url, Object data, String& objectURI)
   at System.Runtime.Remoting.RemotingServices.CreateChannelSink(String url, Object data, IMessageSink& chnlSink)
   at System.Runtime.Remoting.RemotingServices.Unmarshal(Type classToProxy, String url, Object data)
   at System.Activator.GetObject(Type type, String url)
   at LogicBase.Core.Messaging.Remoting.MessagingServerAccessor.GetServer(String hostName, Int32 port)
   at LogicBase.Core.Messaging.RemoteServerImpl..ctor(String ipAddress, Int32 port, String remoteQueueName, String userid, String passsword)
   at LogicBase.Core.Messaging.MessageExchangeFactory.CreateRemoteTarget(String name, NetworkCredential credential)
   at LogicBase.Core.Messaging.MessageExchangeFactory.GetExchangeTarget(String name, Boolean internalRequest, NetworkCredential credential)
   at LogicBase.Core.Messaging.MessageExchangeFactory.GetExchange(String name, Boolean internalRequest, NetworkCredential credential)
   at LogicBase.Core.Messaging.MessageExchangeFactory.GetExchange(String name, Boolean internalRequest)
   at LogicBase.Core.Messaging.MessageExchangeFactory.GetExchange(String name)
   at LogicBase.Components.Default.Workflow.AutoStartFromExchangeComponent.StartWorkflow(IData data) in c:\build\projects\WF71RC1\components\LogicBase.Components.Default\Workflow\AutoStartFromExchangeWorkflowComponent.cs:line 151
   at LogicBase.Core.Models.Workflow.WorkflowServices.CheckAutoStart()
   at LogicBase.Core.Models.Workflow.WorkflowManagementService.CheckAutoStart() in c:\build\projects\WF71RC1\core\LogicBase.Core.WebServices\WorkflowManagementService.cs:line 133
   --- End of inner exception stack trace ---
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at WorkflowManagementService.CheckAutoStart()
   --- End of inner exception stack trace ---
   at LogicBase.Framework.DynamicProxy.InvokeMethod(String MethodName, Object[] parameters)
   at LogicBase.ServerExtensions.Core.WSInvokerDelegate.DoInvoke() in c:\build\projects\WF71RC1\core\LogicBase.ServerExtensions.Core\WebServiceAutoInvokeDelegate.cs:line 153

 

 

02-11-2011 12:08 PM

Great.  I was just concerned after reading the going from 6 to 7 where they recommended you to a agent uninstall of everything then clean install of 7.  So it would seem 7 will hold the same tables as 7.1

 

 

Thanks for that.

Dave

02-11-2011 10:11 AM

Yes, 7.1 will have a new agent version, and once you point your 7.0 agents to the new 7.1 server, your 7.1 server can have a policy enabled to upgrade the agent and the plug-ins.

02-11-2011 09:27 AM

At least in the Beta, the 7.0 licenses work fine.

02-11-2011 08:23 AM

I heard they have frozen Dev on it now

I wonder how long after release it will take to have the licenses available, I doubt V7.0 licenses will work

02-11-2011 03:51 AM

Does anyone know if the current Symantec Management Agent will be upgraded once 7.1 is released.  We are looking at immediate requirements for inventory info from clients, and If I was to deploy 7.0 across the estate would i then have to redo all clients by remove and re-install like you will have to do going from V6 to V7, or is this going to be seemless in 7.1?

02-11-2011 02:40 AM

Don't go thru the SIM to enable AD authentication.  Log in to http://<server>/processmanager and in the admin area you want to add an AD server/domain and then enable AD authentication check box (Master Settings I think, but I will have to check when I get into work tomorrow).  When in the "submit request" area, there should be some folders on the left.  If you click on the servicedesk folder, there should be about 10+ forms (depending on how many options you chose on install).  You should be able to submit a request using those forms, however with my install, I found I could do change management with no issue, but got an error trying to do any type of incident submissions.  The logs showed it was looking for files on the C drive, but my install is on the D,  So I created my folder C\program files\Altiris\Workflow\shared and copied the logicbase folder over, and it all worked after that.  There are some posts that this was fixed in November, but maybe my dowload was prior to that.

02-10-2011 11:03 PM

Thanks,  changing to native mode completed the install.  I did try to go back and install the AD component but got the same error.  Is the logicbase library where the categories etc are stored?  I currently have nothing listed when I try to submit a request.

02-10-2011 05:06 PM

I believe this is because the default admin account (admin@logicbase.com) is being used to authenticate against the domain.  When I set up SD, I use Native Authentication in the initial setup, and then when SD is up and running I enable the AD authentication.  Haven't had any issues except that I installed on the D drive and it looks for logicbase library files on the C, so I had to copy those over.

02-10-2011 04:40 PM

Installing SD on server 2008 r2, sql is running 2008 r2 with sql 2008 sp1 and SMP is running on 2008 r2.  All machines are in the same domain.

"Failed to fetch user: Login failed. The login is from an untrusted domain and cannot be used with Windows authentication."

 

The whole list:

Installing Workflow Server..
Checking Server Extensions service running
Setting local machine information
Process timeouts and escalations
Checking Server Extensions service running
Copying Workflow Server installer..
Workflow Server role installed.
Workflow SymQ Setup completed
Enabling SMP Log Writer..
Installing Workflow Designer..
Workflow Designer role installed.
Installing ServiceDesk ITIL Core..
Checking Server Extensions service running
ProcessManager portal role added to default server
ServiceDesk ITIL Core role installed.
Installing ServiceDesk Portal..
Checking Server Extensions service running
Writing MSSQL connection instance to web configuration file..
Writing Report snapshots location to web configuration file..
ServiceDesk Portal role installed.
Preparing SQL scripts to execute..
Checking Server Extensions service running
SMP server credentials saved.
Executing database integration strategy..
Proceed Full Text Search..
Current version : 963
Current patch : 0
Database integration completed.
Writing OLAP connection instance to web configuration file..
Adding DefaultOLAPConnectionInstance
Writing new Connection Instance
Do not send welcome messages to users as they're added to the portal
Use Process Manager for Critical Errors
The Administrator User already exists in database
Writing administrator login information to web.config..
Checking Server Extensions service running
Writing administrator login to local machine information..
Setting up ActiveDirectory authentication..
Failed to fetch user: Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.
Failed to fetch user: Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.
System.Data.SqlClient.SqlException: Login failed. The login is from an untrusted domain and cannot be used with Windows authentication.
   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
   at System.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK)
   at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
   at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
   at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
   at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
   at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
   at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
   at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
   at System.Data.SqlClient.SqlConnection.Open()
   at Symantec.Workflow.Installer.Core.MSSQL.MSSQLDataProvider.GetConnection(Boolean onDatabase, Boolean withTimeout)
   at Symantec.Workflow.Installer.Core.MSSQL.MSSQLDataProvider.Execute(String sql, Boolean keepConnectionOpen, Boolean onDatabase)
   at Symantec.Workflow.Installer.Core.MSSQL.MSSQLDataProvider.Execute(String sql)
   at Symantec.Workflow.Installer.Strategy.AuthenticationStrategy.CreateDomainAdminUser(ActiveDirectoryServer server)
   at Symantec.Workflow.Installer.Strategy.AuthenticationStrategy.Execute()
   at Symantec.Workflow.Installer.WizardPages.AuthenticationPage.Run()
   at Symantec.Workflow.Installer.InstallerManager.Run()
Installation Failed.

01-21-2011 03:15 PM

I clicked on Default Web Site>Basic settings (test settings was failing). Clicked connect as and added specific user. If Symantec really want to launch a stable product then they have to work with us so that we can test and report all the bugs. How can you even relase a Beta version when there are so many issues. I am not sure we will get a stable ITMS 71 in March ?????

Thanks,

Jimmy

 

 

   

01-21-2011 02:03 PM

I was able to sucessfully install ITMS 71 using registry hacks as I was running into ASP.NET error.

  • Create a DWord called IgnoreInstallPrerequisites and set the value to 1 under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM.
  • Add the key HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\AIM\InstallReadinessCheck\
    to the registry. Create a DWord called EnableNextbutton and set the value
     to 1.

When I launch the console I am keep getting "Attention required". It appears IIS related issues. Has anyone sucessfully installed ITMS 71 following their instructions ??? I tried calling technical support and the guy was not even aware of the fact that ITMS 71 beta is out.

 

 

01-17-2011 03:09 PM

The AMTredirection service runs under the context of the local system account.   If attempting to access a network path (i.e. UNC like \\server\share), either provide read access to EVERYONE or change the logon account of the amtredirection service

01-17-2011 02:25 PM

Mistake on my part - was attempting to use an UNC path.   Apparently the file permissions were not correct for the application.   Need "Read" access.

ISO images can be accessed via local drive (i.e. c:\ider) or UNC path.   Mapped network drive is not supported

If attempting to use a large ISO image - This points to the value of a 2-stage IDE-Redirect boot such as described at http://communities.intel.com/docs/DOC-5552.    This was the approach taken with the Symantec EndPoint Recovery Tool optimization described at http://www.symantec.com/connect/articles/optimizing-sert-intel-vpro-technology

01-07-2011 04:25 AM

There is not going to be a round 2.

The general feeling before the beta started was that the code-base was pretty much there, so no  beta refreshes were anticipated. The code isn't frozen though -the teams are still using the time to polish up the code and address issues already raised. But enhancements not already accepted will likely be shifted to a later release.

Kind Regards,
Ian./

01-06-2011 10:33 PM

Is the code frozen yet? Is there going to be a beta round 2?

12-31-2010 07:04 AM

March 2011 is what I've been told too.

12-31-2010 07:01 AM

I completely agree. This root is a  bit of a mess now, and seeing lots of other tasks filed away nicely, does make me feel that the Altiris stuff should be filed likewise.

12-29-2010 05:36 PM

March 2011.  at least, that's what i keep seeing/hearing around the interwebz... :)

12-29-2010 02:36 PM

Does anyone know when the full version of NS 7.1 is supposed show up?

12-28-2010 01:59 PM

VMware vSphere 4.0 Update 2, VM hardware version 7

the vm is Win srv 2008 r2 enterprise

mem 2g

64 bit Op sys

quad core AMD Opteron processor 8354 2.21 GHz (2 Processors)

 

any other info I can provide? 

12-23-2010 05:58 PM

Multiple attempts to get boot redirection session to start - no luck.   I am able to start a Remote Control and Serial-over-LAN (i.e. Display Task Progress and Remote Control Computer).   Also able to boot into BIOS.   But boot redirection with both ISO or IMG files is not working.  When attempting - get an error of "Power Management Operation Failed" in the Resource Manager

 

Screenshot below shows Altiris.PluggableProtocols.AMTRedirSvcTypeLibrary.zip version

12-14-2010 03:02 PM

I was able to run NSConfigurator in edit mode by launching cmd as administrator and then going to the tools folder to execute.  Hope this helps.

12-13-2010 04:32 PM

This is a great idea David. Have you added it as an idea so people can vote on it?

12-12-2010 06:35 PM

It may seem like a small thing. But, since the new Windows Server Task Scheduler in Server 2008 R2 is orders of magnitude more awesome than the one we have had to deal with all these years. I think we need to move the NS 7.1 lengthy list of scheduled tasks from the ROOT of the task scheduler to its own folder "Altiris" and then divide it up into sub folders if appropriate based on related functions. 

12-12-2010 05:12 PM

Can you issue a new license .zip with a later expiration date?  I don't know about everyone else, but I am getting some holiday vacation which will give me some time to beta test....right now a lot of the licenses in .zip license pack I just downloaded are expired.

12-02-2010 03:34 PM

I am new to Server 2008 R2 and I also encountered this problem. For now I have moved the files to a less protected folder and can execute nsconfigurator just fine.  I will be interested in learnign how to change the security on these folders as I may need to run AexConfig, etc in the future....

12-02-2010 12:29 PM

I had installed 7.1 and it was functional, now I am getting the below error message. When I try to run NSConfigurator I am unable to do it because it's installed under C:\Program Files\Altiris\etc. . .  instead of C:\Program Files (x86).

 

Thoughts???

Symantec Management Server Error

An error has occurred that prevents the Symantec Management Console displaying correctly.

If this page is shown in place of a page or web part in the Symantec Management Console, navigate back to the page using the menu or tree and continue working. If the problem persists, see your local network administrator.

If this page is shown in place of the Symantec Management Console, one of the following could be the cause:

The "Altiris Service" service is not running. Start this service on the server and reload the console.

The account used for either the "Altiris Service" or the Notification Server webs is incorrect, disabled or the password for the account has expired. On the Notification Server computer, run "C:\Program Files\Altiris\Notification Server\bin\AeXConfig.exe /svcid user:(user name) password:(password)]", substituting the correct installation path if a non-default location was used, to provide a new account.

The name of the Notification Server computer has been renamed. The following steps will need to be taken to correct this:

If SQL Server is installed on the same machine as the Notification Server:

In case of SQL Server 2005 visit this link How to: Rename a Computer that Hosts a Stand-Alone Instance of SQL Server.

In case of SQL Server 2008 visit this link How to: Rename a Computer that Hosts a Stand-Alone Instance of SQL Server.

Open the file [NS INSTALL DIRECTORY]\Notification Server\Config\CoreSettings.config, search for the word 'key=DBServer'. Replace the 'value' attribute of the found XML element from the previous server name to the new server name.

If account used for either the "Altiris Service" or the Notification Server webs is a local user (i.e. Not a domain user), you will need to update the account to the new name. You can do so by following the 2nd bullet points on this page.

Open Registry Editor, browse to the registry key "HKLM\SOFTWARE\Altiris\express\Notification Server\". Find and replace any value that contains the old server name with the new name.

Re-push the agent out to all previously managed machines. (#)

Run the Windows schedule named "NS.Package Refresh" to re-validate site/package server packages. To get to the Windows schedules, go to 'Start' > 'Control Panel' > 'Scheduled Tasks'.

If you have hierarchy set up, you will need to remove and re-add the renamed server to the hierarchy. To do so, go to the "Hierarchy Management" page under the menu "Settings" > "Notification Server" > "Hierarchy".

In both cases, the Symantec Management Server log and the Windows Event log may contain useful information. The Symantec Management Server log can be accessed on the server by running "Start" menu > "All Programs" > "Altiris" > "Diagnostics" > "Altiris Log Viewer".

(#) If the NS hosted computer has yet been renamed, a better alternative would be to point all NS clients to the new server name first. You can do this by going to the menu "Settings" > "Agents/Plug-ins" > "Targeted Agent Settings". For each policy in the list, select the "Advanced" tab and specifies the new server name under the "Alternative URL for accessing NS" section. By doing this, all the clients will work automatically once the NS server has been renamed.

 

12-02-2010 11:33 AM

I went ahead and tried the installation again this morning.  The installation failed again.  Attached are two screenshots of the errors received.  The first one occured in the middle of installation, the second one occured immediately after I clicked on OK.  The installation went from 52% to 100% instantly.

12-01-2010 05:49 PM

Ok, I followed your instructions and have come to the Readiness Check page in SIM.  Attached is a screenshot of SIM before I try to continue with installation.

I had to build an entirely new 2008R2 VM due to a bad snapshot of my earlier setup, but that's ok, as I wanted to start completely fresh anyway.  I am going to wait for your reply before continuing the install.

Just FYI, when setting up IIS, there was still no option called IIS 6 Compatability Mode in the Role Services when I manually selected each item to be included.  It looked exactly the same as it did in the screenshot I sent you earlier today.

Also note, when choosing the Role Services for Application Server, when selecting TCP Activation under Windows Process Activation Service Support, it automatically chooses TCP Port Sharing as a requirement/dependency, so my selections are different from yours in that respect.

12-01-2010 01:29 PM

This is a known issue.  But here is what you could try.  Re-install the OS or take it back to a clean unconfigured state if you are using a VM.  Reinstall all the role services that are shown in the screenshots.  The first one is for Web Server, the second is for application server.  Then you need to set the default website to use the .NET classic AppPool, and create a self signed certificate.  Then install SIM and run the install rediness checks.  If it says things need to be corrected, do not click to fix anything.  Send me a screenshot of the errors.  Then we will decide where to go from there.  Thanks!

12-01-2010 09:13 AM

Here is a screenshot of the ASP.Net error I am getting when I try to run the installation to fix the problem.

12-01-2010 09:05 AM

Attached is the screenshot you requested.  Thanks for the assitance.

12-01-2010 08:36 AM

I successfully installed it on a Server 2008 R2 OS that I have loaded on VMWare Workstation.

11-30-2010 05:53 PM

will you please send me a screenshot of all your installed IIS role services?  Thanks!

11-30-2010 05:21 PM

When I go to Role Services, I do not see IIS 6 Compatability Mode as an available option.  The closest thing to it is IIS 6 Management Compatability, which is installed, but obviously that isn't what I'm looking for.  Is there something I missed when I set up IIS services to begin with?

ASP.NET error details:

IMS says I am lacking a minimum requirement for ASP.NET, the reported error is "Microsoft IIS 6 Compatability Mode must be enabled" and under Current System to the right it says "Microsoft IIS 6 Compatability Mode is not enabled".

 

Thanks for the quick reply!

11-30-2010 04:45 PM

Cantatta,

To enable IIS 6 compatibility mode, just enter the server manager under administrative tools.  In the left hand column expand "Roles"and click on Web Server (IIS).  On the right hand side scroll down until you see "Role Services".  Click Add role services and select IIs 6 compatibility mode.  Verify that is enabled.  I beleive this would also get rid of the asp.net error.  If you still have it please give more details on the asp.net errors. Thanks!

11-30-2010 04:37 PM

Which hypervisor are you using?  ESX, ESXi, Hyper-V?  Which version?  We check the registry for CPU info, and if it is not there, then we use a WMI query to get the info.  Then, we use ProcInfo.dll to get core count and some other bits.  Any more detailed info you can give us would be great...

11-30-2010 04:30 PM

Hello,

 

I have successfully installed ITMS7.1 on a Hyper-V virtual server (2008r2).  However, after the installation completes, I receive the error that configuration failed.  It seems that IIS 6 Compatability Mode is not enabled for ASP.NET, and I cannot figure out how to enable it so that configuration can continue.  I found this out by running the installtion a second time per the IMS recommendation after configuration failed.  2nd time through, readiness check fails, reporting problem with ASP.NET and IIS 6 compatability mode.

Can anyone help with this problem?

11-30-2010 03:41 PM

Has anyone tried installing on a VM server?  I cant seem to get past the readiness check for

CPU_new install Readiness Check. Everything else checks out ok, and trust me there is more than enough power for this vm.  I've got 4 CPU's assigned.

I've added the registry entries that allow me to bypass the check and install any but it errors out with "There was an error"

That's it.  there is nothing in the logs other than "there was an error"  quiting install. 

Suggestions?

11-25-2010 05:45 PM

March 2011 seems to be the general consensus.

11-25-2010 11:49 AM

Hello, is there any RTM dates yet?  I am currently setting up a Svr 2008x64 and read moving from 7.0 to 7.1 may not be possible?  Comments?

11-25-2010 11:37 AM

We have similar problem on some computers with Windows Vista and on all with Windows 7. I noticed with one computer (Windows Vista) that error was on standard admin account. When I logged as domain account (also with with admin rights admin) instalationthen  complet successful. I think it could be somthing with user rights. The message says there was error with files coping and it appears after instaler (a used standaolne instaler with additional parameters) finish unpacking files to temp folder.

11-25-2010 07:35 AM

Any ideas when the beta ends and the status goes to RTM/Final ?

11-25-2010 07:22 AM

Hi Susan,

Are you guys planning to release a Beta Refresh soon, I have noticed a few posts where it appears fixes are available in the latest code?

Thanks

Mark.

11-24-2010 04:56 AM

hi

i am trying to altiris 7.1 beta agent on windos 7 platform but show error

11-19-2010 01:48 AM

hi

 

after enabling the feature still it give same error to install role management tool

11-18-2010 10:37 AM

Interesting -I thought I was able to setup IIS without enabling the .NET 3.5.1 feature.

Have you installed the beta SIM yet? This will automatically enable the .NET 3.5SP1 feature for you, or you can alternatively enable this through Server Manager yourself.

 

 

11-18-2010 05:51 AM

Hi

I am installing windows server 2008 x64 R2 for Altiris Beta 7.1

when i am trying to install IIS it showing IIS install successfull but giving error

Please see the attachment

 

11-17-2010 05:18 AM

hi

 

I Install Altiris 7.1 Beta Server successfully.

Can i install ServiceDesk 7.1 on the same server

 

reply anybody urgently

11-17-2010 03:23 AM

Once the very similar problem has been reported for an attempt to apply the corrupted license file. Please check if everything fine with your license (maybe it's worth to try to apply license on different non-beta server to see if this is beta specific or not).

Thank you,

Alex.

11-17-2010 02:09 AM

You can use the following KB to manually remove the trial licenses.

http://www.symantec.com/docs/HOWTO4263

11-17-2010 02:03 AM

hi

I Successfully install Altiris 7.1 Beta. but i want to remove default license i.e 30 days license and want to install new 1000 node license.

But when i am going to remove the default license i facing the following issue and if i trying to overright the license then also its not happening still it shows 30 days default license.

please suggest how i remove default 30 days license and install my new license.

Please see the attachment while i am trying to remove license

 

 

11-15-2010 05:36 AM

Hi Steve.

 

I did the next steps:
 
1. ITMS_7_1_Beta.zip downloaded, placed to root of C and extracted.
 
2. SIM launched (by default SIM will use current global.pl, this pl does not contain the beta suites)
 
3. On “Installed Products” select “Settings” -> “Change product listing” -> “Add” -> “Browse” and select “ITMS_7_1_Beta.pl” from “c:\ ITMS_7_1_Beta” folder. Press OK in all opened dialogs.
 
4. Press “Install new products”. You should be presented with screen with four suites available for install.
 
Hope this helps,
Alex.

11-15-2010 04:42 AM

Hi,

Have you joined the Hampton 7.1 group? Once joined you can download the beta files and these contain the new product list XML file to point the Beta SIM at.

Kind Regards,
Ian./

11-15-2010 04:02 AM

Hi, Is the 7.1 beta still available?  If it is, can someone verify symantec.pl.xml as no suites are listed. 

Thanks. 

11-11-2010 12:48 AM

hi

i already tried that i.e "none" and "suiete" but it showing blank

11-10-2010 03:00 PM

no, this is the same problem i had.  it's not reading the .pl.xml file for ITMS beta.  you have to specify it rather than some web-based zip file that it's pulling that VERY limited product list from. find the settings button in the upper right in SIM, then browse to the itms beta 71 (not exact filename) .pl.xml file, and your product list will be fixed.  I assumed that should have already been in there, but we see what happens when you assume.  I also think that it took entirely too many clicks to find and select the xml file - should have just been browse, select, ok and done with it... but the process seemed almost deliberately drawn out. 

 

Once you've done this you will be able to select by suite or piecemeal.

 

FYI dlopes - setting FILTER to NONE will show you every last little piece available to you rather than JUST the suites.  This is how you would install things piecemeal - say, a standalone DS with none of the NS stuff.  All dependencies still automatically get selected, so doing it this way isn't a problem.

11-10-2010 09:31 AM

Vikasj,

 

On the top right, change the filter from "None" to "Suites".

 

Then you can choose the suites you want installed.

11-10-2010 06:45 AM

hi

i am installing Altiris 7.1 Beta but i can find any suites or solution like CMS, SMS AMS

 

How i installa that CMS or other suits

following is the attachment

 

11-09-2010 06:12 AM

can we install ServiceDesk 7.1 on the same notification server

11-08-2010 10:30 AM

I'm excited to test the beta, thanks Symantec!!!

11-05-2010 01:33 PM

I'm getting a license expired for ITA, but nothing else.

11-02-2010 01:51 AM

In the installation wizard I'm asked for the FQDN of the ServiceDesk Server. I am installing on the same box as the NS is running in a test AD environment. The FQDN I enter is valid for sure, but I keep on getting an error that the FQDN cannot be resolved. Trying to use the short name won't work either.

Using a command line and nslookup I can see my server with full details in forward and reverse lookup. Also ping of FQDN and short name to itself works just fine.

10-29-2010 04:04 AM

Hi noodleNT,

For the 3rd example you could use something similar to what i use for my SMP Agent Policy below.  I use it to check the FileSize of the configuration policy.  You could simply modify this to check for File Exists and then use a RTSM Task to stop the java instance.  The only thing i am not sure how to do remotely quite now is moving the file and delete a cache file, might be something to put into a batch file and run it remotely using a powershell script or something.

Select FileSize from CIM_LogicalFile where FileName = 'jcserver' and extension = 'xml'

Please let me know if this helps.  Please note the SMP Policy is available to download from the monitor community.

Joe,

10-28-2010 09:32 PM

So I tried using the RTSM to restart the service. When I select the task it prompts me to select a connection profile. I do, but it wont save it.

10-28-2010 07:32 AM

I will check out RTM tasks for the resets. It should do the trick for those two examples. However I have a third.
Example 3:
Check for the existence of a file. If file exist kill java instance, move file to archive folder, delete a cache file, kick off a command to restart an application.
We use something like this to monitor the health of BuisnessObjects web based reporting application on one of our servers.

10-28-2010 04:40 AM

Hi noodleNT,

Checking on this now, for example #1 above i used the agentless monitor to check for the service and if it was not running i then used a Real-Time System Manager Service Start to restart the service.  RTSM Tasks do not adhere to maintenance windows since they are performed agentless.  The task should be successful outside of a maintenance winow.

For example #2 you would need to perform the same remediation effort as #1 using RTSM Service Task to avoid maintenance windows,

Please let me know if this helps.

Kind Regards,

10-27-2010 08:54 AM

The problem is that a remediation task will not run if it is triggered outside a maintenance window. For instance here are two examples:
Example 1:
An agentless monitor is configured to make sure the Monitor Agent Service is running. If it is stopped you have a task set to run to start the service. This task will fail if triggered outside a maintenance window.
Example 2:
An agent based monitor is configured to watch available memory. If a limit is reached a service should be reset.
Now in our environment we only patch on the weekends. Since patch managent uses maintenance windows to schedule when updates install, our maintenance windows are only configured for the weekends. If one of these two events are triggered above, they will never run.
A side note: you also can't schedule Jobs (a collection of tasks) to run outside a maintenance window.

10-27-2010 05:12 AM

Hi noodleNT,

Please find screenshot below in regards to Maintenance Windows, again this does not apply to agentless tasks only monitor plug-in tasks:

10-27-2010 04:29 AM

Hi noodleNT,

Monitor Solution does adhere to maintenance windows.  Under the Monitor Solution configuration policies you will find a tab called maintenance windows.  This allows you to select what monitor does during a maintenace window, whether to continue monitoring, change alerts to informational only or to not run any tasks during the maintenance window.  Please note this is for monitor tasks only and does not apply to agentless tasks.

Please let me know if this is what you are looking for?

Kind Regards,

10-25-2010 05:20 PM

Are there any changes to Maintenance Windows? For instance, Monitor Solution tasks will be blocked if they are triggerend outside of a maintenance window. Also Jobs ( a collection of task) can not be scheduled to run outside of a maintenance window.

10-25-2010 02:22 PM

What are the system requirements.....?

This is what I found on page 22 of the  beta documentation (Altiris_IT_Management_Suite_Beta_Guide_7.1_UPDATE_18Oct2010.pdf):


During the installation process, Symantec Installation
Manager displays an Install Readiness Check page. This
page verifies that the computer meets the system
requirements. You only need to meet the minimum system
requirements that are listed on this page.


 

But to get to the 'installation process' the hardware and software has to already be in place.  Did I miss something?

10-25-2010 12:58 AM

hello noomutd,

 

Scripted OS installation both for windows and linux is there in DS beta, let me know where you are task is failing.

10-24-2010 02:54 AM

As i installed beta in windows 2008 R2 , i try to demo OS deployment feature to customer but it can't work. i check all setting is right. i don't quite sure , can it work in this beta ?

10-22-2010 12:47 PM

The ITMS build can be downloaded with the ITMS_7_1_Beta.zip file. (see the original post on this thread.)

10-22-2010 12:45 PM

The VMM License has been added in the ITMS_7_1_Beta_Licenses_VMM.zip. This file only contains the VMM license.

10-20-2010 10:31 AM

From where can i download the ITMS build?

 

Thanks.

10-19-2010 04:11 PM

Hi,

 

And about the enhancements related to Service Desk 7.1?

Is it Web Based Language (Portuguese - Brazil)?

Thanks in advance.

 

Jose Augusto

 

10-14-2010 04:45 PM

For those using the Real Time System Manager Redirection, the .dll fix for this is now available and attached as Altiris.PluggableProtocols.AMTRedirSvcTypeLibrary.zip.

 

Here's the information from the "Known Issues" doc and how to apply this fix:

Real-Time System Manager : The redirection functionality is blocked.
To resolve this, do the following:
1. Download .zip from the 7.1 Beta Symantec Connect page.
2. Extract the "Altiris.PluggableProtocols.AMTRedirSvcTypeLibrary.dll" file.
3. Copy the file to the "C:\windows\assembly" folder.
4. Run "iisreset" command in command line.

10-14-2010 01:02 AM

Good News, support for 64bit Servers is available.

Related Entries and Links

No Related Resource entered.