Deployment Solution

 View Only
  • 1.  Deploying image (No boot Device Found issues)

    Posted Dec 08, 2017 11:02 AM

    I'm having issues deploying an image to another computer. I can prepare the image to be copy that works. Then I can copy the image with no issues. Then I can deploy that image to another computer which is the same model computer and it deploys 100 percent with no errors. Restart the computer and Im getting No boot device found. I can do a diskpart and see that the hard drive has been imaged but for some reason the device won't boot. Any suggestion on what can be the issues here  PS all my other images that worked in the past are not working as well.

    Thank you for your time



  • 2.  RE: Deploying image (No boot Device Found issues)

    Posted Dec 09, 2017 01:38 AM

    Hey Paul,

    This can happen if you are deploying a legacy bios image to a uefi system and it can also happen if the image was created from a uefi system and it is being deployed to a legacy bios system.  It can also occur if your system's bios values were changed recently.

    Here is are a couple of examples:

    • System comes from the factory configured for UEFI but somewhere along the way someone changed the BIOS/EFI to legacy and the way your image was created does not match this configuration.
       
    • System comes configured from the factory in hybrid mode - where it will successfully boot to legacy or UEFI, but someone changed the BIOS to be legacy or uefi explicitly and the way your image was created does not match this configuration.
       
    • System was configured purposely to legacy bios mode for ease of deployment and someone reset the factory defaults in the bios causing the system to revert to UEFI mode and the way your image was created does not match this configuration.

    If none of these sound correct, your problem could be related to the boot partition.

    When installing windows from OEM/Retail media, Windows 7 and newer operating systems create at least 2 partitions by default. 

    • For a legacy/BIOS system, you have a System partition where the boot files reside (usually around 100mb) and then you have the Operating System partition.
       
    • For a UEFI system, you have several partitions that are required for booting - namely a system partition (usually 100mb), an MSR partition, and then you have the Operating System partition. 
       
    • You may also have some extra partitions that are not exactly required for the purposes of booting to Windows, but they serve other purposes such as recovery partitions, etc.

    The critical part here is that in order for the UEFI system to boot to Windows,you have a couple of hard requirements. 

    • The first is that the partition table must be GPT and NOT MBR
       
    • The second critical requirement is that the system partition must be formated as FAT32

    These two requirements are critical for UEFI Systems and are NOT the required with legacy/BIOS systems. 

    If for some reason your image contains an NTFS formated system partition, it will never work on a UEFI based system running in UEFI mode.

    By the same token if you deploy an image created on a UEFI system to a legacy/BIOS system it will also NEVER work.

    Finally, one oddball possibility would be systems that are architecture specific. You can NOT deploy a 64-Bit Operating System to a system that only runs 32-Bit code.  And in some cases the BIOS/EFI on such systems are locked preventing you from disabling UEFI mode which is the case on the two systems listed below.

    • An example of a 32-Bit UEFI only device is the HP ElitePad 900 G1
       
    • An example of a 64-Bit UEFI only device is the Microsoft Surface Pro 3/4

    The aformentioned systems could never run any NON-UEFI based operating system such as Windows 7 or older because you can't turn off UEFI as it is locked.

     

    If this solves your issue, kindly mark this as a solution.  Thanks :)

     



  • 3.  RE: Deploying image (No boot Device Found issues)

    Broadcom Employee
    Posted Dec 12, 2017 07:02 AM
    A System Deployment Image is a file format used primarily with Microsoft products to contain an arbitrary disk image, including boot sector information. 
     
     
     


  • 4.  RE: Deploying image (No boot Device Found issues)

    Posted Dec 12, 2017 10:51 AM

    I had this before with a one off model (XPS 9365).  Fix for me was I had to go to had to go to bios - sata settings - enable AHCI mode.  The image worked on our standard Latitude/Optiplex computers otherwise.



  • 5.  RE: Deploying image (No boot Device Found issues)

    Posted Dec 13, 2017 03:29 PM

    Hello Joel

    I got the image to deploy for the GPT format. My next question is their a way to image MBR format or does it only do GPT hard drives. Reason I'm asking that because we use safeguard for are laptops and safeguard has to use MBR formats only.



  • 6.  RE: Deploying image (No boot Device Found issues)

    Posted Dec 13, 2017 06:08 PM

    Hey Paul,

    This depends on how the target system is configured in the BIOS.  General best practice for building images is to build them on a Virtual Machine. If you configure the target system in legacy BIOS mode , install windows from the iso, customize it, and capture the image.... you will have an MBR image ready to deploy to other MBR systems.  As I have stated before, this image will not work for UEFI systems.

    Now, if you have created an image of a system running in UEFI mode, it will only deploy successfully to other systems of similar hardware that are also running in UEFI mode.

    The way I handle imaging both BIOS and UEFI systems in my environment, is that I create a legacy BIOS (MBR) Virtual Machine, install windows from the iso, customize, and capture the image.  Later if I need to deploy that same MBR image to a UEFI system, I do that with logic scripting.  This way I don't have to maintain 2 separate images.  Back when I developed this, Ghost version 11.XX did not support UEFI imaging natively.  I think its supported natively now....but it depends on how the system is running when you capture the image.

    Based on your original post, I am assuming you are not building images on Virtual Machines, so this also makes it a little harder to troubleshoot.  For Virtual Machines running in Hyper-V, you can just select Generation 1 which is a legacy BIOS Virtual Machine only.  Since you are working on physical systems, you will have to determine if the system can actually run in legacy BIOS mode.

    As far as your question about wanting the image to work on MBR, just make sure the system you are trying to image supports legacy BIOS mode.  I guess one way you can check that would be to go in the bios, see if you can turn off/disable UEFI mode, turn off/disable SECURE BOOT, and try booting to legacy media such as WinPE 2 / 3 / or 3.1 which is legacy only.  If the device boots to these older WinPE enviorments, that means you can install Windows in MBR mode.  The reason I don't suggest WinPE 4 / 5 / 5.1 / or 10 is that all the newer WinPEs will boot up whether the system is in BIOS or UEFI mode.  This makes it a little more confusing because it will be harder to tell what mode you are actually running in.  If you are not comfortable creating different WinPE media, you can just use Windows 7 installation media/iso to determine if the system boots to legacy BIOS mode.  If the system boots to Windows 7 installation media, you will be able to install windows in legacy BIOS (MBR) mode.

    If you are unable to turn off/disable UEFI mode or Secure Boot in the BIOS/EFI, you could have a system like I mentioned in my previous post that are locked to UEFI mode, Examples of this are again the Surface Pro 3/4, or ElitePad 900s.  Obviously there are many other systems like this and you could possibly have one.

    Once you have established that the system does in fact boot to Windows/WinPE running in legacy BIOS mode, you can install Windows 10 or whatever Operating System you intend to deploy and the partition structure will be MBR.  Then you will be sure that your Safeguard software that requires MBR will work correctly.  

    Sorry for the long reply, this stuff can get pretty confusing.

    If this solves your issue, kindly mark this as a solution.  Thanks :)