Deployment Solution

 View Only
  • 1.  DISM Driver Injection Not Working

    Broadcom Employee
    Posted Jun 17, 2014 05:26 PM
      |   view attached

    Hi everyone,

    I'm having issues with DISM driver injection. I'm using DS 6.9 SP5 to deploy the following tasks

    1. Deploy base OS - Deploys Windows 7 SP1 via a .img file
    2. Stage PnP drivers - Copies drivers from a network share to to C:\Windows\Temp
    3. Install Drivers - Executes "z:\Deployment_Resources\tools\dism\dism.exe /Image:C: /Add-Driver /Driver:C:\windows\temp /recurse /LogPath:"f:\TEMP\%ID%_DISM.LOG /LogLevel:2"

    All 3 tasks are run from WinPE.

    This process has worked in the past but since updating the base image it is failing. The changes include SP1 and all recent updates and Office 2020.

    The drivers are definitely copied to C:\Windows\Temp and the DISM injection process reports that each available driver is installed succesfuly but when Windows loads none of the deivces are installed. If I manually update the drivers for those devices and point the process to C:\Windows\Temp the drivers are installed succesfullly.  The drivers are even available in %systemroot%\inf

    Am I missing something in the configuration of the new base image or sysprep? I can't work out what the gap is.

    I've tried creating brand new images but I am getting the same result. I've tried Windows 7 with and without SP1.

    DISM logs are attached.

    Thanks,

    Grant

    Attachment(s)

    txt
    DISM.txt   294 KB 1 version


  • 2.  RE: DISM Driver Injection Not Working

    Posted Jun 17, 2014 06:25 PM

    You need to look in logs in either:

    • c:\windows (setupact.log?)
    • c:\windows\panther
    • c:\windows\system32\sysprep\

    to see why Windows is ignoring the drivers it knows are there as it runs through sysprep and setup. Or look for any setupact.log files or setuperr.log files in C:\windows.
     



  • 3.  RE: DISM Driver Injection Not Working

    Posted Jun 20, 2014 09:12 AM

    Hey GrantXTech,

    Looks like the DISM string has inconsistencies in it...I assume it is failing to write the log file because based on the string it looks like the network share is mapping to Z: but your output log looks like its trying to write to F: which i assume is invalid.  If this is infact your issue the string should look like this if your driver letter in winpe is mapped as Z:

    "Z:\Deployment_Resources\tools\dism\dism.exe /Image:C: /Add-Driver /Driver:C:\windows\temp /recurse /LogPath:"Z:\TEMP\%ID%_DISM.LOG /LogLevel:2"

    of if it is mapped as F:

    "F:\Deployment_Resources\tools\dism\dism.exe /Image:C: /Add-Driver /Driver:C:\windows\temp /recurse /LogPath:"F:\TEMP\%ID%_DISM.LOG /LogLevel:2"

    To avoid this altogether use the altiris token %ALTIRIS_SHARE% which will resolve to the letter no matter what it is mapped as... so you will never have to worry about it no matter how the server is configured so the string should look like this...

    "%ALTIRIS_SHARE%\Deployment_Resources\tools\dism\dism.exe /Image:C: /Add-Driver /Driver:C:\windows\temp /recurse /LogPath:"%ALTIRIS_SHARE%\TEMP\%ID%_DISM.LOG /LogLevel:2"

    hope this helps... :)