Ghost Solution Suite

 View Only
  • 1.  Ghost error Write Sector Failure on restore

    Broadcom Employee
    Posted Aug 15, 2006 01:31 PM
    I have GSS 1.1 running on a server, PXE & DHCP set up to allow network boot and all works well for my dell Optiplex SX-270 desktops. i have created an XP image & restored it to this box and all works great. I tried restoring the same image to an SX-280 and I get:

    Error 29005, Write Sector failure, result=1,drive=0, sector xxxxxxx to xxxxxx.
    If this problem persists, contact Symantec.

    I get this error even before the image loads. Looking at the bottom of the screen, it looks like ghost is trying to restore the NTFS MFT, but can't, and then this error pops up.

    I thought maybe it was an incompatible image, so I built a new system on the SX-280, made an image and tried to restore, but I get the same error.

    Only big difference I can think of is that the SX-270 uses IDE drives, and the SX-280 uses SATA drives. I checked knowledge base, and it gave about 7 or 8 switches to try. I tried them all, and they had no effect. it still can't get past the NTFS MFT first step of the restore.

    My ghost server is running on a Win2k3 system, the images are WinXP. Im using PXE & DHCP and all that works. I updated the bios onthe SX-280 to see if that helped, and it didn't.

    Any ideas?

    Thanx


  • 2.  RE: Ghost error Write Sector Failure on restore

    Broadcom Employee
    Posted Aug 16, 2006 08:55 PM
    The presence of the SATA disk suggests that this could be an interrupt conflict between the SATA disk and the network controller.

    To start off with I'd suggest that you take a look at the pxe image being used. For 3Com images there is an option to "Keep base code" loaded after the network boot. I'd recommend turning this option off for newer systems - for some older PCs this option has to be enabled for the PXE universal network driver to be available after the network boot. To check for this setting in a 3Com image, edit the image, click on properties and then 'change'. The "Keep UNDI" should be enabled and the "Keep Base" disabled.

    Another question on your setup though is whether you are using the Univesal packet driver or the specific network driver for your system? If you're not using the Universal packet driver I'd suggest trying it in you're pxe images as it tends to handle interrupt conflict situations well.

    Regards, Robert.