Deployment Solution

reboot loop problem after image

  • 1.  reboot loop problem after image

    Posted 09-09-2020 09:25 PM
    Hello All,

    I am pretty sure this is my first time posting, I maybe posted once when GSS was a Symantec product.  In any case.  

    A quick background, I come from many lessons of bad habits.  When I first started I was using DS 6.9 Update 7, which I believe was the last in the series.  It was wildly out of support and most of the things I did were self-taught by trial and error.  Seemed like we were always putting a band-aid on things.  Never just a solid image that worked.  

    A couple years ago we finally switched to GSS.  My bad habits continued because I had no real training and wasn't 100% sure what I was doing but I started getting more consistent images.  A few months ago I found a video series on YouTube that was a TON of help!  On Point Drone Works <---- This is a link to his page.

    Start reading here if you don't care about back story!! Haha
    Anyway, I have run into an issue. I have built my image on a VM and when I roll it back to a VM it works fine runs the whole way through.  When I run it to a physical PC, after the image lays down and the computer begins booting for the first time I get an error.  "The computer restarted unexpectedly or encountered an unexpected error".  A simple fix for this, you can find all over the internet is to launch the registry and change the value of HKLM\System\Setup\Status\ChildCompletion\setup.exe from a 1 to a 3. After the image finished fine. 

    It really isn't the most efficient way of imaging to have to change this setting to complete every image.  I have tried a couple of troubleshooting steps and have had really no luck.  I tried to explore the image with Ghost Explorer, but every time I try to open the image Ghost Explorer closes.  I went back to the VM that I used to create the image and the value is a 3.  Next, I went to my test VM the value of setup.exe is a 3.  So this situation only occurs when I roll the image to a physical machine.

    One thing I am still doing that is my own creation, before the image starts, I have a Run Script.  Is is a DiskPart script and it just runs a to clean the drive and convert to GPT in the case of UEFI computer or MBR in the case of a legacy computer. (two separate scripts)  However, I ran them against the VM and they didn't cause this problem.