ICDx

Expand all | Collapse all

ICDX version 1.4 on RHEL 7.7

  • 1.  ICDX version 1.4 on RHEL 7.7

    Posted 11-27-2020 06:31 PM
    No login to portal only dfault guest access
    No access to rabbit mq portal

    Is there anyone in Broadcom that has any knowledge in ICDX to assist with some advice on making it work.

    already tried testing with disabling SELINUX didn't work.

    The following errors after i had to manually turn on better logging.


    1)  [notice] 74796#74796: *1 "/amqp/(.*)" does not match "/amqp", server: ~., request: "GET /amqp HTTP/1.1"
    2)  [error] 74796#74796: *1 open() "/etc/nginx/html/amqp" failed (2: No such file or directory), server: ~., request: "GET /amqp HTTP/1.1"
    3)  [error] 74796#74796: *1 open() "/opt/symantec/icdx/portal_dx/favicon.ico" failed (2: No such file or directory) request: "GET /favicon.ico HTTP/1.1",
    4) [error] 74796#74796: *1 open() "/etc/nginx/html/v1/authentication" failed (2: No such file or directory), server: ~., request: "POST /api/v1/authentication?response_type=token HTTP/1.1"


    NI have no idea why either the installer is broken and missing these files OR something is blocking these files from being written which is lost on me since the install logs have no mention about these being blocked or skipped.


  • 2.  RE: ICDX version 1.4 on RHEL 7.7

    Posted 11-29-2020 07:48 PM
    Finally Resolved issues,

           1)  Overly Permissive controls due to our environment, Had to change umask perms as well as move data & home directory to a drive without noexec flag.



  • 3.  RE: ICDX version 1.4 on RHEL 7.7

    Broadcom Employee
    Posted 11-29-2020 10:37 PM
    This is already known to the support team. They are working on a perm. document explaining the umask and noexec. Sorry you had to figure this out on your own; holiday weekend in the US.

    ------------------------------
    Kris Gainsforth
    Solutions Engineer
    Broadcom
    ------------------------------



  • 4.  RE: ICDX version 1.4 on RHEL 7.7

    Posted 11-30-2020 12:00 AM
    Hey, do you tried check the right permission for these folders?