Data Loss Prevention

Expand all | Collapse all

Unable to connect to SMTP server

Jump to Best Answer
  • 1.  Unable to connect to SMTP server

    Posted 02-19-2019 05:03 AM

    Hi, everyone.

    I encountered the following the error "Couldn't connect to the SMTP server using the specified settings. Please re-enter the SMTP settings." when entering the SMTP setting in the General Settings on Enforce console.

    However, the settings are properly entered and I can log into Exchange OWA using the credentials. I am also able to telnet to the SMTP server via port 25.

    FYI,

    Server: 172.27.10.75

    System Email: dlp.mail@example.com

    User ID: example\dlp.mail

    Password: ********

     

    I need urgent solution on this.



  • 2.  RE: Unable to connect to SMTP server
    Best Answer

    Posted 02-20-2019 01:22 AM

    Hi Pan Fei,

    What is the DLP version on which you are facing this issue ? Also share the OS details for Enforce and SMTP (Detection server ).

    If it's 15.1 , We will need to follow below :

    Stop all DLP Services on Enforce Box

     

    On the 15.1 Enforce install, remove both mail-1.4.7.jar and javax.mail1.6.0 jar from the following directories:

     

    <DLP_home>\Server Platform Common\15.1\Protect\lib\jar

    <DLP_home>\Enforce Server\15.1\Protect\tomcat\lib

     

    Place the mail.jar in the below location

    <DLP_home>\Server Platform Common\15.1\Protect\lib\jar

    <DLP_home>\Enforce Server\15.1\Protect\tomcat\lib

     

    Start all the DLP Services on Enforce Box

     

     

     

     



  • 3.  RE: Unable to connect to SMTP server

    Posted 04-03-2020 12:22 PM
    Hello Ridhi,

    I am seeing the same issue in 15.5 would you know if its the same fix? Where can I locate the needed replacement files, I reached out to support but, still waiting for any response.

    Thanks for any direction, hoping the files are available to download from somewhere within my account

    ------------------------------
    Praxair| Inc.
    ------------------------------



  • 4.  RE: Unable to connect to SMTP server

    Posted 02-20-2019 01:26 AM

    Hi Pan,

    I missed to attach the relevant files , i will attach them in a while .

     

    Regards

    Ridhi Singh



  • 5.  RE: Unable to connect to SMTP server

    Posted 02-20-2019 10:00 AM

    Hi, Ridhi.

     

    I have contacted the Technical Support and they have provided me with the files and steps necessary. They mentioned the same steps and I managed to resolve the issue.



  • 6.  RE: Unable to connect to SMTP server

    Posted 02-20-2019 03:33 PM

    Hi Pan,

    Thank you for confirming that you were able to get it fixed with the steps provided.

    Have a good day ahead.

     

    Regards

    Ridhi Singh



  • 7.  RE: Unable to connect to SMTP server

    Posted 01-13-2021 05:38 AM
    Hi Guys ,

    i have the same problem with version 15.7 MP1 , can anyone pass me these files , i have contacted the support 4 weeks ago and  i didnt get any response yet


    Thanks


    ------------------------------
    Fady Azab
    Senior Consultant
    CCIT GMBH
    ------------------------------



  • 8.  RE: Unable to connect to SMTP server

    Broadcom Employee
    Posted 01-13-2021 03:34 PM
    Hello Fady,

      As of version 15.0, Symantec Data Loss Prevention no longer supports anonymous logins to the SMTP server that is used for sending out alerts and reports. You must enter a valid user name and password.

    Trying to upload mail.jar file but it is not uploading here.




  • 9.  RE: Unable to connect to SMTP server

    Posted 01-13-2021 04:09 PM
    hi
    could you please send it to by mail
    fady.azab@cc-it.de

    ------------------------------
    Fady Azab
    Senior Consultant
    CCIT GMBH
    ------------------------------



  • 10.  RE: Unable to connect to SMTP server

    Broadcom Employee
    Posted 05-07-2021 03:39 PM
    Hi - the solution given above (replacing JAR files) is actually no longer valid.
    There was in fact an issue with Java Mail JARs in 15.1 era, but it turns out that was a Java issue where they were updating protocols (for security reasons).

    As it turns out, not only is DLP v15.1 End of Service, but the actual solution is to simply require Authentication at your SMTP server (as indicated by Vibu in above comment).

    This is noted in the 15.7 Release Notes, under "Known Issues":

    Issue = 4231954

    Description = As of version 15.0, Symantec Data Loss Prevention no
    longer supports anonymous logins to the SMTP server that
    is used for sending out alerts and reports. You must enter
    a valid user name and password.

    Workaround = Don't use anonymous login to the SMTP server that you
    use to send out alerts and reports.

    Hopefully this is helpful! Please contact Support if more assistance is needed.

    ------------------------------
    Global Support Lead, DLP
    Broadcom, Symantec Enterprise Division
    ------------------------------