Data Loss Prevention

 View Only
  • 1.  Symantec DLP Agents backward compatibility

    Posted Jan 05, 2022 01:19 PM

    Hi team

    I have an urgent request to deploy an DLP Mac agent on a Mac system running macOS 10.14.6. However, since our Enforce and Endpoint Servers are currently running DLP '15.0100.01063' and macOS 10.14.6 is support for DLP Agents 15.7x (higher). 

    1) Can you please advise, what would be best short term options in order to deploy and DLP Agent 15.7  on a macOS 10.14.6 Mac system. Enforce and Endpoint Servers are 15.0100

    2) Are DLP Agents backward compatible ?. Meaning if I generate a DLP Agent 15.7 (Mac) package on an older Enforce Server (15.0.100). Will an DLP Agent 15.7 fully function and successfully report/communicate to an older Enforce DLP Server version ?

    I appreciate your assistance in this matter.



  • 2.  RE: Symantec DLP Agents backward compatibility

    Posted Jan 06, 2022 01:46 AM
    Hi Satya,

    Please go through this KB article

    https://knowledge.broadcom.com/external/article/164811/does-symantec-support-endpoint-agents-on.html

    BR
    Atif


  • 3.  RE: Symantec DLP Agents backward compatibility

    Broadcom Employee
    Posted Jan 06, 2022 08:33 AM
    Hello Satya,

    Newer agent versions are not supported on older Enforce versions.
    That is, 15.7 agents are not supported on 15.0 Enforce servers.

    You really only have one option to support macOS 10.14.6.
    Upgrade Enforce, all Detection servers, and the Mac agents to a version that supports macOS 10.14.6.
    Since the only supported versions of DLP are 15.7 and higher, you should upgrade to at least 15.7.

    David Spoons
    Designated Support Engineer
    Broadcom - Symantec Enterprise Division (SED)


    office: 385.421.2600  |  mobile: 801.310.1295 
    Office hours: 0700 to 1600 hours Mountain Time.
    25 E. Scenic Point Dr., Draper, Utah 84020-6128

    david.spoons@broadcom.com  |   broadcom.com





    This electronic communication and the information and any files transmitted with it, or attached to it, are confidential and are intended solely for the use of the individual or entity to whom it is addressed and may contain information that is confidential, legally privileged, protected by privacy laws, or otherwise restricted from disclosure to anyone else. If you are not the intended recipient or the person responsible for delivering the e-mail to the intended recipient, you are hereby notified that any use, copying, distributing, dissemination, forwarding, printing, or copying of this e-mail is strictly prohibited. If you received this e-mail in error, please return the e-mail to the sender, delete it from your computer, and destroy any printed copy of it.





  • 4.  RE: Symantec DLP Agents backward compatibility

    Posted Feb 21, 2022 08:36 AM
    Edited by Grzegorz Wierzbicki Feb 21, 2022 08:37 AM
    Dear David

    There was a page where I could check compatibility matrix for Symantec DLP. I searched whole Internet to find it but failed... Is there such a document still out there?  I am aware that for instance 15.7 does not support 15.1 agents, but I would like to have "official" confirmation via web page. If one exist... :D

    I am interested in all versions backward compatibility.

    thanks in advance!


  • 5.  RE: Symantec DLP Agents backward compatibility

    Broadcom Employee
    Posted Feb 22, 2022 10:03 AM
      |   view attached
    Grzegorz,

    Hello again.

    Agent compatibility information is included in the DLP upgrade guides.
    You can find those guides in these links:



    Also, review the System Requirements and Compatibility Guides in those same links.

    This KB also points you to the upgrade guides.

    Does Symantec Support Endpoint Agents on Newer Versions than the Enforce/Endpoint Server?


    And I have attached a file showing older version agent compatibility.
    This chart was never updated and is no longer available online.


    David Spoons
    Designated Support Engineer
    Broadcom - Symantec Enterprise Division (SED)






    This electronic communication and the information and any files transmitted with it, or attached to it, are confidential and are intended solely for the use of the individual or entity to whom it is addressed and may contain information that is confidential, legally privileged, protected by privacy laws, or otherwise restricted from disclosure to anyone else. If you are not the intended recipient or the person responsible for delivering the e-mail to the intended recipient, you are hereby notified that any use, copying, distributing, dissemination, forwarding, printing, or copying of this e-mail is strictly prohibited. If you received this e-mail in error, please return the e-mail to the sender, delete it from your computer, and destroy any printed copy of it.



    Attachment(s)

    xlsx
    AgentCompatibity_Old.xlsx   10 KB 1 version


  • 6.  RE: Symantec DLP Agents backward compatibility

    Posted Feb 23, 2022 03:03 AM
    David

    Thank you for your reply, the attachment info is the one I was searching for. It is a pitty that this data is no longer available online and that it was never updated. There are many companies that use Symantec DLP and I am more than sure that they can't upgrade agents at the same time as servers. That is why publicly available information about backward compatibility is so important...

    thanks again for the help!