CA OPS/MVS

Expand all | Collapse all

I am getting error message when I try to Auto-Enable a Message Rule. Please help.

Jump to Best Answer
  • 1.  I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 09:44 AM

    I am getting below error message when I try to Auto-Enable/Compile a Message Rule in OPSMVS:

     

    ENDREQ OF AOFEXEC FAILED, RC=X'00D37000'                         
    AOF COMPILE PROCESSING OF SSM.HC9999A FAILED                     
    ------------------ Return code 4 from AOF cmd COMPILE SSM.HC9999A

     

    I was able to set the AE flag till yesterday. Not sure what is causing the issue today.

    The problem is with all the rules. Can you please point me where I can check for the issue.



  • 2.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 10:03 AM

    Hello Bharath Kunda ,

    Please open a case for this problem and we will get you the help you need. Go to CA Support Online and provide the problem information. We will get you an answer. The release of your OPS/MVS product and contact information is important to finding a solution.  Also, some of our customer have been successful using a Google search to find problem related information. Our information can be located that way. Just wanted you to know.



  • 3.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.
    Best Answer

    Posted 03-23-2017 10:03 AM

    Hello Bharath,

     

    When time permits today please visit the OPSVIEW panels option 4.1.1 and look at the following parameter values:

     

    AOFPRECOMPILED

    AOFPRECOMPILEDDSN

     

    Most likely your AOFPRECOMPILED parameter value is YES and the AOFPRECOMPILEDDSN has the name of a library that contains your compiled AOF rules. Review the dataset information of the dataset and confirm if you have run out of directory space for this PDS. Proceed to maintain the library using your site standards to allow this dataset to growth in directory space.

     

    If you have problems doing this then please let us know. Situations like this could happen without a warning so it is expected for this not to work today and then produce this error the next day.

     

    Regards, Cesar



  • 4.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 10:21 AM

    D37 suggests your compiled rules dataset may be out of space. I would try to re-allocate a new one and re-compile all of your rules. You would need to bring OPSMVS down to do this.

    Good luck, Mark



  • 5.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 10:28 AM

    Thank you Kraig and Mark for participating.

     

    Bharath, when time permits look at knowledge document TEC1988424 using the following URL:

     

    https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1988424.html

     

    Even you are not seeing the error documented in this KD it gives you steps you can follow how to perform the required maintenance in the affected library. Hope this helps to plan your it and feel free to open a ticket in case you need further assistance.

     

    Regards, Cesar



  • 6.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 11:11 AM

    Thanks a lot Cesar/Mark/Kraig.
    I have dropped a mail to the Storage team. We might fix this during our next IPL.



  • 7.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 01:10 PM

    We just compressed the dataset using a job. The usage Percentage now dropped to 23%.



  • 8.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-23-2017 02:34 PM

    Excellent news.

    Were you able to auto enable the rule in question?

    Cesar



  • 9.  Re: I am getting error message when I try to Auto-Enable a Message Rule. Please help.

    Posted 03-24-2017 02:51 AM

    Yes... now i am able to auto-enable the rules.